Subject: [Dcrouting] DC Routing requirements draft

From: Jeff Tantsura <[email-masked]>
Date: Tue, 31 Oct 2017 12:15:39 -0700

All,

The authors have published DC Routing requirements draft (draft-dt-rtgwg-dcrouting-requirements) that is going to be presented at the upcoming BoF in Singapore.
Please note that EDCO group (draft-elkins-routing-brickmortar-topology) input was not included and will have a separate track.

Co-authors are looking forward to your feedback and suggestions. 

draft co-authors

---

From: Randy Bush <[email-masked]>
Date: Tue, 31 Oct 2017 19:43:53 +0000

> The authors have published DC Routing requirements draft
> (draft-dt-rtgwg-dcrouting-requirements)

usually requirements are motivated/justified; that seems to be missing.

some would note the lack of is-is and mpls, both known to be used in
data centers.  hence this is describing needs of a future protocol.  but
it reads like a laundry list meant to match a protocol product set which
is yet to be revealed.

> Please note that EDCO group
> (draft-elkins-routing-brickmortar-topology) input was not included and
> will have a separate track.

i can not find that draft.  i did find
draft-elkins-brickmortar-architecture-00.txt which, as we previously
discussed, does not seem relevant to a data center discussion.

randy

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 31 Oct 2017 13:18:15 -0700

Randy,

please see inline

Cheers,
Jeff

-----Original Message-----
From: Randy Bush <[email-masked]>
Date: Tuesday, October 31, 2017 at 12:43
To: Jeff Tantsura <[email-masked]>
Cc: <[email-masked]>
Subject: Re: [Dcrouting] DC Routing requirements draft

    usually requirements are motivated/justified; that seems to be missing.
[jeff] to come, we have just started
    
    some would note the lack of is-is and mpls, both known to be used in
    data centers.  hence this is describing needs of a future protocol.  but
    it reads like a laundry list meant to match a protocol product set which
    is yet to be revealed.
[jeff] the intention of the draft is not to call names but to identify set of requirements every proposal (new, or enhancements to an existing protocol) could be compared against in a tangible way, running beauty contest between protocols is not very productive…

    i can not find that draft.  i did find
    draft-elkins-brickmortar-architecture-00.txt which, as we previously
    discussed, does not seem relevant to a data center discussion.
[jeff] the intention here is that it will be relevant, unfortunately, the authors have missed cutoff date to upload new version (still being worked on), the draft will provide description of what it is today and set of requirements as seen by the enterprise DC’s. 
Nalini – please feel free to add your comments.
    
    randy

---

From: Tony Przygienda <[email-masked]>
Date: Tue, 31 Oct 2017 14:16:14 -0700

> it reads like a laundry list meant to match a protocol product set which
In this case IMO you're too suspicious Randy ;-)

The requirements doc leaves room for many solutions and e'one on the
discussion was mature enough to understand that we won't achieve much if we
go into the ISIS vs. OSPF vs. BGP vs. SDN positional warfare so we focused
on doing first pass of a laundry list as to what is necessary, relevant,
desirable or needed ...  Were people influenced by their experiences,
resulting preferences and scar-tissue from operating different solutions?
You bet they were. This ain't a fear-not-dream-on document by any means ;-)

So I think the doc' is pretty balanced BTW and yes, I think that there are
multiple subsets of the requirements each possibly justiying a different
engineering trade-off appealing to a customer base sae big enough to be
relevant

The BoF should be lively and then the market will tell ...

--- tony

---

From: Nalini J Elkins <[email-masked]>
Date: Tue, 31 Oct 2017 23:56:03 +0000 (UTC)

>>> Please note that EDCO group
   >>> (draft-elkins-routing-brickmortar-topology) input was not included and
   >>> will have a separate track.
    
    >>i can not find that draft.  i did find draft-elkins-brickmortar-architecture-00.txt which, as we previously
    >> discussed, does not seem relevant to a data center discussion.

    >[jeff] the intention here is that it will be relevant, unfortunately, the authors have missed cutoff date to upload new version (still being worked on), 
    >the draft will provide description of what it is today and set of requirements as seen by the enterprise DC’s. 

     >Nalini – please feel free to add your comments.

Guys, I am working on description of what our requirements are and what our data centers look like.   I will post the draft to the list as I have, unfortunately, missed the cut off for
draft submission.

The draft in its current state does not have enough about routing.  But, just in case some people are thinking that enterprises do not have data centers, I thought I might post some definitions of "data center".  I hope I have misunderstood the comment.

>From TechTarget:  http://searchdatacenter.techtarget.com/definition/data-center

"A data center (or datacenter) is a facility composed of networked computers and storage that businesses or other organizations use to organize, process, store and disseminate large amounts of data. A business typically relies heavily upon the applications, services and data contained within a data center, making it a focal point and critical asset for everyday operations."
>From Wikipedia: https://en.wikipedia.org/wiki/Data_center
"A data center is a facility used to house computer systems and associated components, such as telecommunications and storage systems. It generally includes redundant[clarification needed] or backup power supplies, redundant data communications connections, environmental controls (e.g. air conditioning, fire suppression) and various security devices. A large data center is an industrial-scale operation using as much electricity as a small town.[1][2]"
>From Gartner: https://www.gartner.com/it-glossary/data-center/
"The data center is the department in an enterprise that houses and maintains back-end information technology (IT) systems and data stores—its mainframes, servers and databases. In the days of large, centralized IT operations, this department and all the systems resided in one physical place, hence the name data center."
 
Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

________________________________
 From: Jeff Tantsura <[email-masked]>
To: Randy Bush <[email-masked]> 
Cc: [email-masked]; Nalini J Elkins <[email-masked]>
Sent: Tuesday, October 31, 2017 1:18 PM
Subject: Re: [Dcrouting] DC Routing requirements draft

Randy,

please see inline

Cheers,
Jeff

-----Original Message-----
From: Randy Bush <[email-masked]>
Date: Tuesday, October 31, 2017 at 12:43
To: Jeff Tantsura <[email-masked]>
Cc: <[email-masked]>
Subject: Re: [Dcrouting] DC Routing requirements draft

    > The authors have published DC Routing requirements draft
    > (draft-dt-rtgwg-dcrouting-requirements)

    
    > Please note that EDCO group
    > (draft-elkins-routing-brickmortar-topology) input was not included and
    > will have a separate track.

    randy

---

From: Fred Baker <[email-masked]>
Date: Wed, 1 Nov 2017 06:19:10 +0400

> On Nov 1, 2017, at 3:56 AM, Nalini J Elkins <[email-masked]> wrote:
> 

This feels like a pissing contest.

Yes, enterprises run data centers, and data center operations like Azure, Google, and Facebook run data centers. Where there are data centers, there are networking issues related to data centers. Randy, I don't understand your questioning the concept that enterprises might run their own data centers instead of or in addition to the well known public data center services.

That said, enterprises *also* run campus networks, which might be as small as the mom and pop grocery on the corner or as large as a Cisco or an IBM, with campuses and offices everywhere. I know of some enterprises whose campus networks rival in Internet itself for breadth.

The two problems are different. Nalini, I think Randy thinks you're solving the second problem and calling it the first. I think you are trying to describe both problems. But he is right in saying that they are not the same problem, and in your document you need to make the differing sets of requirements clear.

---

From: Randy Bush <[email-masked]>
Date: Wed, 01 Nov 2017 04:36:45 +0000

> Randy, I don't understand your questioning the concept that
> enterprises might run their own data centers instead of or in addition
> to the well known public data center services.

this may be because i made, or at least intended, no such assertion.

yes, enterprises sometimes have datacenters on the side.  and data
centers almost always have enterprises on the side, if only to churn out
the billing, but usually more.

> The two problems are different.

and here we agree.  though, i suspect some folk think they have a
univerdsal solvent.  as it has yet to be revealed, it is premature
to judge.

randy

---

From: Randy Bush <[email-masked]>
Date: Wed, 01 Nov 2017 05:25:50 +0000

> Guys, I am working on description of what our requirements are and
> what our data centers look like.

who is 'our'?

> But, just in case some people are thinking that enterprises do not
> have data centers

i doubt anyone questions that enterprises sometimes have datacenters.
enterprises sometimes also have printers.  this does not mean
enterprises *are* printers.

rsndy

---

From: Fred Baker <[email-masked]>
Date: Wed, 1 Nov 2017 09:31:31 +0400

> On Nov 1, 2017, at 9:25 AM, Randy Bush <[email-masked]> wrote:
> 

That may be the rub here. I doubt that enterprises that have data centers *are* data centers in either of your minds, any more than enterprises that *have* printers *are* printers. However, in the data centers that enterprises have, they may have specific requirements that don't map well to the likes of Azure or Google, but which are in fact requirements of a class of data centers.