Subject: [Dcrouting] DC ROUTING BOF at IETF100 - call for meeting topics

From: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Thu, 19 Oct 2017 12:39:28 +0000

Hi All,

Apologies for the cross posting.

Data Center Routing (DCROUTING<https://datatracker.ietf.org/wg/dcrouting/about/>) will be having a non-working-group-forming BOF during IETF100. Over the last year, there have been discussions in a number of routing area working groups about proposals aimed at routing within a data center. Because of their topologies (traditional and emerging), traffic patterns, need for fast restoration, and need for low human intervention, among other things, data centers are driving a set of routing solutions specific to them. The intent of this BOF is to discuss the special circumstances that surround routing in the data center and potential new solutions. The objective is not to select a single solution, but to determine whether there is interest and energy in the community to work on any of the proposals.

If you have a draft and would like to see it discussed during the BOF meeting, then please send the note to the BOF co-chairs and copy the [email-masked]<mailto:[email-masked]> email address.

A rough agenda overview leads to following preliminary agenda intent:

  *   Agenda bash, scribe, minute taker
  *   DC Problem Statement Intro’s (DC testimonial summaries)
  *   Solution Space Proposals
  *   Summary

To contribute and join the BOF email list:

List address: ​[email-masked]<mailto:[email-masked]>
Mailing List: ​https://www.ietf.org/mailman/listinfo/dcrouting<https://www.ietf.org/mailman/listinfo/dcrouting>
Archive: ​https://mailarchive.ietf.org/arch/search/?email_list=dcrouting<https://mailarchive.ietf.org/arch/search/?email_list=dcrouting>
To subscribe: ​https://www.ietf.org/mailman/listinfo/dcrouting<https://www.ietf.org/mailman/listinfo/dcrouting>

Kind Regards,

Victor & Gunter
co-chairs DC Routing BOF

---

From: prz <[email-masked]>
Date: Thu, 19 Oct 2017 06:37:28 -0700

On Thu, 19 Oct 2017 12:39:28 +0000, "Van De Velde, Gunter (Nokia -
BE/Antwerp)"  wrote:  

Hi All, 

DATA CENTER ROUTING (DCROUTING [1]) will be having a
non-working-group-forming BOF during IETF100. Over the last year, there
have been discussions in a number of routing area working groups about
proposals aimed at routing within a data center. Because of their
topologies (traditional and emerging), traffic patterns, need for fast
restoration, and need for low human intervention, among other things,
data centers are driving a set of routing solutions specific to them.
The intent of this BOF is to discuss the special circumstances that
surround routing in the data center and potential new solutions. The
objective is not to select a single solution, but to determine whether
there is interest and energy in the community to work on any of the
proposals.  

Hey Gunter, hey Victor,  

pls put me down on the agenda
to walk over RIFT @ level that will depend on the length of the slot you
can carve out for it in the "solution space" part, anything between
"that's the set of reqs it's tackling" to "here are some of the cool,
gory technical details". Draft been out a while and another updated
version will hit the wire before cut-off ... 

https://datatracker.ietf.org/doc/draft-przygienda-rift/

thanks much

-- tony  

Links:
------
[1]
https://datatracker.ietf.org/wg/dcrouting/about/

---

From: "Russ White" <[email-masked]>
Date: Thu, 19 Oct 2017 10:00:31 -0400

> If you have a draft and would like to see it discussed during the BOF meeting,
> then please send the note to the BOF co-chairs and copy the
> [email-masked] <mailto:[email-masked]>  email address.

Please include a slot for openfabric.

😊

Russ

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 20 Oct 2017 00:54:50 +0000

Hi Gunter & Victor,

I would like to request a 10-min slot for https://tools.ietf.org/html/draft-xu-ospf-flooding-reduction-in-msdc-01.

Best regards,
Xiaohu

发件人: Dcrouting [mailto:[email-masked]] 代表 Van De Velde, Gunter (Nokia - BE/Antwerp)
发送时间: 2017年10月19日 20:39
收件人: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
抄送: Victor Kuarsingh
主题: [Dcrouting] DC ROUTING BOF at IETF100 - call for meeting topics

Hi All,

·         Agenda bash, scribe, minute taker
·         DC Problem Statement Intro’s (DC testimonial summaries)
·         Solution Space Proposals
·         Summary

Kind Regards,

Victor & Gunter
co-chairs DC Routing BOF

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Fri, 20 Oct 2017 01:23:00 +0000

Please reserve a slot for https://datatracker.ietf.org/doc/draft-shen-isis-spine-leaf-ext/.
Either Naiming or myself will present.

   Les

From: Dcrouting [mailto:[email-masked]] On Behalf Of Van De Velde, Gunter (Nokia - BE/Antwerp)
Sent: Thursday, October 19, 2017 5:39 AM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: Victor Kuarsingh <[email-masked]>
Subject: [Dcrouting] DC ROUTING BOF at IETF100 - call for meeting topics

Hi All,

Kind Regards,

Victor & Gunter
co-chairs DC Routing BOF

---

From: Keyur Patel <[email-masked]>
Date: Mon, 23 Oct 2017 22:23:04 +0000

Hi Gunter & Victor,

We would like to request 10 mins each for:

1)       https://datatracker.ietf.org/doc/draft-keyupate-idr-bgp-spf/

2)       https://datatracker.ietf.org/doc/draft-acee-idr-lldp-peer-discovery/

Regards,
Keyur

From: Isis-wg <[email-masked]> on behalf of "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Thursday, October 19, 2017 at 5:47 AM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [Isis-wg] DC ROUTING BOF at IETF100 - call for meeting topics

Fixing ISIS/RTGWG email address typos
------

Hi All,

Kind Regards,

Victor & Gunter
co-chairs DC Routing BOF

---

From: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Tue, 24 Oct 2017 07:53:08 +0000

Thanks.

G/

From: Keyur Patel [mailto:[email-masked]]
Sent: Tuesday, October 24, 2017 00:23
To: [email-masked]
Cc: Van De Velde, Gunter (Nokia - BE/Antwerp) <[email-masked]>; [email-masked]; Acee Lindem (acee) <[email-masked]>
Subject: FW: DC ROUTING BOF at IETF100 - call for meeting topics

Hi Gunter & Victor,

  1.  https://datatracker.ietf.org/doc/draft-keyupate-idr-bgp-spf/
  2.  https://datatracker.ietf.org/doc/draft-acee-idr-lldp-peer-discovery/

Regards,
Keyur

From: Isis-wg <[email-masked]<mailto:[email-masked]>> on behalf of "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, October 19, 2017 at 5:47 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Isis-wg] DC ROUTING BOF at IETF100 - call for meeting topics

Hi All,

Kind Regards,

Victor & Gunter
co-chairs DC Routing BOF

---

From: Fred Baker <[email-masked]>
Date: Wed, 25 Oct 2017 15:50:51 -0700

Gunter:

I would strongly suggest that you get someone from an enterprise shop to talk about routing in their networks. Hint: it isn't necessarily BGP.

Fred

> On Oct 24, 2017, at 12:53 AM, Van De Velde, Gunter (Nokia - BE/Antwerp) <[email-masked]> wrote:
> 
> Thanks.
> 
> G/
> 
> 	• https://datatracker.ietf.org/doc/draft-keyupate-idr-bgp-spf/
> 	• https://datatracker.ietf.org/doc/draft-acee-idr-lldp-peer-discovery/
> 
> Regards,
> Keyur
> 
> Data Center Routing (DCROUTING) will be having a non-working-group-forming BOF during IETF100. Over the last year, there have been discussions in a number of routing area working groups about proposals aimed at routing within a data center. Because of their topologies (traditional and emerging), traffic patterns, need for fast restoration, and need for low human intervention, among other things, data centers are driving a set of routing solutions specific to them. The intent of this BOF is to discuss the special circumstances that surround routing in the data center and potential new solutions. The objective is not to select a single solution, but to determine whether there is interest and energy in the community to work on any of the proposals.
> 
> If you have a draft and would like to see it discussed during the BOF meeting, then please send the note to the BOF co-chairs and copy the [email-masked] email address.
> 
> 	• Agenda bash, scribe, minute taker
> 	• DC Problem Statement Intro’s (DC testimonial summaries)
> 	• Solution Space Proposals
> 	• Summary
> 
> List address: ​[email-masked]
> Mailing List: ​https://www.ietf.org/mailman/listinfo/dcrouting
> Archive: ​https://mailarchive.ietf.org/arch/search/?email_list=dcrouting
> To subscribe: ​https://www.ietf.org/mailman/listinfo/dcrouting
> 
> Kind Regards,
> 
> Victor & Gunter
> co-chairs DC Routing BOF
> 
> _______________________________________________
> Dcrouting mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dcrouting

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 25 Oct 2017 15:59:28 -0700

we have got EDCO folks, who are going to present - draft-elkins-brickmortar-architecture

Cheers,
Jeff

-----Original Message-----
From: Dcrouting <[email-masked]> on behalf of Fred Baker <[email-masked]>
Date: Wednesday, October 25, 2017 at 15:51
To: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>, <[email-masked]>
Cc: Keyur Patel <[email-masked]>, "[email-masked]" <[email-masked]>, "Acee Lindem (acee)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Dcrouting] DC ROUTING BOF at IETF100 - call for meeting topics

    Gunter:

    Fred

---

From: Nalini J Elkins <[email-masked]>
Date: Wed, 25 Oct 2017 23:00:12 +0000 (UTC)

Fred,

I already started the conversation with Gunter.   A number of the routing people (Jeff & Tony) were kind enough to reach out to us quite a while back about participating.  I got extremely busy and could not work on the draft until a few days ago (sigh) but we are hard at work now.

It is "Common Network Architecture for Brick and Mortar Enterprises"
 
https://datatracker.ietf.org/doc/draft-elkins-brickmortar-architecture/?include_text=1

I had a conversation with a new enterprise co-author this morning - a large retail enterprise.  And, have a discussion planned in about an hour with a third.

As you say, many of our enterprises use primarily OSPF and EIGRP.  BGP is used but not that much.

Gunter was very helpful and provided some guidance on other things he would like to see in the draft.  We hope to get it cleaned up and ready to talk about at the DCRouting BoF.  Again, the fault was all mine for being overwhelmed with things to do. 
Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

________________________________
From: Fred Baker <[email-masked]>
To: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>; [email-masked] 
Cc: Keyur Patel <[email-masked]>; "[email-masked]" <[email-masked]>; Acee Lindem (acee) <[email-masked]>; "[email-masked]" <[email-masked]>
Sent: Wednesday, October 25, 2017 3:51 PM
Subject: Re: [Dcrouting] DC ROUTING BOF at IETF100 - call for meeting topics

Gunter:

Fred

---

From: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Thu, 26 Oct 2017 06:12:00 +0000

Hi Nalini, all, thanks for the update. Great to understand about the content being enhanced.

Yes, looking forward for an updated version providing a bit more context and examples on DC Routing aspects, requirements and expectations.

All the best,

G/

On 26/10/2017, 01:00, "Nalini J Elkins" <[email-masked]> wrote:

    Fred,

     

    
    
    Nalini Elkins
    CEO and Founder
    Inside Products, Inc.
    www.insidethestack.com
    (831) 659-8360

    
    Gunter:

    Fred

---

From: Randy Bush <[email-masked]>
Date: Thu, 26 Oct 2017 09:00:52 +0200

> It is "Common Network Architecture for Brick and Mortar Enterprises"

in our customer base, 'enterprise' networks are *very* different from
'datacenter' networks and have extremely differnt needs.  are we trying
to stuff dissimilar tomatoes into one can?

randy

---

From: Nalini J Elkins <[email-masked]>
Date: Thu, 26 Oct 2017 12:53:24 +0000 (UTC)

>to stuff dissimilar tomatoes into one can?

Randy, this is a very interesting comment.  Our thought is that as enterprises we also have data centers.   
Do you think a definition of terms or topology would be worth while?
Nalini

---

From: Randy Bush <[email-masked]>
Date: Thu, 26 Oct 2017 15:01:27 +0200

tl;dr: i think enterprise is the massive office lan.  datacenter is
racks of servers.  i do not confuse 'enterprise' being not owned by some
sort of service provider.

> I would agree the wide area and access parts of enterprise networks
> are different from the datacenter side of the house.

i did not say wide area.  enterprise lans look a lot live isp wans exept
there are far more services and more midleboxes.  though the isps are
catching up on the middleboxes :(

> However, would you apply that same differentiation to enterprise
> datacenter vs. carrier and/or cloud datacenters as well?

no.  i would differentiate cloud vs service, i.e. [semi-]homogenous vs
hetrogenous.  e.g. goog, vs aws, vs a lot of what we do is essentially
colo+deep management.

> In my experience, ISPs, Cloud shops etc had folks internally with BGP
> expertise, so tended to not shy away from using it to deal with DC
> routing challenges there.

now you add 'cloud'.  some enterprises have datacenters _on the side_
which they operate as internal cloud services.  some enterprises have
datacenters _on the side_ over which they provide external services
(bank web, for example).

my point is 'enterprise' networks are lans, often fairly complex, which
have their own constraints and problems which are quite different from
those of a 'datacenter.'

randy

---

From: Randy Bush <[email-masked]>
Date: Thu, 26 Oct 2017 15:02:34 +0200

> enterprises we also have data centers.

they also have coffee machines.

randy

---

From: Randy Bush <[email-masked]>
Date: Thu, 26 Oct 2017 15:09:41 +0200

> they also have coffee machines.

apologies.  in a research meeting; and i could be more clear.

that the widget corporation may run (or outsource) a datacenter.
this does not make all of their IT datacenter.

what i am trying to avoid are discussions such as printers, firewalls,
... from datacentwr routing.  focus on fat trees, clos, ...

randy

---

From: Tony Przygienda <[email-masked]>
Date: Thu, 26 Oct 2017 08:49:38 -0700

+1 here

---

From: Keyur Patel <[email-masked]>
Date: Thu, 26 Oct 2017 16:15:38 +0000

Agree with Randy and Tony.

From: Tony Przygienda <[email-masked]>
Date: Thursday, October 26, 2017 at 8:49 AM
To: Randy Bush <[email-masked]>
Cc: Nalini J Elkins <[email-masked]>, "[email-masked]" <[email-masked]>, Fred Baker <[email-masked]>, Keyur Patel <[email-masked]>, "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "Acee Lindem (acee)" <[email-masked]>
Subject: Re: [Dcrouting] DC ROUTING BOF at IETF100 - call for meeting topics

+1 here

randy

_______________________________________________
Dcrouting mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dcrouting

---

From: Randy Bush <[email-masked]>
Date: Thu, 26 Oct 2017 18:20:50 +0200

i think both enterprie/lan and datacenter/clos/... networking and
routing are important and intereting.  but they are rather different.
and i just think we need to be careful with nomenclature or things get
very slidy (no, that isn't a word).

randy

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 26 Oct 2017 10:28:17 -0700

Randy,

The focus is specifically DC Networking, not enterprise LAN’s and such

Cheers,
Jeff

-----Original Message-----
From: Dcrouting <[email-masked]> on behalf of Randy Bush <[email-masked]>
Date: Thursday, October 26, 2017 at 06:09
To: Nalini J Elkins <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Fred Baker <[email-masked]>, Keyur Patel <[email-masked]>, "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "Acee Lindem (acee)" <[email-masked]>
Subject: Re: [Dcrouting] DC ROUTING BOF at IETF100 - call for meeting topics

    

    randy

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 26 Oct 2017 10:25:26 -0700

we are all in agreement, I believe it is also well understood by Nalini and folks represented

Cheers,

Jeff

From: Dcrouting <[email-masked]> on behalf of Keyur Patel <[email-masked]>
Date: Thursday, October 26, 2017 at 09:15
To: Tony Przygienda <[email-masked]>, Randy Bush <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Fred Baker <[email-masked]>, "[email-masked]" <[email-masked]>, Nalini J Elkins <[email-masked]>, "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>, "Acee Lindem (acee)" <[email-masked]>
Subject: Re: [Dcrouting] DC ROUTING BOF at IETF100 - call for meeting topics

+1 here 

randy

_______________________________________________ Dcrouting mailing list [email-masked] https://www.ietf.org/mailman/listinfo/dcrouting

---

From: Nalini J Elkins <[email-masked]>
Date: Thu, 26 Oct 2017 18:03:15 +0000 (UTC)

Guys,
Yes, sure.  I think we understand!   Will do our best.
We do use routing protocols within our confines.  Are we now defining "data centers" as only being server farms which connect to the Internet?  Am I misunderstanding? Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

      From: Jeff Tantsura <[email-masked]>
 To: Keyur Patel <[email-masked]>; Tony Przygienda <[email-masked]>; Randy Bush <[email-masked]> 
Cc: "[email-masked]" <[email-masked]>; Nalini J Elkins <[email-masked]>; "[email-masked]" <[email-masked]>; Fred Baker <[email-masked]>; "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>; "[email-masked]" <[email-masked]>; Acee Lindem (acee) <[email-masked]>
 Sent: Thursday, October 26, 2017 10:48 AM
 Subject: Re: [Dcrouting] DC ROUTING BOF at IETF100 - call for meeting topics
   
#yiv2961956948 #yiv2961956948 -- _filtered #yiv2961956948 {font-family:Arial;panose-1:2 11 6 4 2 2 2 2 2 4;} _filtered #yiv2961956948 {panose-1:2 4 5 3 5 4 6 3 2 4;} _filtered #yiv2961956948 {font-family:Calibri;panose-1:2 15 5 2 2 2 4 3 2 4;}#yiv2961956948 #yiv2961956948 p.yiv2961956948MsoNormal, #yiv2961956948 li.yiv2961956948MsoNormal, #yiv2961956948 div.yiv2961956948MsoNormal {margin:0in;margin-bottom:.0001pt;font-size:12.0pt;}#yiv2961956948 a:link, #yiv2961956948 span.yiv2961956948MsoHyperlink {color:blue;text-decoration:underline;}#yiv2961956948 a:visited, #yiv2961956948 span.yiv2961956948MsoHyperlinkFollowed {color:purple;text-decoration:underline;}#yiv2961956948 span.yiv2961956948EmailStyle17 {color:windowtext;}#yiv2961956948 span.yiv2961956948EmailStyle18 {color:windowtext;font-weight:normal;font-style:normal;}#yiv2961956948 span.yiv2961956948msoIns {text-decoration:underline;color:teal;}#yiv2961956948 .yiv2961956948MsoChpDefault {font-size:10.0pt;} _filtered #yiv2961956948 {margin:1.0in 1.0in 1.0in 1.0in;}#yiv2961956948 div.yiv2961956948WordSection1 {}#yiv2961956948 we are all in agreement, I believe it is also well understood by Nalini and folks represented  Cheers,Jeff  From: Dcrouting <[email-masked]> on behalf of Keyur Patel <[email-masked]>
Date: Thursday, October 26, 2017 at 09:15
To: Tony Przygienda <[email-masked]>, Randy Bush <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Fred Baker <[email-masked]>, "[email-masked]" <[email-masked]>, Nalini J Elkins <[email-masked]>, "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>, "Acee Lindem (acee)" <[email-masked]>
Subject: Re: [Dcrouting] DC ROUTING BOF at IETF100 - call for meeting topics  Agree with Randy and Tony.  From: Tony Przygienda <[email-masked]>
Date: Thursday, October 26, 2017 at 8:49 AM
To: Randy Bush <[email-masked]>
Cc: Nalini J Elkins <[email-masked]>, "[email-masked]" <[email-masked]>, Fred Baker <[email-masked]>, Keyur Patel <[email-masked]>, "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "Acee Lindem (acee)" <[email-masked]>

_______________________________________________
Dcrouting mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dcrouting
 _______________________________________________ Dcrouting mailing list [email-masked] https://www.ietf.org/mailman/listinfo/dcrouting _______________________________________________
Dcrouting mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dcrouting

---

From: Victor Kuarsingh <[email-masked]>
Date: Thu, 26 Oct 2017 14:16:57 -0400

> datacenters _on the side_ over which they provide external services

Sorry, ignore “cloud”  and substitute provider who builds DCs for the purposes of IaaS or like-fiction. I had noted that since these are often different then ISPs and Enterprises DCs.

My main point (and I know Jeff has commented since that we all seem to be in general agreement) was the we are talking about Datacenter irrespective of where those Datacentesr are and who is building them. 

regards,

Victor K