Subject: Re: [Dcrouting] DC Routing requirements draft

From: Nalini J Elkins <[email-masked]>
Date: Wed, 1 Nov 2017 17:38:24 +0000 (UTC)

>>> But, just in case some people are thinking that enterprises do not
>>> have data centers
> 
>> i doubt anyone questions that enterprises sometimes have datacenters.
>> enterprises sometimes also have printers.  this does not mean

>> enterprises *are* printers.

> That may be the rub here. I doubt that enterprises that have data centers *are* data centers in either of your minds, any more than enterprises that *have* printers *are* printers. 
> However, in the data centers that enterprises have, they may have specific requirements that don't map well to the likes of Azure or Google, but which are in fact requirements of a 
> class of data centers.

Guys, I am getting another of my enterprise folks involved who had a good comment:

"We will have an underlay network [in our data center], which I think is going to still be OSPF and BGP, and an overlay network of VXLAN that allows ACI connectivity, which I think is what you're calling a big LAN (extended layer 2 subnets between pods and even between data centers).  I think this is reality for the modern data center.  We're also still keeping the brick and mortar components from your draft, overlaid on top of the "big lan"; firewalls, load balancers, web tier, app tier, middleware, etc....  So both models are true, one overlaid on top of the other.  In other words, when you route from the load balancer to the web server, you're traversing the ACI/VXLAN network to get there." 

I think this is a good discussion.   I am working to get this enterprise to also help co-author and explain their environment.   My brick and mortar draft ( 
https://datatracker.ietf.org/doc/draft-elkins-brickmortar-architecture) has a fair amount of stuff that is non-routing related because we are just getting started.  We will likely split it into more documents as this develops.  I am also adding in stuff about our diagnostic needs.  Have been talking to people about that as well. 

Sorry to get so behind on everything.  My best estimate for a new draft is tomorrow (Thursday) afternoon.

Thanks for your patience and comments.

Nalini

---

From: Nalini J Elkins <[email-masked]>
Date: Fri, 3 Nov 2017 13:47:39 +0000 (UTC)

Hello All,
I am posting our updated draft to the list as I have missed the deadline for submission.   Please let me know any comments.
I can revise at least one more time before the meeting. Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360