Subject: RE: [Forces-protocol] PL/TML Interface::topic 1

From: [email-masked]
Date: Mon, 26 Apr 2004 09:16:55 -0400

Hello Hormuzd,

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of ext Khosravi,
> Hormuzd M
> Sent: Monday, April 26, 2004 1:13 AM
> To: [email-masked]; Wang,Weiming
> Cc: [email-masked]
> Subject: [Forces-protocol] PL/TML Interface::topic 1
> 
> 
> Jamal, Weiming,
> 
> Just trying to summarize some of the requirements or services for TML,
> PL based on our discussions...
> 
> TML Requirements/Services...
> 
> 1. Reliability acc to Reqs (no data loss, data corruption
> 2. Security
> 3. Congestion Control
> 4. Uni/multi/broadcast addressing/delivery
> 5. Connection or Association State maintainance(helps with HA)
> 

- Add to  point 5 for HA services - TML (eg., link layer triggers to report link failure)
and connection reassociation and state maintenance.

> Things that belong to PL...
> 
> 1. PL level reliability using Acks/Responses
> 2. Timeliness, again using Acks
> 3. Batching
> 4. transactional operations (2pc etc)
> 5. Capability exchange (FE, LFB Caps) (BTW, not sure what 
> Jamal means by
> this in context with TML?)
> 6. HA decisions 

- Here for HA decision (dead peer detection and switch operations)

- FE and CE's PL layer also needs to be part of intial capability exchange. 

> 
> 
> Hope this is reasonably captures all the discussions. I was not sure
> about what you mean by FEM/CEM interface so I didn't mention that in
> this list.
> 
> regards
> Hormuzd
> 
> 
> _______________________________________________
> Forces-protocol mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/forces-protocol
> 

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Mon, 26 Apr 2004 09:19:33 -0700

Ram,

Thanks for your comments. I am fine with your suggestions, I think they
are mostly covered already.

Hormuzd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, April 26, 2004 6:17 AM
To: Khosravi, Hormuzd M; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [Forces-protocol] PL/TML Interface::topic 1

Hello Hormuzd,

> 5. Connection or Association State maintainance(helps with HA)

- Add to  point 5 for HA services - TML (eg., link layer triggers to
report link failure)
and connection reassociation and state maintenance.

- FE and CE's PL layer also needs to be part of intial capability
exchange.

---

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Mon, 26 Apr 2004 14:54:12 -0700

Jamal,

I'll send out a list with more details. Some comments/question below..

-----Original Message-----
From: Jamal Hadi Salim [mailto:[email-masked]] 

Hormuzd, i would recommend to put more maet if you compile things like
this. Sending out bullet forms tends to reignite deiscussions already
gone by (as i am noticing in some eamils from Ram).

> 1. Reliability acc to Reqs (no data loss, data corruption

whats acc? [HK] according

> 3. Congestion Control

There may be value in the TML informing the PL about congestion events
in the transport layer. This is not unlike ECN signals received
from IP which get upwards propagated. I would like (not sure of the
value) to suggest that the signaling should also be available from PL to
TML; if the PL is congested, it could be probably easily detected if it
is not pulling packets fast enough.

Also one thing we didnt have in this list is prioritization.
This is related to congestion. Example: under congestion, 
the TML may decide to drop lower priority packets from the PL.
Likewise if the PL is congested, the TML may decide to drop low prio
packets destined to it.

[HK] Good point, I will add prioritization to the PL, TML list

> 5. Capability exchange (FE, LFB Caps) (BTW, not sure what Jamal means
by
> this in context with TML?)

Capability also belongs to the TML layer. Example is the FE capability.

[HK] I don't think Capability exchange belongs to the TML. Weiming also
sent some comments to this effect. LFB Capabilities, LFB graph or
topology, FE capabilities (such as whether it supports LFB Topology
Reconfiguration or only static topologies) are all part of PL messages
and need to be communicated to the Applications running on the CE. I am
a bit confused as to why you say this belongs to the TML ? May be you
mean some other TML Capabilities ?

> 6. HA decisions

So the way i see it is:

1)Items that are the responsibility of the TML terminate at the TML.
Example i dont see any decryption/encryption/authentication being done
by the PL. 
OTOH, There may be information that needs to be propagated to the PL
but i think we are saying that maybe implementation specific, no?
Probably thet TML author will say "to get congestion notification
you need to register for callback x".

[HK] Yes this is implementation specific

Regards
Hormuzd