Subject: RE: [Forces-protocol] Protocol Messages: topic 3 & 4a

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Fri, 30 Apr 2004 11:18:12 -0700

Hi Weiming,

Thanks for this list! I am mostly fine with it except a few things..
I think we need Event Reg/De-reg messages, these are very different
semantically from Config.
Also, just a Join msg, instead of FE,CE Join if we use Src/Dst ID in the
header.
That's all.

Thanks again,
Hormuzd

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Weiming Wang
Sent: Friday, April 30, 2004 9:57 AM
To: [email-masked]
Subject: Re: [Forces-protocol] Protocol Messages: topic 3 & 4a

Hi Hormuzd,

Ok, then, following compromise scheme may be acceptable to me, and
should let it
as our initials and open for changes if we enconter some difficulty when
we
actually begin writing  the text:

1.  Syncronization msg
    - for FE join, Leave, CE join, leave
2. Query / Query resp msg
    - include to query the capability
3. Config / Config resp msg

4. State Maintenance msg

5. Event Notification msg

6. Redirect msg

We do not need to categorize them.

Best regards,
Weiming

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: "Weiming Wang" <[email-masked]>
Date: Sat, 1 May 2004 03:27:05 +0800

Hormuzd,

Some clarifications so as to answer your two questions:

1.  Event reg/de-reg can be very easily implemented by either following two
means:
a. using config msg as I mentioned.  Actually I can not see any difference of it
from general config.
b. by event msg itself. That is, event msg include the event report and event
register, a flag (or a context) can easily notarize it.
(Actually I more like the word 'subscribe/unsubscribe' here, but let's leave it
for msg writers to choose)

2. I suppose Syn msg is one msg, with the flag in the msg body (or TLV) to
notarize if it's Join or leave, and as you mentioned using Src/Dst ID (even  by
context, as Jamal mentioned) to notarize that of CE or FE (There is no any
specific join msg then). Want Jamal to verify it.

It's 3am now, and I'm afraid need to go to bed,  therefore have to hope others
help you to finally decide it then. I know today is the deadline.

Cheers,
Weiming

----- Original Message -----
From: "Khosravi, Hormuzd M" <[email-masked]>

Hi Weiming,

Thanks again,
Hormuzd

-----Original Message-----

Hi Hormuzd,

1.  Syncronization msg

4. State Maintenance msg

6. Redirect msg

Best regards,
Weiming