Subject: RE: [Forces-protocol] ForCES Protocol Design Team first task - timeline!

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Fri, 2 Apr 2004 15:43:26 -0800

Hi All

IETF 60th meeting starts Aug 1st...
Working backwards, we should have our 00 draft submitted by July 1st
atleast.
Considering it would need to be reviewed atleast once before submission
I would go for distributing the draft on the mailing list for review by
June 15th.
That gives us about 2.5 months to get the draft done.

Some intermediate milestones could be...
1. Outline, 2. Complete discussion of major issues, 3. Complete writing
of major sections, 4. Send to mailing list for external review, 5.
Submission to IETF

Here are some suggested dates.
1. Outline done - April' 9th
2. Complete discussion of major issues - April' 30th
2.b. Discussion on mailing list of any contentious issues - ?
3.a. Complete writing of major sections - May' 20th
3.b. Distribute sections for internal review - May'21st
3.c. Incorporate comments from protocol team - June 1st
4. Send to ForCES mailing list for external review - June 2nd
5. Submission to IETF - June 15th

If we can hit these dates, we will be well ahead of schedule :-)

Let me know what you guys think.
Jamal, I'll start by responding to your text on HA over the weekend.

Thanks
Hormuzd

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Putzolu, David

The first task of the team is to come up with 
proposed dates for a first draft to be presented
to the working group, along with any intermediate
milestones (outline done etc.).  

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: [email-masked]
Date: Sat, 3 Apr 2004 09:29:01 +0900

Seems like a reasonable schedule to me.

I think we should also select an editor to be responsible for keeping 
the draft in shape as we move along.  We can all contribute text and 
agree on content, but there should be one person, agreeable to the 
entire group, who actually takes care of the doc.

a.

---

From: Jamal Hadi Salim <[email-masked]>
Date: 02 Apr 2004 20:47:11 -0500

> entire group, who actually takes care of the doc.

I actually very strongly disagree on this given past experiences.
There should be no editor of any sort. I sent an email over 8 hours ago
but for some reason it didnt make it in.

cheers,
jamal

---

From: "Wang,Weiming" <[email-masked]>
Date: Sun, 4 Apr 2004 19:06:14 +0800

Hi Hormuzd,

That's a workable plan I think, only with the first outline date - 9th may seem
a little hurry.  I suggest it be 20th, leaving only one month for individual
writing. I suppose  it's enough to make it in a month.

Thank you.
Weiming

----- Original Message -----
From: "Khosravi, Hormuzd M" <[email-masked]>

Hi All

Thanks
Hormuzd

---

From: "Wang,Weiming" <[email-masked]>
Date: Sun, 4 Apr 2004 19:31:44 +0800

And moreover, I suggest the pahse 2 and 2.b for issue discussions may be divided
into two sub-phases, one is for issues related to the draft outline work, the
other is for more specific issues. The first sub-phase discussions should end
before 20th when the outline comes, the second may continue along with the draft
writing. I also think we need to distribute the writing tasks among the
individuals immediately after the outline is reached so as to speed the writing.

Jamal,
because the TML is separeated from the current PL work, do you think we need to
go through the issues again,  or to come with a new list  which is more relavent
to current PL work, or just continue with the remained issue list?

Thank you.
Weiming

---

From: "Ligang Dong" <[email-masked]>
Date: Sun, 4 Apr 2004 21:31:54 +0800

hi, 

Based on the opinion of Hormuzd and Weiming, the updated dates are as follows.

1.Before April 9th,
  a. A initial outline done
  b. decide whether and how we use XML and/or CVS
2.Before April 30th,
  a. Work out a final and detailed outline, and complete discussion of major issues
  b. Distribute sections for individual writing
     (During the writing, discussion on mailing list of any contentious issues continues)
3.a. Complete writing of each sections - May' 20th
  b. Distribute sections for internal review - May'21st
  c. Incorporate sections and comments from protocol team - June 1st
4. Send to ForCES mailing list for external review - June 2nd
5. Submission to IETF - June 15th

any comments?
Ligang

----- Original Message ----- 
From: "Wang,Weiming" <[email-masked]>
To: <[email-masked]>
Sent: Sunday, April 04, 2004 7:31 PM
Subject: Re: [Forces-protocol] ForCES Protocol Design Team first task - timeline!

> ����趇(�f��)��+-��z�k���X���+�m����5��_��?�������+-�w���+q�)��hr�

---

From: Jamal Hadi Salim <[email-masked]>
Date: 04 Apr 2004 10:59:24 -0400

> to current PL work, or just continue with the remained issue list?

You make a good point on PL vs TML; 
I think we already went over a lot of the TML related ones though - its
actually by going over those issues that we reached a conclusion a TML
is needed ;->

We need to have good talking points to drive whatever dates we are
trying to set. From this perspective, I think the list is a good
starting point. Thoughts?
Maybe a rewrite of that list to fit different categories would be
appropriate?

Heres a annotated rerun:

0) ID on the header.
1) Encoding

Above are PL specific

2) Multiple channels/connections
3) Transport: unicast/multicast/broadcast 
 { TCP, UDP, SCTP, DCCP, Direct over L2 or proprietary backplanes, TIPC}
4) Congestion control
5) Reliability
6) Security
7) High availability

Above are TML related

8) Capability exchange

Above is PL specific

9) The FEM/CEM interface

PL but more administrative than protocol. Would influence
some things in PL.

10) Support for vendor functions

PL 

11) Cross check with model draft before it is published

Administrative

12) Master Slave or peer-peer?

PL - Very important in my opinion because will influence some PL
decisions.

I dont think above is exhaustive rather a good starting point like i
pointed earlier.

cheers,
jamal

---

From: Jamal Hadi Salim <[email-masked]>
Date: 04 Apr 2004 11:10:03 -0400

>   a. A initial outline done

I think we should finish the remaining issues discussion first quickly
first before going into any outlines.

>   b. decide whether and how we use XML and/or CVS

Hopefully it shouldnt take a few days to decide that.
If we decide to go CVS i can create the environment and send
instructions to people.

>      (During the writing, discussion on mailing list of any contentious issues continues)

Reasonable

>   b. Distribute sections for internal review - May'21st

I would hope there will a continous feedback as opposed to someone
dissapearing with a section and showing up later with contentious
text.

>   c. Incorporate sections and comments from protocol team - June 1st

This is where we may need a merger (not editor).

> 5. Submission to IETF - June 15th

Looks good overall. I didnt see any difference from what Hormuzd posted
originally though. 
I am optimistic we could beat most of these deadlines.

cheers,
jamal