Subject: [Forces-protocol] Outline

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Mon, 5 Apr 2004 23:49:59 -0700

Here is an initial outline for the draft

Abstract
1. Introduction
2. Protocol Overview
3. Common Header
4. Protocol Messages
5. Example Scenarios
6. TML Requirements
7. Security Considerations
8. References
9. Acknowledgments

Let me know what you guys think ?
We can add more details as we move along.

Thanks
Hormuzd

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: Jamal Hadi Salim <[email-masked]>
Date: 06 Apr 2004 14:48:01 -0400

Hormuzd,
Some comments:

> Here is an initial outline for the draft

Should we follow with protocol details after this?
And should TML move to just below Protocol overview or were you thinking
protocol overview contains overview of TML as well?

> 7. Security Considerations

do security requirements belong to TML as well?

> We can add more details as we move along.

I think its a good start and good idea to have this at this point. We
probably shouldnt spend too much time on cosmetics right now because i
think we can iron those out as we go on.

cheers,
jamal

---

From: "Wang,Weiming" <[email-masked]>
Date: Wed, 7 Apr 2004 14:39:23 +0800

Hi Hormuzd, Jamal,

----- Original Message -----
From: "Jamal Hadi Salim" <[email-masked]>

> > Here is an initial outline for the draft

[Weiming] I suppose we add
    2. Definitions

> > 3. Common Header
[Weiming] The common header can be inside the overview. And also the overivew
will explain the layering model of PL and TML, therefore the TML requirements
can also be included in it.

> protocol overview contains overview of TML as well?

[Weiming] Agreed as above.
> > 5. Example Scenarios

[Weiming] This section should be as an Appendix.

> > 6. TML Requirements

[Weiming]As mentioned above, this should be put early in the protocol overview,
so that some protocol messages related to TML can be reasonably understood.

> do security requirements belong to TML as well?
[Weiming]This section is still normally needed even TML will be more responsible
for protocol security issues.

> think we can iron those out as we go on.

[Weiming] To summarise, I think we may only need to give the first layer
outlines as follows,

1. Introduction
2. Definitions
3. Protocol Overview
4. Protocol Messages

All others are just normal ones and the more we need to discuss followed is the
contents inside the overview and messages. As Jamal said, we can do it along
with the issue discussions.

Yours,
Weiming

---

From: Jamal Hadi Salim <[email-masked]>
Date: 07 Apr 2004 07:52:17 -0400

Weiming, Hormuzd,

> [Weiming] I suppose we add

Makes sense.

> > > 2. Protocol Overview

I have a feeling that this being the only section that describes the
protocol details then "overview" is insufficient?

> can also be included in it.

This i think should be a section on its own. Theres a lot of details to
explain.

cheers,
jamal