Subject: RE: [Forces-protocol] topic 2:: HA

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Mon, 26 Apr 2004 10:43:42 -0700

Ram,

I see what your saying. It seems like you are talking about some cases
which might not have been explicitly covered by the text. I will add
some clarification to the text. The details will also be more clear once
we start getting into the protocol messages.

Thanks
Hormuzd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
> 
> > 
> > Based on our discussions on TML and PL as well as the 3 
> > schemes proposed
> > by Jamal, here is my suggestion for HA scheme...
> > 
> > At any time there is one Primary CE controlling the FE and 
> > there can be
> > multiple secondary Ces. The FE PL is aware of the primary and 
> > secondary
> > Ces. Only the primary CE is sending Control messages to the 
> > Fes. The FE
> > may choose to send its events, redirection packets to all the Ces or
> > only Primary CE (we need to decide one or keep this 
> configurable ?). A
> > CE-to-CE synchronization may be needed, however that is out of our
> > current scope for ForCES PL. The association between the FE 
> > and primary
> > CE may change based on the Connection State (triggered by TML) or an
> > explicit message (such as Move, described by Jamal) from the 
> > primary CE.
> 
> 
> As CE's are maste,we have two levels of issues. One is remote endpoint
> is dead and another 
> is link failure(very rare to happen in single box scenarion, but
> possible in multi hop situation).
> Consider a case CE1 & CE2 are master and slave respectively for FE-1.
> FE-2 is an standby for FE-1.
> When CE-1 detects the link failure, it may will wake up alternative FE
> (say FE-2). But FE-1 informs CE-2 
> that CE-1 has failed. But CE-1 and CE-2 are already in the 
> loop. In this
> scenario, CE(s) is the master and 
> CE-2 should inform the FE-1 to be pulled out.
> 
> There are other such scenario's we can derive. Since CE is the
> controlling authority and we are 
> assuming that there is CE to CE synchornization taking place, 
> link layer
> failure cases are different than the
> remote peer detection.
> 
> [HK] So what was your suggestion based on this scenario ? 
> Would you like
> to see some change to the scheme that I described ? Sorry its 
> not clear
> to me.
> 

<Ramg>

What i wrote is an extension (or additions )to your proposed text. For
example, where both primary 
CE and FE informing the standby CE and standy CE should inform the FE to
take appropriate actions. As CE are 
considered masters and have control over the services.

<Ramg>

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: Jamal Hadi Salim <[email-masked]>
Date: 26 Apr 2004 16:05:47 -0400

Folks,

I would like to make a small recommendation:
Lets use anything that exists today in terms of charter, drafts (such as
the model draft), RFCs such as the requirements as good guidelines
not as the Word Of God (if you believe s/he/they exist). 

We need to develop a good protocol, thats what counts the most.
None of the other drafts matter if the protocol is not usable.
For example, i dont think we should rule out CE-CE extension if it makes
sense and the cost of adding it is acceptable.

Apologies for going a little out of tangent.

cheers,
jamal

---

From: "Wang,Weiming" <[email-masked]>
Date: Tue, 27 Apr 2004 19:04:33 +0800

Jamal,

I agree with you that we may only take them more as guidelines, because all of
us participating in the ForCES have to confess that a lot of  stuff ForCES is
trying is much more than being easy, even from the viewpoints of experts of
distributed systems, therefore it's reasonable to have what have been done
always be open for improvement instead of becoming dogmas. On the other hand, I
have an idea that when we are not sure of the ways, we may be better to choose
the easier way to go and let the others developed later.

Actually I'm not objecting to consider the CE-CE cases, only a little worry that
this may be quite complex to consider currently. I'll definitely support it if
we eventually can find some good schemes to deal with it.

Cheers,
Weiming

----- Original Message -----
From: "Jamal Hadi Salim" <[email-masked]>
To: "Khosravi, Hormuzd M" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>;
<[email-masked]>; <[email-masked]>
Sent: Tuesday, April 27, 2004 4:05 AM
Subject: [Forces-protocol] That dogma in the requirements