Subject: [Forces-protocol] List of issues for discussion

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Sun, 18 Apr 2004 22:17:51 -0700

Hi All

Weiming started a private discussion with Jamal and myself over the
weekend regarding renewing of protocol drafts and it has turned into a
useful discussion of how to make some quick progress on the protocol.
Both Jamal and myself are concerned that we have Not made good progress
so far on this team.

Here is a list of issues to be discussed as suggested by Jamal.

0. Expected architecture/use cases:

I believe this is important to remove the major stumbling issue -

the different views of implementations.

i) What each of (PL and TML) does; we could steal from Davids url.

ii) scenario layouts of processing. 

ii-I) joining and leaving; CEM/FEM role etc

ii-II) Lets pick one or two simple examples (maybe just IPV4 forwarding

with OSPF).

1. TML

#0 above should help ease this.

a) roles of TML vs PL.

b) services provided by TML to PL

i) what are they? 

ii) should the services be controllable by the PL?

iii) if yes, to what degree

2. HA

3. Capability Exchange, FEM/CEM

4.a. Protocol Messages

4.b. Protocol Scenarios

4.c. Common Header

5. Support for Vendor functions

6. Master-Slave or Peer-to-Peer model

Lets get the ball rolling...:-)

regards

Hormuzd

---

From: [email-masked]
Date: Mon, 19 Apr 2004 13:14:08 -0400

Hello Jamal, all,

> -----Original Message-----
> From: ext Jamal Hadi Salim [mailto:[email-masked]]
> Sent: Monday, April 19, 2004 12:11 PM
> To: Gopal Ram (Nokia-NRC/Boston)
> Cc: [email-masked]; [email-masked]
> Subject: RE: [Forces-protocol] List of issues for discussion
> 
> 
> 
> On Mon, 2004-04-19 at 09:52, [email-masked] wrote:
>  
> > In future, please discuss all the issues on the list.
> 
> The discussion had nothing to do with the list. 
> The result was - thats why it was posted.
> 
> 
> > regarding this work item - comments are inline.
> >  
> > Regards
> > Ramg
> >         -----Original Message-----
> >         From: [email-masked]
> >         [mailto:[email-masked]]On Behalf Of ext
> >         Khosravi, Hormuzd M
> >         Sent: Monday, April 19, 2004 1:18 AM
> >         To: [email-masked]
> >         Subject: [Forces-protocol] List of issues for discussion
> >         
> >         
> >         
> >         Hi All
> >         
> >          
> >         
> >         Weiming started a private discussion with Jamal and myself
> >         over the weekend regarding renewing of protocol 
> drafts and it
> >         has turned into a useful discussion of how to make 
> some quick
> >         progress on the protocol. Both Jamal and myself are 
> concerned
> >         that we have Not made good progress so far on this team.
> >         
> >          
> >         
> >         i) What each of (PL and TML) does; we could steal 
> from Davids
> >         url.
> >         
> >          
> >         
> >         <RamG>
> >         What's the reason for picking this two?
> >         
> >         <RamG>
> 
> This seems to be the simplest one. You can pick something else.
> 
> >         
> >         1. TML
> >         
> >         [<Ramg>]  This needs to be discussed.
> 
> yes. The whole TML needs discussion.
> 
> >          2. HA 
> >         
> >         
> >         [<Ramg>]  Commonly used mechanism are CE-CE and its outside
> >         the scope. But we need to make sure that the protocol can
> >         accomudate both FE-CE and also CE-CE (and not sure of FE-FE
> >         scenario's - typically done in hardware).
> >         
> 

> I posted a little text a while back with some details on several
> alternatives. In there i mention what i thought was a part 
> the protocol
> plays.

May be during this discussion - i had internal email problems - let me go to archive and pull out.

> >         [<Ramg>]  May be reverse the order. 
> >         
> >         a. Message types and overview
> >         
> >         b. Common header
> >         
> >         c. Protocol MEssage structure
> >         
> >         d. Protocol scenarios ( operations)
> >         
> >          
> 
> Sounds to me like b, c,a, d is the right sequence.
> 

The section of a is a overview about types of message and its a head start for the complete section
 and it has nothing going there... this is to give a flow of the section.

regards
ramg

> cheers,
> jamal

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Mon, 19 Apr 2004 13:22:03 -0700

Ram,

I agree with Jamal's comment below on the private emails.

Hormuzd