Subject: [Fwd: Re: [Forces-protocol] ForCES Protocol Design Team first task - timeline!]

From: Jamal Hadi Salim <[email-masked]>
Date: 02 Apr 2004 21:27:20 -0500

Heres an email i sent earlier that for some odd reason didnt
make it.
Hormuzds has made similar comments and may give more reason to why
the editing should be distributed.

cheers,
jamal

-----Forwarded Message-----

From: Jamal Hadi Salim <[email-masked]>
To: "Putzolu, David" <[email-masked]>
Cc: [email-masked]
Subject: Re: [Forces-protocol] ForCES Protocol Design Team first task - timeline!
Date: 02 Apr 2004 11:59:01 -0500

David,
This is the old list, no?
For a move forward i would suggest that we complete the issues list
from earlier and then go into details of each.
I would like to suggest that the above get done by the 3rd of may
(gives us a month) and also time to pass things onto
the mailing list for review before san diego.
I would also like to suggest a method where everyone is contributing to
the text as opposed to having a single editor. This maybe what the model
people did, not sure. It worked very well for us in the netlink2 draft;
i also didnt like the way the requirements draft went with a single
editor - so i am hoping to avoid a repeat of any issues that came up
then (at least from me) in order to focus the energies on the issues.

For the documentation scheme, my suggestion is to use the XML variant
although i am not sure how you could show any updates using XML. 
The advantage with that is some of us dont own any MS products but need
to be able to update the doc.

cheers,
jamal

On Thu, 2004-04-01 at 12:33, Putzolu, David wrote:
> Hi all.
> 
> Welcome to the ForCES protocol design team.
> 
> Patrick & I have constituted this team to create a
> proposed ForCES protocol draft.  Please note that:
> 
> * This document will be an individual contribution
>   until the WG has a chance to review and accept it.
> 
> * The draft presented to the WG does not need to 
>   be complete, but it does need to have enough
>   content to allow the WG to say, "we (disagree|agree)
>   with the fundamental direction and approach taken
>   in this draft."
> 
> * All work by the design team should be visible to
>   the ForCES mailing list and the design team mailing 
>   list archive is publicly accessible.
> 
> * Non-members of the design team may (and hopefully
>   will!) provide input and contribute to the work
>   of the design team. 
> 
> * The design team has been made a small group in
>   order to allow for rapid progress & effective
>   communication. As such, if you are working with
>   people outside the design team, please ensure 
>   that their contributions are up to date with
>   current design team thinking & consensus.
> 
> I'm sure more will come to mind. :)
> 
> The first task of the team is to come up with 
> proposed dates for a first draft to be presented
> to the working group, along with any intermediate
> milestones (outline done etc.).  
> 
> Thanks!
> -David
> 
> _______________________________________________
> Forces-protocol mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/forces-protocol

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol

---

From: [email-masked]
Date: Sat, 3 Apr 2004 11:37:58 +0900

i definitely support using XML.

If we are going to have multiple authors all contributing to the draft, 
I suggest we set up some sort of source control.

a.

---

From: Jamal Hadi Salim <[email-masked]>
Date: 02 Apr 2004 21:44:59 -0500

> I suggest we set up some sort of source control.

Good idea.
Since XML is text based, i think CVS should do. Would it be painful for
some people? I use it all the time but dont wanna force it on people.

cheers,
jamal

---

From: [email-masked]
Date: Sat, 3 Apr 2004 11:53:19 +0900

I am fine with CVS, though I am rusty so could whoever set  it up send 
out some brief and basic instructions for CVS net use.

In terms of the XML, it is relatively easy to set it up to include 
separate files.  Once we have the outline, I can set up the base xml 
files and include files for the subsections - already have stubs I use 
so it should be easy.

a.

---

From: Jamal Hadi Salim <[email-masked]>
Date: 02 Apr 2004 22:09:50 -0500

> files and include files for the subsections - already have stubs I use 

If you can do include files, the need for CVS may die since
manageability of versioning  is reduced to smaller files. 
Do you use the M Rose XML2rfc package?

cheers,
jamal

---

From: [email-masked]
Date: Sat, 3 Apr 2004 12:17:26 +0900

> Do you use the M Rose XML2rfc package?

Yes, though I do sometime used a hacked up version that includes some 
numbering improvements and some equation support - which I don't think 
we will need for this effort.  the basic xml2rfc package includes the 
include support.

a.

---

From: "Wang,Weiming" <[email-masked]>
Date: Mon, 5 Apr 2004 19:51:39 +0800

I'm fine with XML either.  Talking about CVS or XML2RFC  include,  I suggest we
check to see XML2rfc first. If it can meet all requirements for us, we then go
with it, or else, I'm afraid we have to use CVS. Seems only the new version of
xml2rfc contains the include?

Weiming
----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Sent: Saturday, April 03, 2004 10:37 AM
Subject: Re: [Fwd: Re: [Forces-protocol] ForCES Protocol Design Team first
task - timeline!]

---

From: [email-masked]
Date: Mon, 5 Apr 2004 21:32:42 +0900

On 5 apr 2004, at 20.51, Wang,Weiming wrote:

> Seems only the new version of

I have used it for at least the last 2 versions.

a.

---

From: "Wang,Weiming" <[email-masked]>
Date: Mon, 5 Apr 2004 21:17:54 +0800

Hi all,

Talking about editor(s), I'd like to put some opinions as follows,

1) I'm afraid we need editor(s) anyway,  sooner or later, provided we have a
quite big team. In this case, as Avri mentioned, my opinion is also that we need
to have it set before we begin the draft writing. I don't think it is very
reasonable and acceptable to have it set after the draft is finished. To set
editor(s) ASAP will definitely speed up the team work.

2) From the history of the former three candidate protocols and the experiences
of the merge process discussions, I have a stron feeling that we should firstly
try to have three editors/writers, one from each former candidate protocols, for
the first 00 draft. This is the most efficient, the most reasonable, and
probably most acceptable scheme for current work, I think.

3) In the case the 2) scheme can not work well or even can not be concensused,
we then need to choose a neutral editor for the current work. I don't think in
this case, a non neutral editor can work well provided 2) scheme can not work,
(also given the past experiences of others), therefore it should be definitely
precluded at any time.

Anyway, let's decide it now in order to speed up the process.

Yours,
Weiming

----- Original Message -----
From: "Jamal Hadi Salim" <[email-masked]>
To: <[email-masked]>
Sent: Saturday, April 03, 2004 10:27 AM
Subject: [Fwd: Re: [Forces-protocol] ForCES Protocol Design Team first task-
timeline!]

---

From: Jamal Hadi Salim <[email-masked]>
Date: 06 Apr 2004 16:25:39 -0400

Weiming,

> probably most acceptable scheme for current work, I think.

Ok, if this is acceptable to others i will go along as well . I do hope
we dont end into some deadlocks.

cheers,
jamal

---

From: "Ligang Dong" <[email-masked]>
Date: Wed, 7 Apr 2004 20:44:44 +0800

hi,

I agree with weiming and jamal. 
It is necessary to have one editor from each previous candiate protocol. The reason is the coordination between 7 authors should be easier and more efficient than the coordination between 3 editors. As a result, our process will be faster.

Besides, the authors in the same candiate protocol almost have the same view. Therefore, it is feasible to recommend one from the authors for the same candiate protocol.

best regards
Ligang

----- Original Message ----- 
From: "Jamal Hadi Salim" <[email-masked]>
To: "Wang,Weiming" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, April 07, 2004 4:25 AM
Subject: Re: Re: [Forces-protocol] ForCES Protocol Design Team first task-timeline!]

> ����趇(�f��)��+-��z�k���X���+�m����5��_��?�������+-�w���+q�)��hr�

---

From: "Ligang Dong" <[email-masked]>
Date: Thu, 8 Apr 2004 10:05:28 +0800

hi,

best regards
Ligang