Subject: RE: [Forces-protocol] List of issues for discussion

From: [email-masked]
Date: Mon, 19 Apr 2004 09:52:11 -0400

Hello All,
 
Thanks for the update- the purpose of the mailing list is the have people discuss the issues openly and not to have private conversation of the decision. I have been having difficulties in reading emails and the past few days only I was reading emails. 
 
In future, please discuss all the issues on the list.
 
regarding this work item - comments are inline.
 
Regards
Ramg

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of ext Khosravi, Hormuzd M
Sent: Monday, April 19, 2004 1:18 AM
To: [email-masked]
Subject: [Forces-protocol] List of issues for discussion

Hi All

Weiming started a private discussion with Jamal and myself over the weekend regarding renewing of protocol drafts and it has turned into a useful discussion of how to make some quick progress on the protocol. Both Jamal and myself are concerned that we have Not made good progress so far on this team.

Here is a list of issues to be discussed as suggested by Jamal.

0. Expected architecture/use cases:

I believe this is important to remove the major stumbling issue -

the different views of implementations.

i) What each of (PL and TML) does; we could steal from Davids url.

ii) scenario layouts of processing. 

ii-I) joining and leaving; CEM/FEM role etc

ii-II) Lets pick one or two simple examples (maybe just IPV4 forwarding

with OSPF).

<RamG>

What's the reason for picking this two?

<RamG>

1. TML

#0 above should help ease this.

a) roles of TML vs PL.

b) services provided by TML to PL

i) what are they? 

ii) should the services be controllable by the PL?

iii) if yes, to what degree

[<Ramg>]  This needs to be discussed.

 2. HA 

[<Ramg>]  Commonly used mechanism are CE-CE and its outside the scope. But we need to make sure that the protocol can

accomudate both FE-CE and also CE-CE (and not sure of FE-FE scenario's - typically done in hardware).

 3. Capability Exchange, FEM/CEM

4.a. Protocol Messages

4.b. Protocol Scenarios

4.c. Common Header

[<Ramg>]  May be reverse the order. 

a. Message types and overview

b. Common header

c. Protocol MEssage structure

d. Protocol scenarios ( operations)

<RamG> Describe the HA specific operation, security operation, TML specific opreation etc..

 5. Support for Vendor functions

6. Master-Slave or Peer-to-Peer model

Regards

Ramg 

Lets get the ball rolling...:-)

regards

Hormuzd

---

From: "Weiming Wang" <[email-masked]>
Date: Mon, 19 Apr 2004 22:41:34 +0800

Hello Ram, and all,

Actually we have not try to decide anything privately. Firstly I just want mention Jamal if he needs to update the Netlink2 draft, for it is very near the expire date. I privately write to Jamal on this because i think it is beyond the current topic and I don't want make some noise on the list. When we realized some topic has related to design team topic, I think Hormuzd has immediately transfered it to the list.

I'm sorry if it it has made the list a little bit unhappy.

Yours,
Weiming

----- Original Message ----- 
  From: [email-masked] 
  To: [email-masked] ; [email-masked] 
  Sent: Monday, April 19, 2004 9:52 PM
  Subject: RE: [Forces-protocol] List of issues for discussion

  Hello All,

  Regards
  Ramg
    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]]On Behalf Of ext Khosravi, Hormuzd M
    Sent: Monday, April 19, 2004 1:18 AM
    To: [email-masked]
    Subject: [Forces-protocol] List of issues for discussion

    Hi All

    with OSPF).

    <RamG>

    <RamG>

    1. TML

    a) roles of TML vs PL.

    i) what are they? 

     2. HA 

    4.a. Protocol Messages

    4.b. Protocol Scenarios

    4.c. Common Header

    b. Common header

    Regards

    Ramg 

    Lets get the ball rolling.J

    regards

    Hormuzd

---

From: Jamal Hadi Salim <[email-masked]>
Date: 19 Apr 2004 12:11:13 -0400

> In future, please discuss all the issues on the list.

The discussion had nothing to do with the list. 
The result was - thats why it was posted.

>         From: [email-masked]
>         [mailto:[email-masked]]On Behalf Of ext
>         Khosravi, Hormuzd M
>         Weiming started a private discussion with Jamal and myself
>         over the weekend regarding renewing of protocol drafts and it
>         has turned into a useful discussion of how to make some quick
>         progress on the protocol. Both Jamal and myself are concerned
>         that we have Not made good progress so far on this team.
>         
>          
>         

This seems to be the simplest one. You can pick something else.

>         [<Ramg>]  This needs to be discussed.

yes. The whole TML needs discussion.

>          2. HA 
>         
>         
>         [<Ramg>]  Commonly used mechanism are CE-CE and its outside
>         the scope. But we need to make sure that the protocol can
>         accomudate both FE-CE and also CE-CE (and not sure of FE-FE
>         scenario's - typically done in hardware).
>         

I posted a little text a while back with some details on several
alternatives. In there i mention what i thought was a part the protocol
plays.

>         d. Protocol scenarios ( operations)

Sounds to me like b, c,a, d is the right sequence.

cheers,
jamal

_______________________________________________
Forces-protocol mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/forces-protocol