Subject: [netext] review of draft-ietf-netext-pmipv6-sipto-option-03

From: Marco Liebsch <[email-masked]>
Date: Thu, 2 Feb 2012 13:26:33 +0000

Please find some comments about the 3rd revision of draft-ietf-netext-pmipv6-sipto-option-03
below.

- Sect 1. Intro, 2nd paragraph: ..IP flows that needs to be.. -> ..that need to be..

- Sect 3. First paragraph: ..HTTP flows may be be offload.. -> ..may be offload..

- Sect 3. Second paragraph: talks about the traffic selector attributes which can be matched
against the fields in the 'IP packet header'. As the TS includes attributes from the
transport header or even deeper in the packet, matching against IP header is not
sufficient. Just write 'matched against the header fields in the data packets'.
Seems less confusing.

- Page 5, reference to the figure 1 should be a reference to Figure 2, as the text
mentions. 'operational sequence'. Then a reference to Figure 1 is missing, which
I would include to the first paragraph of Section 3.

Same page and paragraph: '..access link are not show here' -> '..not shown here..'

General comment:

The current procedure assumes pretty static offload rules. These can be either
recommended by the MAG and approved by the LMA or the LMA provides the
rules. Something like 'all port 80 traffic to be offloaded ', etc. This does not allow
a decision on a flow basis, as the rules are established with the PBU/PBA where no
flow has been initiated yet. Hence, beside well-known ports, information about
port numbers for TS is rather limited.

Maybe an extended use of the proposed option makes sense to support
dynamic decisions about traffic offload. After registration, the MAG may receive
an uplink packet of a new flow and takes decision about an offload policy or requests
the policy from the LMA. The same options can be used (now ports are clear), but
an additional PBU/PBA need to be sent to establish the dynamic rule. The specification
could just consider this in the MAG/LMA operations section.

marco

---

From: Sri Gundavelli <[email-masked]>
Date: Thu, 02 Feb 2012 11:38:08 -0800

Hi Marco:

Thanks for the review. Inline.

On 2/2/12 5:26 AM, "Marco Liebsch" <[email-masked]> wrote:

> [Sri] OK
> [Sri] OK
> against the fields in the ŒIP packet header¹. As the TS includes attributes
> from the
> sufficient. Just write Œmatched against the header fields in the data
> packets¹.
> Seems less confusing.
> 
> [Sri] OK
>  
> 
> mentions. Œoperational sequence¹. Then a reference to Figure 1 is missing,
> which
> [Sri] OK. Thanks for catching this.
> 
> 
>  
> Same page and paragraph: Œ..access link are not show here¹ -> Œ..not shown
> here..¹
> 
> 
> [Sri] OK
>  
> General comment:
>  
> rules. Something like Œall port 80 traffic to be offloaded ¹, etc. This does
> not allow
> [Sri] I agree as well. We need to be able to change the rules dynamically.  I
> was planning to make that change.
> 
> Thanks for the review.
> 
> 
> Regards
> Sri
>