Subject: [Agentx] AgentX and draft-ietf-v6ops-ipv4survey-ops-00.txt

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 19 Feb 2003 12:31:07 -0800

Hi -

The analysis of AgentX protocol in this I-D is incorrect.
The ability to represent an IPv4-specific data type is necessary
to the protocol's operation, and has no bearing whatsover on
its ability to represent IPv6 addresses or operate in IPv6
environments.

Section 5.091 should be replaced with "There are no IPv4 dependencies
in this protocol."  Section 7.3.26 should state that there are no issues.

Randy

> From: <[email-masked]>
> To: <IETF-Announce:>
> Cc: <[email-masked]>
> Sent: Wednesday, February 19, 2003 4:11 AM
> Subject: I-D ACTION:draft-ietf-v6ops-ipv4survey-ops-00.txt
>

> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the IPv6 Operations Working Group of the IETF.
>
> Title : Survey of IPv4 Addresses in Currently Deployed IETF
>                           Operations & Management Area Standards
> Author(s) : P. Nesser II
> Filename : draft-ietf-v6ops-ipv4survey-ops-00.txt
> Pages : 0
> Date : 2003-2-14
>
> This document seeks to document all usage of IPv4 addresses in currently
> deployed IETF Operations & Management Area documented standards.  In order to successfully transition from an all IPv4 Internet to
an all IPv6 Internet, many interim steps will be taken. One of these steps is the evolution of current protocols that have IPv4
dependencies.  It is hoped that these protocols (and their implementations) will be redesigned to be network address independent,
but failing that will at least dually support IPv4 and IPv6.  To this end, all Standards (Full, Draft, and Proposed) as well as
Experimental RFCs will be surveyed and any dependencies will be documented.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-v6ops-ipv4survey-ops-00.txt
>
> To remove yourself from the IETF Announcement list, send a message to
> ietf-announce-request with the word unsubscribe in the body of the message.
>
> Internet-Drafts are also available by anonymous FTP. Login with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> "get draft-ietf-v6ops-ipv4survey-ops-00.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
> [email-masked].
> In the body type:
> "FILE /internet-drafts/draft-ietf-v6ops-ipv4survey-ops-00.txt".
>
> NOTE: The mail server at ietf.org can return the document in
> MIME-encoded form by using the "mpack" utility.  To use this
> feature, insert the command "ENCODING mime" before the "FILE"
> command.  To decode the response(s), you will need "munpack" or
> a MIME-compliant mail reader.  Different MIME-compliant mail readers
> exhibit different behavior, especially when dealing with
> "multipart" MIME messages (i.e. documents which have been split
> up into multiple messages), so check your local documentation on
> how to manipulate these messages.
>
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

---

From: "Philip J. Nesser II" <[email-masked]>
Date: Wed, 19 Feb 2003 14:16:10 -0800

Randy,

Thanks.  I will make updates in the -01 version.  The whole goal is
to solicit input from the people who have a much more intimate
knowledge of individual protocols than I do.  It has been a daunting
task and it is hard to fit everything together when you are trying to
digest 900 or so protocol documents.  I really appreciate your time
to read through the document and make your comments.

I am currently taking input from (hopefully) a lot of independent
sources and putting then all together.  

- --->  Phil

> -----Original Message-----
> From: Randy Presuhn [mailto:[email-masked]]
> Sent: Wednesday, February 19, 2003 12:31 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: AgentX and draft-ietf-v6ops-ipv4survey-ops-00.txt
> 
> Hi -
> 
> Section 5.091 should be replaced with "There are no IPv4
> dependencies in this protocol."  Section 7.3.26 should state that
> there are no issues.  
> 
> Randy
> 
> > A New Internet-Draft is available from the on-line
> > Internet-Drafts 
> directories.
> > This draft is a work item of the IPv6 Operations Working Group of
> > the 
> IETF.
> >
> > This document seeks to document all usage of IPv4 addresses in
> > currently deployed IETF Operations & Management Area documented
> > standards.  In 
> order to successfully transition from an all IPv4 Internet to
> an all IPv6 Internet, many interim steps will be taken. One of
> these steps is the evolution of current protocols that have IPv4
> dependencies.  It is hoped that these protocols (and their
> implementations) will be redesigned to be network address
> independent, but failing that will at least dually support IPv4 and
> IPv6.  To this end, all Standards (Full, Draft, and Proposed) as
> well as
> > http://www.ietf.org/internet-drafts/draft-ietf-v6ops-ipv4survey-op
> > s- 
> 00.txt
> >
> > To remove yourself from the IETF Announcement list, send a
> > message to ietf-announce-request with the word unsubscribe in the
> > body of the 
> message.
> >
> > Internet-Drafts are also available by anonymous FTP. Login with
> > the 
> username
> > "anonymous" and a password of your e-mail address. After logging
> > in, type "cd internet-drafts" and then
> > a MIME-compliant mail reader.  Different MIME-compliant mail
> > readers exhibit different behavior, especially when dealing with

---

From: "Philip J. Nesser II" <[email-masked]>
Date: Wed, 19 Feb 2003 14:16:10 -0800

Randy,

- --->  Phil