Subject: [Agentx] Relocation Errorin AgentX SNMP

From: [email-masked]
Date: Sat, 3 Jan 2004 19:34:18 +0530

Hi all,
 
As a part of my project I need to implement some SNMP communication
between the Agent and Manager . 
I am working on the sample examples given in the net-snmp.org site . 
 
I downloaded the code and manage to compile successfully. But while
running the executable I am getting the following error.
This error is coming when I issue  a snmpget or snmpwalk command from
the manager .

Agent side 
---------------
 [root@linuxserver code]# ./example-demon
./example-demon: relocation error: /usr/lib/libnetsnmpagent.so.5:
undefined symbol: hosts_ctl
 
manager side
-------------------
 
[root@linuxserver code]# snmpwalk  -v2c -c public localhost
.1.3.6.1.4.1.8072.2.4.1.1.2.0
Error in packet.
Reason: (genError) A general failure occured
Failed object: NET-SNMP-MIB::netSnmp.2.4.1.1.2.0
                                                              
NET-SNMP-MIB::netSnmp.2.4.1.1.2.0 = No Such Object available on this
agent at this OID

Would you please guide me to resolve the issue .
Any type of help will be appreciated . 
 
Thanks and regards,
Saurabh Mahapatra
Nortel Esn:6-877-8955
PBX:080-8520408 Extn:3358

---

From: "Randy Presuhn" <[email-masked]>
Date: Sat, 3 Jan 2004 11:53:54 -0800

Hi -

Your question is about a specific implementation of the AgentX
protocol, rather than about the protocol itself.  I suggest you send
your query to the appropriate net-snmp.org mailing list, rather than
this one.

Randy

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Sent: Saturday, January 03, 2004 6:04 AM
Subject: [Agentx] Relocation Errorin AgentX SNMP

Hi all,

Agent side
---------------

manager side
-------------------

Thanks and regards,
Saurabh Mahapatra
Nortel Esn:6-877-8955

---

From: "Randy Presuhn" <[email-masked]>
Date: Sat, 3 Jan 2004 11:53:54 -0800

Hi -

Randy

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Sent: Saturday, January 03, 2004 6:04 AM
Subject: [Agentx] Relocation Errorin AgentX SNMP

Hi all,

Agent side
---------------

manager side
-------------------

Thanks and regards,
Saurabh Mahapatra
Nortel Esn:6-877-8955