Subject: [Anima-bootstrap] meeting notes 10/7

From: "Max Pritikin (pritikin)" <[email-masked]>
Date: Wed, 7 Oct 2015 15:46:17 +0000

We discussed specific sections of the document update I loaded yesterday.

AI: Max to add the figure2 changes supplied by Michael Behringer (complete)
AI: Toerless to provide text for s3.1.1. Discovery around adjacent AN nodes and using GRASP. 

I updated the git repository with these changes in the doc. 

Attached is a built copy of the draft for those of you who don’t like to rebuild from the xml. This is “pre01” and working toward a submit on the deadline so PLEASE read and provide comments/text. 

- max

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 8 Oct 2015 08:39:31 +1300

> AI: Toerless to provide text for s3.1.1. Discovery around adjacent AN nodes and using GRASP. 

"   3.  MUST: unsecured-GRASP as a link local discovery method?
       [Toerless to provide updated text]"

Here's how I look at it. GRASP is objective-oriented, so we have to model the
bootstrap service as an objective. The next GRASP draft will be in CBOR terms,
so the objective will be described in a GRASP discovery message expressed in
CBOR disgnostic format something like this:
 ["bootstrapks.tcp", 0]
or if you want the whole message:
 [1, 6075274, ["bootstrapks.tcp", 0]]
and the discovery response something like:
 [2, 6075274, h'fd0000000000000128ccdc4c97036781']

bootstrapks.tcp is just a name. It does have to go in the GRASP IANA registry.

6075274 is the GRASP session ID, which is just a weak nonce.

The response content is a naked IPv6 address. CBOR encoding is clever enough that
this is unambiguously an IPv6 locator.

    Brian

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Thu, 8 Oct 2015 08:05:12 +0000

Brian, 

The point I was trying to make with the adjacency table is that that table gets fed by many input vectors, and used by many others. Bootstrap is only one case here. 

If we use GRASP for general discovery, then I wouldn't want to link it to bootstrap. It's a standalone function, which each autonomic nodes does, on a continuous basis. A node needs to know at all times (!) what's around it. If a new node pops up, depending on its state, it'll do different things. 

Michael

> -----Original Message-----
> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: 07 October 2015 21:40
> To: Max Pritikin (pritikin) <[email-masked]>; anima-bootstrap <anima-
> [email-masked]>
> Cc: Toerless Eckert (eckert) <[email-masked]>; Michael Behringer
> (mbehring) <[email-masked]>
> Subject: Re: [Anima-bootstrap] meeting notes 10/7
> 
> 
> 
> bootstrap service as an objective. The next GRASP draft will be in CBOR
> terms, so the objective will be described in a GRASP discovery message
> expressed in CBOR disgnostic format something like this:
>  ["bootstrapks.tcp", 0]
> The response content is a naked IPv6 address. CBOR encoding is clever
> enough that this is unambiguously an IPv6 locator.
> 
>     Brian