Subject: [Anima-bootstrap] bootstrap design team meeting notes Re: [Anima] Adjacency table

From: "Max Pritikin (pritikin)" <[email-masked]>
Date: Wed, 14 Oct 2015 16:01:45 +0000

During today’s bootstrapping design team we discussed the attached thread/image from the anima WG mailing list.

There are 4 points where this table interfaces with the bootstrapping documents as follows:

1) “AN discovery (cloud redirect)” is a possible reference to draft-ietf-anima-bootstrapping-keyinfra [draft-bootstrap]
 Section 3.1.4 discussion of “EST Redirect”. From discussion it appears the ‘redirect’ text is in the wrong place. It will occur during the s3.1.3 “request join” so some of the text needs to be moved to there. Additionally the protocol details section 5.1 needs some discussion of how the redirect occurs.

2) “Bootstrap that node” is a reference to providing proxy behavior as per [draft-bootstrap] section 3.2. [draft-bootstrap] says nothing about providing this service as a result of any the AN adjacency table state and it isn’t clear if there is something to reconcile here. Perhaps [draft-bootstrap] only supports bootstrap for nodes in the adjacency table that have been discovered w/o a domain or perhaps it provides bootstrap for any node. My personal preference is for the later as it doesn’t imply state but the design team discussion is not complete.

3) “I bootstrap” is a reference to a New Entity initiating bootstrap functionality. This is the start of the [draft-bootstrap] s3.1 state diagram and initiates the discovery functionality described in s3.1.1.

4) “Non-autonomic inputs” is a possible reference to [draft-bootstrap] s5.3 “basic configuration information package”. This is effectively only a placeholder w/in the current document and feedback is solicited.

I’ll be making changes as per (1) above as well as attempting to add a figure to s5 that provides a more detailed view of figure2 (see s3) that includes more protocol details.

Also discussed was to ensure bootstrap has an agenda point during the IETF94 proceedings.

- max

On Oct 7, 2015, at 9:54 AM, Michael Behringer (mbehring) <[email-masked]<mailto:[email-masked]>> wrote:

ANIMA WG,

In the latest version of the ACP draft, I was trying to be clearer on what triggers ACP creation. While thinking about this I came to the conclusion that practically all operations in ANIMA today are really focused around an adjacency table, which I now list in section 5.1 (precondition).

Also in the bootstrap design team call just now, same thing: What triggers a bootstrap action? And again, it’s really anchored around the adjacency table.

Since this seems a pretty important concept (although quite simple, really), I wanted to illustrate how this all fits together in my mind:

There are processes feeding the adjacency table; there are processes triggered by it. Discovery feeds the table. But there are also potential other input vectors. Depending on the state of the device, and what it sees in the table, different things happen. And there we go into the bootstrap draft, the ACP draft, or potentially others.

I guess the reference model should explain this table, because it really links all the documents together, in a way. v

Does this make sense to everyone? Any things that don’t seem right? Thoughts?

Michael

_______________________________________________
Anima mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/anima

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Wed, 14 Oct 2015 16:39:41 +0000

And here is the updated figure (not complete yet, need to think a bit more about some bits, especially the re-direct). I now also put in references to where the corresponding topic is discussed.

To me, this picture explains the big “how it all fits together”, which element feeds which other element. Again, the adjacency table is the pivotal piece at this stage, and it is really important that we drive to a common understanding here.

I’d really appreciate more discussion. For Yokohama I’ll prepare this slide in more detail, going through the life cycle of an autonomic device.

Michael

From: Max Pritikin (pritikin)
Sent: 14 October 2015 18:02
To: Anima WG <[email-masked]>; anima-bootstrap <[email-masked]>
Cc: Michael Behringer (mbehring) <[email-masked]>
Subject: bootstrap design team meeting notes Re: [Anima] Adjacency table

- max

ANIMA WG,

Michael