Subject: [Anima-bootstrap] notes from 3/3

From: "Max Pritikin (pritikin)" <[email-masked]>
Date: Thu, 3 Mar 2016 22:02:23 +0000

raw notes from the call today. Plan is to update doc as per these and push the -02 (to obtain more formal feedback) early next week.

thx,

- max

s1.2

intended to call out that fragmentation issues make this fail on deployments that can’t handle that. such as the LLN that SHOULD NOT. 

it isn’t the protocol -- its the necessary size of the messages. 

section 3.2.3
pull
move I-D reference to the top of section.

s3 
need text indicating that communication between proxy and registar is up to the proxy and the registrar. 
we need to state the ‘mandatory to implement’ protocol.
need 3.2.x “how proxy discovers registrar needs to be indicated”
	need an equivalent statement about how the registrar responds to that.

need to make it clear that the proxy is not terminating the CoAP connection

we maintain 3.2.1 and 3.22 so we support HTTP and CoAP and we’ll need to add sections in 5.x how to encapsulate into CoAP with block transfer.
Add section and text w/ pointers about how to use CoAP and block transfer. black transfer should be going into last call. 

3.2.2.
the registrar MUST accept the CONNECT. 

3.2.x
need section describing how the proxy discovers the register 
	using GRASP is possibility
	the proxy will discover the address of the registrar through reference
	(prefix allocation document might provide a more complex example. ours should be easier).

---

From: peter van der Stok <[email-masked]>
Date: Mon, 07 Mar 2016 09:14:19 +0100

Hi Max,

Not having the section in front of me I do a guess about the number.

My remark was to put in section 3.2? a phrase like:
The new node sends an unprotected link-local CoAP request to the proxy. 
The proxy forwards the request over a protect IP-IP connection to the 
registrar.

Current;y, there is text about proxy and registrar but not on new node.

Greetings,

Peter

Max Pritikin (pritikin) schreef op 2016-03-03 23:02:
> raw notes from the call today. Plan is to update doc as per these and
> push the -02 (to obtain more formal feedback) early next week.
> 
> thx,
> 
> - max
> 
> s1.2
> 
> intended to call out that fragmentation issues make this fail on
> deployments that can’t handle that. such as the LLN that SHOULD NOT.
> 
> we maintain 3.2.1 and 3.22 so we support HTTP and CoAP and we’ll need
> to add sections in 5.x how to encapsulate into CoAP with block
> transfer.
> Add section and text w/ pointers about how to use CoAP and block
> transfer. black transfer should be going into last call.
> 
> 3.2.2.
> _______________________________________________
> Anima-bootstrap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima-bootstrap

---

From: "Max Pritikin (pritikin)" <[email-masked]>
Date: Mon, 7 Mar 2016 18:52:36 +0000

Thanks Peter. I think I have this covered in the new text I just pushed to the git repository. 

- max

> On Mar 7, 2016, at 1:14 AM, peter van der Stok <[email-masked]> wrote:
> 
> Hi Max,
> 
> The new node sends an unprotected link-local CoAP request to the proxy. The proxy forwards the request over a protect IP-IP connection to the registrar.
>