Subject: [Dcrup] dkim bleeding-edge

From: Jeremy Harris <[email-masked]>
Date: Sat, 9 Sep 2017 12:39:58 +0100

Does anyone have an MTA running with DKIM rsa-sha512 support?

I need a test target for Exim development,
and Mail::DKIM::Signer isn't there yet.
-- 
Thanks,
  Jeremy

---

From: Scott Kitterman <[email-masked]>
Date: Sat, 09 Sep 2017 15:56:25 +0000

>and Mail::DKIM::Signer isn't there yet.

rsa-sha512 isn't used in DKIM and I don't believe there are any plans for it.

Scott K

---

From: Jeremy Harris <[email-masked]>
Date: Sat, 9 Sep 2017 17:04:13 +0100

> rsa-sha512 isn't used in DKIM and I don't believe there are any plans for it.

See
https://tools.ietf.org/html/draft-srose-dkim-ecc-00

-- 
Cheers,
  Jeremy

---

From: Scott Kitterman <[email-masked]>
Date: Sat, 09 Sep 2017 17:09:00 +0000

>https://tools.ietf.org/html/draft-srose-dkim-ecc-00

See https://datatracker.ietf.org/doc/draft-ietf-dcrup-dkim-crypto

The working group is focused on Ed25519-SHA256 for future crypto.

Scott K