Subject: [Hipsec] Noticed a 2012 patent application with respect to HIP and HIT handling -- has patent sillyness started for HIP?

From: Darren Lissimore <[email-masked]>
Date: Tue, 12 Jun 2012 13:49:58 -0700

Ran across this patent application while looking for a HIP reference,

http://www.freepatentsonline.com/y2012/0072513.html

pertains to new HIT delivery.

Hope this is not the start of patent sillyness for all things HIP related.

Anyone seen this can care to comment?

Darren
-----------------------------------------------------------
D. Lissimore             Cell: 778-387-4039
http://www.darrenlissimore.com
Skype: darrenlissimore
-----------------------------------------------------------
This communication is intended for the use of the recipient to which
it is addressed, and may contain confidential, personal, and or
privileged information. Please contact the sender immediately if you
are not the intended recipient of this communication, and do not copy,
distribute, or take action relying on it. Any communication received
in error, or subsequent reply, should be deleted or destroyed.

---

From: Miika Komu <[email-masked]>
Date: Wed, 13 Jun 2012 07:59:58 +0300

Hi,

althought the patent does not mention privacy, the patent appears to be 
about changing the HITs (not really about IP addresses). This further 
points out to the sketchy UPDATE portion of blind-based privacy:

http://tools.ietf.org/html/draft-zhang-hip-privacy-protection-03#section-4.2

I should note that there's predating related prior art on changing HITs 
from 2004:

http://hipl.infrahip.net/papers/appmob.pdf

"Application Mobility with HIP": Teemu Koponen, Andrei Gurtov, Pekka 
Nikander

On 06/12/2012 11:49 PM, Darren Lissimore wrote:
> _______________________________________________
> Hipsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hipsec

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 13 Jun 2012 14:40:02 +0300

The subject header of the message says: "has patent sillyness started for HIP"? 

--> If you only search for Pekka Nikander in the patent archive you will find lots of patents on HIP. 
So, the answer is "yes" and a long time ago already. 

Regarding your assessment of the patent you need to know that it does not matter whether you think a patent is valid or not the opinion of a judge matters in a patent dispute.

Ciao
Hannes

On Jun 13, 2012, at 7:59 AM, Miika Komu wrote:

> Hi,
> 
> althought the patent does not mention privacy, the patent appears to be about changing the HITs (not really about IP addresses). This further points out to the sketchy UPDATE portion of blind-based privacy:
> 
> I should note that there's predating related prior art on changing HITs from 2004:
> 
> "Application Mobility with HIP": Teemu Koponen, Andrei Gurtov, Pekka Nikander
>