Subject: [Idnet] Benefits of Introducing AI into Network

From: Sheng Jiang <[email-masked]>
Date: Wed, 10 May 2017 02:53:20 +0000

In ETSI NGP ISP, we have an Work Item for IDN (Intelligence-Defined Network). In one of the general sections, We briefly describes the benefits of introducing AI into network, as below.

-          Towards Fully Autonomic Network

-          Ability of Handling Complex Issues

-          More Adaptive and Flex

-          Predictive

-          Potential Self-Evolving Ability

-          Potential Decision Efficiency

If there are major benefits that we have not covered, we would like to include.

Regards,

Sheng

---

From: Ing-Jyh Tsang <[email-masked]>
Date: Wed, 10 May 2017 08:23:36 +0200

Is it possible to give a brief (or detail) description of each o the topic?

On 10/05/2017 04:53, Sheng Jiang wrote:
>
> In ETSI NGP ISP, we have an Work Item for IDN (Intelligence-Defined 
> Network). In one of the general sections, We briefly describes the 
> benefits of introducing AI into network, as below.
>
> -Towards Fully Autonomic Network
>
> -Ability of Handling Complex Issues
>
> -More Adaptive and Flex
>
> -Predictive
>
> -Potential Self-Evolving Ability
>
> -Potential Decision Efficiency
>
> _______________________________________________
> IDNET mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idnet

---

From: Manav Bhatia <[email-masked]>
Date: Wed, 10 May 2017 11:58:50 +0530

I agree, since the benefits listed are quite generic and appears to give
the impression that AI is the panacea to all the problems, which it clearly
is not. One problem that I have with all such discussions is that these are
quite vague and we tend to talk from a 20,000 feet distance. The devil is
in the details. I agree that AI can help us with being able to predict
events. What i dont know is even at a high level how one gets there. Can we
spend some time discussing that as well?

Thanks, Manav

On Wed, May 10, 2017 at 11:53 AM, Ing-Jyh Tsang <
[email-masked]> wrote:

> Network). In one of the general sections, We briefly describes the benefits
> of introducing AI into network, as below.
>
>
>
> IDNET mailing [email-masked]://www.ietf.org/mailman/listinfo/idnet
>
>
>

---

From: yanshen <[email-masked]>
Date: Wed, 10 May 2017 12:04:50 +0000

Dear Ing-Jyh Tsang and all,

There is some personal thought of these topics. Comments and suggestions are most welcome!

--Towards Fully Autonomic Network

        The advantage (or say aim) of a fully autonomic network is implementing the close-ring of “Sensing-Analysis-Decision”, which will minimize the input of manual labor in the pure operating actions (without analysis). In current, the process of sensing, analysis and decision are independent to each other and the cooperation of these is depend on manual work. The shortage is caused by the lack of analysis ability of network, which is exactly AI technology is good at.

--Ability of Handling Complex Issues

        The machine learning (ML) method is one of the best way to solve the complex problems, such as classifying problems and optimal decision problems. In network area, the problems that related to resource management and route decision are typically complex. The introducing of AI method essentially build up a centralized analysis system which may provide a global view solution for the network, which cannot (or difficult) be implemented with the current highly distributed architecture. A centralized architecture may not solve all problems but it is indeed a good supplement for nowadays network.

--More Adaptive and Flex

       The ML model can output different policies according to the input training data. Each domain of network may own different characters (e.g. different traffic character). It is possible to provide adaptive solution for different situation via uniform train model.

--Predictive

        Prediction is one of the most important attribute that AI technology brings. On one hand, the prediction (e.g. traffic prediction or failure prediction) that produced by AI algorithm can make the network manager preventing the risky failure and nip the problem in the bud. It will reduce the risk of network fault so that the cost of recovering from the failure. On the other hand, the prediction can be also used to evaluate the reliability of network policy. For example, to evaluate what is the probability of a VPN route is faced with congestion.

--Potential Self-Evolving Ability

        The ML method is self-evolving, which may provide same attribute to network. According to training the network decision model continuously, the network can match the change of service and traffic. Actually, the optimization is just the process that modifying the network parameters to match the requirement. The self-evolving feature of ML method may bring the same ability to the network.

--Potential Decision Efficiency

        The machine learning algorithm can solve the decision problems which has been verified in other area (e.g. AlphaGo). It will be valuable to train a decision model of network that input the current state and output corresponding policies (e.g. device configuration parameters). This model may configure the network device directly when necessary or provide probable configurations as choices when doubt. Both of them will save the time and cost and make the decision process toward efficient.

Yansen
Huawei Technologies Co., Ltd.
[Company_logo]
Cellphone ：+86-13488809882<tel:+86%20134%208880%209882>
Email ：[email-masked]<mailto:[email-masked]>
________________________________

This e-mail and its attachments contain confidential information from HUAWEI, which
is intended only for the person or entity whose address is listed above. Any use of the
information contained herein in any way (including, but not limited to, total or partial
disclosure, reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!

发件人: IDNET [mailto:[email-masked]] 代表 Ing-Jyh Tsang
发送时间: 2017年5月10日 14:24
收件人: Sheng Jiang <[email-masked]>; [email-masked]
主题: Re: [Idnet] Benefits of Introducing AI into Network

-          More Adaptive and Flex

-          Predictive

Regards,

Sheng

IDNET mailing list

[email-masked]<mailto:[email-masked]>

---

From: David Meyer <[email-masked]>
Date: Wed, 10 May 2017 05:34:20 -0700

Folks,

I would encourage people to ask the question: How does <this> actually
work?

where <this> are claims being made about AI and what it might do. If we
can't answer this basic question then we're off on the wrong foot. We need
to understand the technical details of how different techniques work in
order to be successful. This has been proven out time and time again in
both the research community and in industry.  More specifically, falling
prey to the ML hype machine won't serve anyone's purposes.

So when we make wish-lists about what ML might do for us, let's remember to
ask the important questions, such as: what data sets to we have (and what
are their properties), what assumptions are we making, what models are
appropriate, and what are their computation properties (both in training
and inference), to name a few. For example, in the case of something as
simple as PCA (or if you like single hidden layer linear auto-encoder), we
assume linearity, that mean and variance are sufficient statistics, that
large variances have important structure, and that the principle components
(rows of P) are orthogonal. All, some or none of these may be true for a
given network data set.

BTW, even the term AI is being used in inconsistent ways. For the most part
it seems like people are talking about Machine Learning (weak or narrow AI)
as opposed to something like AGI (strong AI). While the problems are
related (weak vs. strong AI, an AGI might use ML techniques), they are in
very different stages of development and have very different properties.

It will serve us well to be precise about what we're talking about.

Dave

On Wed, May 10, 2017 at 5:04 AM, yanshen <[email-masked]> wrote:

>         The advantage (or say aim) of a fully autonomic network is
> implementing the close-ring of “Sensing-Analysis-Decision”, which will
> minimize the input of manual labor in the pure operating actions (without
> analysis). In current, the process of sensing, analysis and decision are
> independent to each other and the cooperation of these is depend on manual
> work. The shortage is caused by the lack of analysis ability of network,
> which is exactly AI technology is good at.
>
>
>
>         The machine learning (ML) method is one of the best way to solve
> the complex problems, such as classifying problems and optimal decision
> problems. In network area, the problems that related to resource management
> and route decision are typically complex. The introducing of AI method
> essentially build up a centralized analysis system which may provide a
> global view solution for the network, which cannot (or difficult) be
> implemented with the current highly distributed architecture. A centralized
> architecture may not solve all problems but it is indeed a good supplement
> for nowadays network.
>
>
>
> --More Adaptive and Flex
>
>
>
>        The ML model can output different policies according to the input
> training data. Each domain of network may own different characters (e.g.
> different traffic character). It is possible to provide adaptive solution
> for different situation via uniform train model.
>
>
>
> --Predictive
>
>
>
>         Prediction is one of the most important attribute that AI
> technology brings. On one hand, the prediction (e.g. traffic prediction or
> failure prediction) that produced by AI algorithm can make the network
> manager preventing the risky failure and nip the problem in the bud. It
> will reduce the risk of network fault so that the cost of recovering from
> the failure. On the other hand, the prediction can be also used to evaluate
> the reliability of network policy. For example, to evaluate what is the
> probability of a VPN route is faced with congestion.
>
>
>
>         The ML method is self-evolving, which may provide same attribute
> to network. According to training the network decision model continuously,
> the network can match the change of service and traffic. Actually, the
> optimization is just the process that modifying the network parameters to
> match the requirement. The self-evolving feature of ML method may bring the
> same ability to the network.
>
>
>
>         The machine learning algorithm can solve the decision problems
> which has been verified in other area (e.g. AlphaGo). It will be valuable
> to train a decision model of network that input the current state and
> output corresponding policies (e.g. device configuration parameters). This
> model may configure the network device directly when necessary or provide
> probable configurations as choices when doubt. Both of them will save the
> time and cost and make the decision process toward efficient.
>
>
>
> Yansen
>
> Cellphone ：+86-13488809882 <+86%20134%208880%209882>
> Email ：[email-masked]
> ------------------------------
>
>
> *发件人:* IDNET [mailto:[email-masked]] *代表 *Ing-Jyh Tsang
> *发送时间:* 2017年5月10日 14:24
> *收件人:* Sheng Jiang <[email-masked]>; [email-masked]
> *主题:* Re: [Idnet] Benefits of Introducing AI into Network
>
>
>

---

From: yanshen <[email-masked]>
Date: Thu, 11 May 2017 01:03:07 +0000

Thank you David.

Really good suggestion for planning a new blue map.

I think it is just the significant to speak out all things possible.  The introspection after advancing will be always valuable.

Yansen

发件人: David Meyer [mailto:[email-masked]]
发送时间: 2017年5月10日 20:34
收件人: yanshen <[email-masked]>
抄送: Ing-Jyh Tsang <[email-masked]>; [email-masked]
主题: Re: [Idnet] 答复: Benefits of Introducing AI into Network

Folks,

I would encourage people to ask the question: How does <this> actually work?

where <this> are claims being made about AI and what it might do. If we can't answer this basic question then we're off on the wrong foot. We need to understand the technical details of how different techniques work in order to be successful. This has been proven out time and time again in both the research community and in industry.  More specifically, falling prey to the ML hype machine won't serve anyone's purposes.

So when we make wish-lists about what ML might do for us, let's remember to ask the important questions, such as: what data sets to we have (and what are their properties), what assumptions are we making, what models are appropriate, and what are their computation properties (both in training and inference), to name a few. For example, in the case of something as simple as PCA (or if you like single hidden layer linear auto-encoder), we assume linearity, that mean and variance are sufficient statistics, that large variances have important structure, and that the principle components (rows of P) are orthogonal. All, some or none of these may be true for a given network data set.

BTW, even the term AI is being used in inconsistent ways. For the most part it seems like people are talking about Machine Learning (weak or narrow AI) as opposed to something like AGI (strong AI). While the problems are related (weak vs. strong AI, an AGI might use ML techniques), they are in very different stages of development and have very different properties.

Dave

On Wed, May 10, 2017 at 5:04 AM, yanshen <[email-masked]<mailto:[email-masked]>> wrote:
Dear Ing-Jyh Tsang and all,

--More Adaptive and Flex

--Predictive

Yansen

发件人: IDNET [mailto:[email-masked]<mailto:[email-masked]>] 代表 Ing-Jyh Tsang
发送时间: 2017年5月10日 14:24
收件人: Sheng Jiang <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
主题: Re: [Idnet] Benefits of Introducing AI into Network

-          More Adaptive and Flex

-          Predictive

Regards,

Sheng

IDNET mailing list

---

From: Javier Antich Romaguera <[email-masked]>
Date: Thu, 11 May 2017 01:38:13 +0000

Hi folks,
  Apologizes in advance, I do not mean to be rude, but what´s the purpose of this discussion? I mean, where does this lead us into exactly?
  I think it is clear and we all agree on the potential benefits of AI/ML categories of techniques to our networking world, and some of the potential benefits have been already stated. I do not think we need to re-emphasize them.
  I wonder what is exactly the mission here, other than sharing thoughts and experiences, is there anything here that in the context of IETF can/should be done, specified, prescribed to facilitate the introduction or leverage of AI/ML techniques?
  I think it would be good if first we list, detail or even prioritize specific use cases where this can be used. Not generic benefits but specific use cases, specific pain points that could be addressed which previously, with other techniques could not be [properly] addressed.
  This is ultimately about network elements (of different sorts) that generate some kind of data, which will be streamed in some kind of format, which will be collected by some kind of platform, stored in some kind of data store, queried and processed by some kind of engine, using some kind of advanced algorithm, and visualized or used as an input for some other processing or eventually action back to the network.
  What is it that needs to be done from IETF perspective to facilitate this to happen? What is networking specific or what is “just” generic data processing. Once data (telemetry) leaves the network this essentially becomes a generic data analysis problem that  "happens to be related" to the network, but conceptually is not different than any other data processing problem. What of this may need to be specified/defined/recommended from an IETF point of view? (if anything).
- Definitely seems like Data Models are a relevant aspect, but many of those are already being specified on other contexts, either within IETF or other bodies. Is there any gap that needs to be addressed?
- Definitely the aspect of the “action back” to the network is relevant, so there may be common mechanisms defined.
- For the rest, is there anything that we can be prescriptive about or define from an architectural point of view? It is all entirely dependent on the application or use case. A use case related to network troubleshooting may need a real time characteristic that would require a set of capabilities. But other use cases related to capacity optimization, might not require the same. I highly doubt we can prescribe or specify anything on this layers, not sure what arguments could be used.
  Then, is there anything that can be done from this forum to facilitate this?
- Few things were mentioned in the past:
* Lack of a useful theory of networking:  isn´t it about modeling? What models are missing?
* Lack of publicly available data sets. Not every industry has publicly available data sets and that does not prevent them from moving forward in the applicability of these techniques. Networks can generate a lot of data to work with, in very few time, so I do not see this being necessarily a blocker. Could be a nice thing to have. But is there any actionable item here?
* Lack of skills: no different than in any other Industry that plans to use these techniques. Not sure if there is any action item on this respect. We need to start small, use knowledge where exists, and learn step by step.
    There are already solutions on our networking space that make use of ML/AI, none of the above seems to be a blocker. What is it that needs to be enhanced? what is it required to ensure multivendor support? what is it required to enable multiple applications from different sources to consume data from the network?
       Would like to understand what the actual next steps may be for this forum.

Thanks
Javier
______________________________________________
Javier Antich Romaguera
Product Line Manager. JUNOS Team.
Juniper Networks
email: [email-masked]<mailto:[email-masked]>
m. +34639218428
“Achieving the difficult, trying the impossible"

From: IDNET <[email-masked]<mailto:[email-masked]>> on behalf of David Meyer <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, May 10, 2017 at 2:34 PM
To: yanshen <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Ing-Jyh Tsang <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idnet] 答复: Benefits of Introducing AI into Network

Folks,

Dave

--More Adaptive and Flex

--Predictive

Yansen

-          More Adaptive and Flex

-          Predictive

Regards,

Sheng

IDNET mailing list