Subject: Re: [lisp] LISP errors

From: [email-masked] (Noel Chiappa)
Date: Thu, 30 Apr 2009 13:25:10 -0400 (EDT)

> From: Olivier Bonaventure <[email-masked]>

    > The protocol spec will also need to discuss how an xTR will behave upon
    > reception of an ICMP message.

And also how the xTR can make sure the ICMP message is not spurious, and
intended to perform a DoS attack.

Etc, etc.

My instinct would be to leave dealing with a lot of this until we have some
more operation experience to make sure the whole direction is worthwhile -
i.e. that lookup delays are tolerable, mapping caching behaviour plausible,
etc, etc.

Sure, if we run into _operational_ issues with our field trial that require
them, then by all means we should go ahead and spec the ones we need for that
right away. Otherwise, they can probably wait for a bit...

	Noel

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 30 Apr 2009 10:50:52 -0700

There seems to be points for discussion on both sides of
the coin regarding whether/not LISP errors are needed, and
I think I agree with what I hear others saying which is that
we don't have to solve it all right now. I don't have time
right now to work up an exhaustive list of LISP errors (but
see the short list in my previous message), but I'd like to
add one thought for now to see if it sheds more light on
the considerations.

Consider the ITR and ETR as being the left and right
halves of a unified router that are simply split apart
with an Internet stuck in between them. We can therefore
abstract away the Internet (along with all of its ICMP
"noise"), and consider LISP errors simply as a way for
the right half of the unified router to tell left half
what is going on.

Thanks - Fred
[email-masked]

> -----Original Message-----
> From: Noel Chiappa [mailto:[email-masked]]
> Sent: Thursday, April 30, 2009 10:25 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [lisp] LISP errors
> 
> 
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp