Subject: Re: [lisp] LISP errors

From: [email-masked] (Noel Chiappa)
Date: Thu, 30 Apr 2009 16:03:10 -0400 (EDT)

> From [email-masked]  Thu Apr 30 13:51:11 2009

    > Consider the ITR and ETR as being the left and right halves of a
    > unified router that are simply split apart with an Internet stuck in
    > between them.

Oh, wow, half-gateways - for the elderly among us, those words bring back
memories! (See, e.g., RFC-1009!) :-)

But to be serious, I have previously discussed (on the RRG list, back in
December) my notion that in some sense what we're building is _another_
packet switching layer, one which uses the legacy Internet as a giant NBMA
'local' network underneath it. (An ITR has to run 'routing' to figure out
what the 'next-hop' ETR is, make sure it's not down, etc, etc...)

(When discussing this concept with some other LISP people, I got the sense
that they didn't buy it.... but I still think there's enough truth to it for
it to be a useful mental model! :-)

I'l have to think whether this new model you mention (the half-router one) is
one that brings any useful improvement; right off the top of my head I don't
see any, but my brain is kind of frazzled today. Can you show me any ways in
which the 'half-router' model helps conceptually, in a way the 'new packet
switching layer' one does not?

	Noel

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 30 Apr 2009 13:20:30 -0700

Noel,

Trying to clarify a bit, I'm thinking of the ITR as a
"left-half-router" that can in some sense be thought of
as being paired with an ETR as the "right-half-router"
when the ETR receives a tunneled packet. So, the ITR
will pair with many ETRs (not just one), but the pairing
is temporal and lasts only for the duration of the delivery
of the packet to the ETR's LISP process. At that precise
moment in time, it is as if the ITR and ETR LISP processes
were co-resident within the same physical box and passing
a message via IPC, and the Internet is abstracted away.
So, any errors that need to be conveyed would be specific
to the IPC protocol (in this case, LISP) and not to the
(abstracted away) network layer. 

I'm not trying to claim any originality here; just trying
a conceptual model on for size.

Fred
[email-masked]

> -----Original Message-----
> From: Noel Chiappa [mailto:[email-masked]]
> Sent: Thursday, April 30, 2009 1:03 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [lisp] LISP errors
> 
> 
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 30 Apr 2009 15:47:24 -0700

Noel,

> what the 'next-hop' ETR is, make sure it's not down, etc, etc...)

Regarding NBMA, we have been closely tracking that model
in RANGER/VET/SEAL/ISATAP for about 10 years now. Still,
not meaning to claim originality or the like.

Thanks - Fred