Subject: Re: [lisp] LISP and IPv6

From: [email-masked] (Noel Chiappa)
Date: Mon, 23 May 2011 13:24:44 -0400 (EDT)

> From: "Templin, Fred L" <[email-masked]>

    > If a large site can procure short PI IPv6 prefixes from an Internet
    > registry, and then announce the prefixes into the native IPv6 Internet
    > routing system .. why would the site use LISP instead of just using
    > native IPv6?

LISP does provide some other benefits, e.g. the ability to do optimal entry
selection without having to inject more-specifics.

It's not possible to list them all, though: addition of a fundamental new
architectural capability like separation of location and identity will wind up
being used in ways nobody (or collection of them) can accurately forsee.

	Noel

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 23 May 2011 10:36:07 -0700

Hi Noel,

> being used in ways nobody (or collection of them) can 

I am skeptical that a large site such as a major
enterprise network that participates in BGP routing
on its own behalf would do better to use LISP than
to just use native IPv6. Same for a major Internet
content provider. We have also talked at length in
the past about "identitiy". The LISP "identity" is
an IP address, and IP addresses name interfaces not
end systems. The acronym was and remains a misnomer.

Fred
[email-masked]

---

From: Darrel Lewis <[email-masked]>
Date: Mon, 23 May 2011 10:57:41 -0700

> end systems. The acronym was and remains a misnomer.

Well, not to start this again, but if the interface the IP address names is, say, Loopback0, then you are naming the end system for every practical purpose.

-Darrel

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 23 May 2011 11:10:42 -0700

Hi Darrel, 

> -----Original Message-----
> From: Darrel Lewis [mailto:[email-masked]] 
> Sent: Monday, May 23, 2011 10:58 AM
> To: Templin, Fred L
> Cc: Darrel Lewis; Noel Chiappa; [email-masked]
> Subject: Re: [lisp] LISP and IPv6
> 
> 
> Well, not to start this again, but if the interface the IP 
> address names is, say, Loopback0, then you are naming the end 
> system for every practical purpose.

Not if the end system connects to multiple sites. Then,
the IP address only names one (loopback interface) site
personality of the end system.

Fred

---

From: Darrel Lewis <[email-masked]>
Date: Mon, 23 May 2011 11:25:10 -0700

> personality of the end system.

If the address configured on the loopback is independent of the sites, then the above does not follow.

-Darrel

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 23 May 2011 11:27:14 -0700

Hi Darrel, 

> Sent: Monday, May 23, 2011 11:25 AM
> To: Templin, Fred L
> If the address configured on the loopback is independent of 
> the sites, then the above does not follow.

But if it is not independent of the sites, then it
does follow. LISP "identifiers" name *interfaces*.

Fred