Subject: [lisp] Fwd: New Version Notification for draft-maino-nvo3-lisp-cp-01.txt

From: Fabio Maino <[email-masked]>
Date: Thu, 20 Sep 2012 07:01:15 -0700

This is the draft on LISP Control Plane for NVO3 that we'll present 
later today at the NVO3 interim.

Please use this thread to send comments.

Thanks,
Fabio

-------- Original Message --------
Subject: 	New Version Notification for draft-maino-nvo3-lisp-cp-01.txt
Date: 	Wed, 19 Sep 2012 22:41:50 -0700
From: 	<[email-masked]>
To: 	<[email-masked]>
CC: 	<[email-masked]>, <[email-masked]>, <[email-masked]>

A new version of I-D, draft-maino-nvo3-lisp-cp-01.txt
has been successfully submitted by Fabio Maino and posted to the
IETF repository.

Filename:	 draft-maino-nvo3-lisp-cp
Revision:	 01
Title:		 LISP Control Plane for Network Virtualization Overlays
Creation date:	 2012-09-19
WG ID:		 Individual Submission
Number of pages: 19
URL:             http://www.ietf.org/internet-drafts/draft-maino-nvo3-lisp-cp-01.txt
Status:          http://datatracker.ietf.org/doc/draft-maino-nvo3-lisp-cp
Htmlized:        http://tools.ietf.org/html/draft-maino-nvo3-lisp-cp-01
Diff:            http://www.ietf.org/rfcdiff?url2=draft-maino-nvo3-lisp-cp-01

Abstract:
    The purpose of this draft is to analyze the mapping between the
    Network Virtualization over L3 (NVO3) requirements and the
    capabilities of the Locator/ID Separation Protocol (LISP) control
    plane.  This information is provided as input to the NVO3 analysis of
    the suitability of existing IETF protocols to the NVO3 requirements.

The IETF Secretariat

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 20 Sep 2012 11:23:13 -0700

I would suggest using the word VPN rather than tenant. Because a customer, aka as a tenant, could be part of more than one VPN.

And in service provider networks, these terms and definitions are well known and accepted.

Dino

On Sep 20, 2012, at 11:18 AM, "Reith, Lothar" <[email-masked]> wrote:

> Hi Fabio, Dear all
>  
> I have a couple of observations:
> t
> 1.     The quality of the contribution appears to be excellent, however there is one thing: the text appears to be kind of loose regarding what the LISP Instance ID identifies. While it is not wrong to state that the LISP Instance ID identifies the tenant, such wording is misleading. The LISP Instance ID does not directly identify the tenant. I suggest to more correctly state, that the LISP instance ID identifies a virtual network (this occurs in multiple places throughout the document). Of course there will be somewhere some table mapping the virtual network to a virtual data center, and the virtual data center to a tenant, with whom the virtual datacenter and therefore the virtual network belongs.
> 2.     In that context, I would recommend to the authors of the NVO3 framework document to review the definition of tenant. Is a tenant really a “customer”, or rather a subscriber of a business service, that is authorized by a customer?
> The key question is if adding a  “virtual network” can be subject to a separate subscription (where e.g. different SLAs, pricing, legal conditions etc may apply) or if adding a virtual network can only be done by changing the subscription to a virtual data center service (which has uniform SLAs, pricing, legal conditions etc). According to the framework, the latter appears to apply.
> 3.     And while we are at it: the claim in draft-maino-nvo3-lisp-cp-01.txt that draft-lasserre-nvo3-framework-03.txt has defined key terms such as DC is correct, however, it is not the term DC that is used, but the term “data center network”. And unfortunately, the term data center network is not defined. For example, I am not sure, if the term “data center network” refers to
> a.     the underlay network inside the boundaries of a single DC, including its capability to create virtual data centers comprising multiple VNs, where each VN is confined to the boundary of one DC
> b.    the underlay network potentially spanning the boundaries of multiple DC, including their capability to create virtual data centers spanning multiple DC, and thus VNs spanning multiple DC.
> c.     Something else
>  
> It should be noted that the definition of the term “virtual data center” currently does not specify, if it is confined to one DC or may span multiple DC.
>  
>  
> Best Regards, Lothar
>  
> Detecon International GmbH (Deutsche Telekom group)
>  
>  
>  
>  
> Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Fabio Maino
> Gesendet: Donnerstag, 20. September 2012 16:01
> An: [email-masked]
> Cc: [email-masked]
> Betreff: [nvo3] Fwd: New Version Notification for draft-maino-nvo3-lisp-cp-01.txt
>  
> This is the draft on LISP Control Plane for NVO3 that we'll present later today at the NVO3 interim.
> 
> Subject:
> New Version Notification for draft-maino-nvo3-lisp-cp-01.txt
> Date:
> To:
> <[email-masked]>
> CC:
> <[email-masked]>, <[email-masked]>, <[email-masked]>
>  
> 
> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3

---

From: "Reith, Lothar" <[email-masked]>
Date: Thu, 20 Sep 2012 19:36:01 +0000

Dino,

No, the framework document calls it virtual network, and this term appears to be reasonably well accepted and understood across networking centric and compute centric communities.

One could argue however about whether the definition of "virtual network" in the NVO3-framework document can be improved. I believe yes. 

Lothar

-----Ursprüngliche Nachricht-----
Von: Dino Farinacci [mailto:[email-masked]] 
Gesendet: Donnerstag, 20. September 2012 20:23
An: Reith, Lothar
Cc: Fabio Maino; [email-masked]; [email-masked]
Betreff: Re: [nvo3] Fwd: New Version Notification for draft-maino-nvo3-lisp-cp-01.txt

Dino

On Sep 20, 2012, at 11:18 AM, "Reith, Lothar" <[email-masked]> wrote:

> 2.     In that context, I would recommend to the authors of the NVO3 framework document to review the definition of tenant. Is a tenant really a "customer", or rather a subscriber of a business service, that is authorized by a customer?
> The key question is if adding a  "virtual network" can be subject to a separate subscription (where e.g. different SLAs, pricing, legal conditions etc may apply) or if adding a virtual network can only be done by changing the subscription to a virtual data center service (which has uniform SLAs, pricing, legal conditions etc). According to the framework, the latter appears to apply.
> 3.     And while we are at it: the claim in draft-maino-nvo3-lisp-cp-01.txt that draft-lasserre-nvo3-framework-03.txt has defined key terms such as DC is correct, however, it is not the term DC that is used, but the term "data center network". And unfortunately, the term data center network is not defined. For example, I am not sure, if the term "data center network" refers to
> It should be noted that the definition of the term "virtual data center" currently does not specify, if it is confined to one DC or may span multiple DC.
>  
>  
> Best Regards, Lothar
>