Subject: Re: [lisp] AD Review: draft-ietf-lisp-eid-block

From: Luigi Iannone <[email-masked]>
Date: Mon, 3 Sep 2012 11:55:07 +0200

Hi Brian,

thanks for your reply.

Agreed on the 2119 language. I will delete it and go back on normal language.

I understand as well that the text concerning the prefix size needs to be somehow improved.

Will do both.

On 31 Aug. 2012, at 20:11 , Brian Haberman <[email-masked]> wrote:

[snip]
> 
> 
>> 
>> In addition, I know that all LISP work is marked as "experimental"
>> but let's also keep in mind that there are companies out there that
>> start making business out of LISP.
>> 
> 
> That is their choice.

True, but would be better to not penalise them. They are helping in gaining knowledge on new technology.

> 
>> 
>>> Should there be a termination date for this allocation?
>> 
>> I do not see IPv6 addressing space as a scarce resource, and for the
>> same reasons I cited above I wouldn't put a termination date.
>> 
>> Obviously, IANA may decide to allocate the prefix only for a limited
>> amount of time and decide in few years whether or not to make it a
>> definitive allocation.
>> 
> 
> That is definitely one possibility.
> 

Which the current draft does not prevent.

Thanks again.

Luigi

> Regards,
> Brian

---

From: Luigi Iannone <[email-masked]>
Date: Mon, 3 Sep 2012 11:56:16 +0200

Hi Adrian,

I've got your point.

As I already replied to Brian, the document will be modified to avoid any 2119 language.

ciao

Luigi

On 31 Aug. 2012, at 20:32 , Adrian Farrel <[email-masked]> wrote:

> Hi,
> 
> Just cutting to the discussion of routing...
> 
>>>>     The only suggestion I would make for this document is to drop the
>>>> use of the 2119 language.  It is only used in a few places and those
>>>> uses are not really appropriate for 2119 language.  I would suggest
>>>> re-writing those guidelines with normal prose and drop the 2119
>>>> boilerplate from the document.
>> 
>> We tried not to use so much the 2119 language, but if you think it is better
> to
>> drop it completely, this can be done.
>> 
>> But, what do you think about section 8 "Routing Consideration" ? There, with
>> 2119 language, we recommend that routers that do not support LISP do not
>> handle the prefix in any special way. WOuldn't be better to maintain that
> part?
> 
> I am not sure that this document can mandate the behavior of routers that don't
> support this document. So the use of must/should language in upper or lower case
> seem inappropriate.
> 
> Normally what we do is say: "Implementations that are not aware of this special
> feature will carry on processing as defined in [RFCfoo] with the following
> results..."
> 
> Thanks,
> Adrian
>