Subject: Re: [lisp] Adoption of draft-chiappa-lisp-architecture-01 and draft-chiappa-lisp-introduction-01

From: "Templin, Fred L" <[email-masked]>
Date: Tue, 4 Sep 2012 09:21:16 -0700

I have long maintained that what LISP is calling "EID" is not
really an identifier but rather names a (virtual) interface the
same as any IP address. Therefore, if the node has multiple
independent (virtual) interfaces to which LISP EIDs must be
assigned, it is not possible to say that only one of them is
the "identity" of the endpoint.

RFC4838 illustrates my point, where it defines the term Endpoint
Identifier (EID) as: "a name, expressed using the general syntax
of URIs (see below) that identifies a DTN endpoint". RFC4838
recognizes that an endpoint may connect to multiple Internets
(e.g., the terrestrial Internet as we know it today and an
interplanetary Internet that may come into existence in the future)
where each such Internet may maintain an independent routing and
addressing system. Therefore, an IP address that is relevant in
Internet A may have no relevance in Internets B, C, D, etc. and
cannot therefore be considered the "identity" of the endpoint.

With a namespace like URIs that have nothing to do with routing
and addressing, it is natural to have a single URI identity for
such a "multi-internetted" endpoint. So, an endpoint known as
"xyzzy" in the terrestrial Internet would still be known as
"xyzzy" in any other Internet it might happen to connect to.

I'm not sure I have any specific recommendations relative to
this, but just to observe that the LISP EID is really just an
IP address that only necessarily has relevance within the
terrestrial Internet. A true EID (e.g., in the spirit of
RFC4838) would have to be taken from some "neutral" namespace
that has nothing to do with routing and addressing.

Fred
[email-masked]

---

From: Ronald Bonica <[email-masked]>
Date: Tue, 4 Sep 2012 21:10:53 -0400

Hi Fred,

The term EID bothers me too, but for a different reason. The function of an EID varies depending upon your location with respect the interface that the EID references. If you are behind the same ETR as the referenced interface, the EID both locates and identifies the referenced interface. If you are not behind the same ETR as the referenced interface, the EID only identifies the interface.

At this point, it would be painful to start using a new term. Probably the best that we can do is to point out that the term EID might be a bit of a misnomer.

                                         Ron

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Templin, Fred L
> Sent: Tuesday, September 04, 2012 12:21 PM
> To: Noel Chiappa; [email-masked]
> Subject: Re: [lisp] Adoption of draft-chiappa-lisp-architecture-01 and
> draft-chiappa-lisp-introduction-01
> 
> I have long maintained that what LISP is calling "EID" is not really an
> identifier but rather names a (virtual) interface the same as any IP
> address. Therefore, if the node has multiple independent (virtual)
> interfaces to which LISP EIDs must be assigned, it is not possible to
> say that only one of them is the "identity" of the endpoint.
> 
> Identifier (EID) as: "a name, expressed using the general syntax of
> URIs (see below) that identifies a DTN endpoint". RFC4838 recognizes
> that an endpoint may connect to multiple Internets (e.g., the
> terrestrial Internet as we know it today and an interplanetary Internet
> that may come into existence in the future) where each such Internet
> may maintain an independent routing and addressing system. Therefore,
> an IP address that is relevant in Internet A may have no relevance in
> Internets B, C, D, etc. and cannot therefore be considered the
> "identity" of the endpoint.
> 
> With a namespace like URIs that have nothing to do with routing and
> addressing, it is natural to have a single URI identity for such a
> "multi-internetted" endpoint. So, an endpoint known as "xyzzy" in the
> terrestrial Internet would still be known as "xyzzy" in any other
> Internet it might happen to connect to.
> 
> I'm not sure I have any specific recommendations relative to this, but
> just to observe that the LISP EID is really just an IP address that
> only necessarily has relevance within the terrestrial Internet. A true
> EID (e.g., in the spirit of
> RFC4838) would have to be taken from some "neutral" namespace that has
> nothing to do with routing and addressing.
> 
> Fred
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp