Subject: Re: [lisp] draft-ietf-lisp-architecture: Demand Loading of Mappings

From: [email-masked] (Noel Chiappa)
Date: Wed, 9 Jan 2013 14:05:47 -0500 (EST)

> From: [email-masked]

    > Pull (LISP) versus Push (legacy IP). This discussion confirms that LISP
    > is not and has never been a loc-id-split protocol.

So... LISP+NERD _would_ be a "loc-id-split protocol"?

{Sorry, all, couldn't resist... :-}

	Noel

---

From: [email-masked]
Date: Wed, 9 Jan 2013 17:38:56 -0500 (EST)

We all know a well running loc-id-split solution which is the yellow postal service:  It forwards the letter to the indicated address and deliberately risks an eventually negative  "return to sender, identifier unknown, no such number, no such phone..." i.e. does not waste its capacities with billions of UPDATEs to ensure that any ingress office would know that the potential receiving person really lives at the indicated address. Note, it is not already the egress post office per se, no, it is its mail man standing in front of the addressed door who recognizes that the letter can or cannot be delivered. This means: "loc-id-split" handled in such a way works for a network which is 100,000 or may be 1 million times larger than the internet. 

My TARA (Topology Aggregating Routing Architecture) precisely works that way. It does not waste the routers' capacities with thousands of reachability updates per second. No PUSH and no PULL !!! 

The sender sends the packet, bestowed with destination-identifier (ipv4 addr) and destination-(TARA-)Locator as learned from DNS, which is forwarded to that TARA-site as indicated by this destination-TARA-Locator. There, 3 things may happen: 1) packet can be delivered, 2) a well-scoped broadcast search can be started to look for the roaming destination user all over the local geographical surrounding, 3) or alternatively a negative response.

Running out of IPv4 Unicast addresses, it is however necessary that any (roaming) user owns an IPv4-address which is unique per its "home-geopatch" and that it will be its IPv4-address plus its home-geopatch (2 octets) when roaming.

I hope this also explains why LISP (in spite of its name) is not a loc-id-split solution.

Heiner

-----Ursprüngliche Mitteilung----- 
Von: Noel Chiappa <[email-masked]>
An: lisp <[email-masked]>
Cc: jnc <[email-masked]>
Verschickt: Mi, 9 Jan 2013 8:05 pm
Betreff: Re: [lisp] draft-ietf-lisp-architecture: Demand Loading of Mappings

	Noel
_______________________________________________
lisp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lisp

---

From: [email-masked]
Date: Wed, 9 Jan 2013 17:57:13 -0500 (EST)

sorrry,
two words (= identified by) were missing

-----Ursprüngliche Mitteilung----- 
Von: heinerhummel <[email-masked]>
An: jnc <[email-masked]>; lisp <[email-masked]>
Verschickt: Mi, 9 Jan 2013 11:39 pm
Betreff: Re: [lisp] draft-ietf-lisp-architecture: Demand Loading of Mappings

Running out of IPv4 Unicast addresses, it is however necessary that any (roaming) user owns an IPv4-address which is unique per its "home-geopatch" and that it will be identified by its IPv4-address plus its home-geopatch (2 octets) when roaming.

Heiner

-----Ursprüngliche Mitteilung----- 
Von: Noel Chiappa <[email-masked]>
An: lisp <[email-masked]>
Cc: jnc <[email-masked]>
Verschickt: Mi, 9 Jan 2013 8:05 pm
Betreff: Re: [lisp] draft-ietf-lisp-architecture: Demand Loading of Mappings

	Noel