Subject: Re: [lisp] Should we use Locator-Status-Bits in Internet deployment?

From: [email-masked] (Noel Chiappa)
Date: Wed, 23 Jan 2013 13:44:16 -0500 (EST)

> From: Eliot Lear <[email-masked]>

    >> If an ITR detects any transition (0 -to-1 or 1-to-0), verify it

    > Oh and s/ITR/ETR/ right?

No, I don't think so. LSBs are used to tell ITRs the status of ETRs, so
ITRs are the things which will use them - and should verify them.

But, to make a larger point, I don't think asking the mapping system is
really going to be the way to verify any changes - the whole point of LSBs (I
thought) was to cover an interim level of dynamics between i) changing the
mappings (i.e. updating the mapping system) and really dynamic stuff (e.g.
reachability failures). So I don't think status changes reflected in the LSB
would _necessarily_ show up in the mapping database.*

(* One use I heard postulated for LSBs was if you wanted to change the
mapping, and permanently _remove_ an ETR, since ITRs might not pick up a new
mapping entry right away, you could mark it 'down' in the LSBs. Or something
like that... I forget how you tell which bits in an LSB correspond to what
RLOCs. And of course I think that was before mapping sequence/version numbers
came in, which allow an ITR to quickly discover that it has an outdate
mapping.)

Maybe I'm confused, but I'm still not hearing why the LSB buys us anything
above and beyond what we have to have anyway: i) mappings, and some way to
detect that an ITR has an outdated copy of one, and ii) reachability (which
necessarily has to discover, on a fairly real-time basis, a superset of 'up').

	Noel

---

From: Ronald Bonica <[email-masked]>
Date: Wed, 23 Jan 2013 20:57:34 +0000

> 
> 
> Maybe I'm confused, but I'm still not hearing why the LSB buys us
> anything above and beyond what we have to have anyway: i) mappings, and
> some way to detect that an ITR has an outdated copy of one, and ii)
> reachability (which necessarily has to discover, on a fairly real-time
> basis, a superset of 'up').
> 

Noel, Dino,

Thanks for clearing up my misconceptions regarding LSB function. Now, I think that we are in a better position to discuss Noel's question, above.

Dino has suggested that the LSB provides a convenient way for ETRs to inform ITRs that locators have been taken in or out of service. This can be done without involving the mapping service.

However, the mechanism only works in "controlled environments". Furthermore, even in controlled environments, when the LSB==1, the ITR still has to test for reachability. This is because a locator can be in service, but unreachable from a particular ITR. (I am not sure about this, but when the LSB==0, might the ITR have to test for reachability anyway, just to ensure that things haven't changed).

Do I have this much right?

If so, does the LSB offer enough to be worth the complexity and processor load.

                                                       Ron

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 23 Jan 2013 21:41:32 -0800

> Dino has suggested that the LSB provides a convenient way for ETRs to inform ITRs that locators have been taken in or out of service. This can be done without involving the mapping service.

What the LSBs buy us is fast convergence. Let me explain.

(1) An IGP operating in a small part of the network can converge faster than propagating control messages to remote ASes.

(2) Once the IGP tells the data-plane, the data-plane sets these control bits. That means the control bits are sent from one AS to another very fast, via fast-switching of packets in the core routers.

(3) The LSBs are NOT reachability status. They are source up/down status that the source knows about. Where the source here is the site that operates the xTRs.

> However, the mechanism only works in "controlled environments". Furthermore, even in controlled environments, when the LSB==1, the ITR still has to test for reachability. This is because a locator…

If your LSB bit is 0, it doesn't matter if the reachability to you is up, because if you are down, then it doesn't matter. However, if your LSB bit is 1, it means you are up. But from my part of the topology you may be unreachable, but from Noel's part of the topology you may be reachable.

So up/down is global and reachability is pairwise.

> If so, does the LSB offer enough to be worth the complexity and processor load.

I believe it is worth it and it is being used in different use-cases and environments.

Dino