Subject: [lisp] Description of locator in map-reply section

From: Sander Steffann <[email-masked]>
Date: Sun, 6 Jan 2013 18:41:09 +0100

Hi,

I was reading http://tools.ietf.org/html/draft-ietf-lisp-24 when I noticed the following text in section 6.1.4, 'Map-Reply Message Format':

   Locator:  an IPv4 or IPv6 address (as encoded by the 'Loc-AFI' field)
      assigned to an ETR.  Note that the destination RLOC address MAY be
      an anycast address.  A source RLOC can be an anycast address as
      well.  The source or destination RLOC MUST NOT be the broadcast
      address (255.255.255.255 or any subnet broadcast address known to
      the router), and MUST NOT be a link-local multicast address.  The
      source RLOC MUST NOT be a multicast address.  The destination RLOC
      SHOULD be a multicast address if it is being mapped from a
      multicast destination EID.

It talks about source and destination RLOCs, which seems weird in the context of a map-reply message. My feeling is that this text belongs in a more generic section, or am I missing something here?  I thought that locators in map-replies are always meant to be used as destination RLOCs.

Thanks,
Sander

---

From: Sander Steffann <[email-masked]>
Date: Sun, 6 Jan 2013 19:58:54 +0100

Another question:

>   Locator:  [...] The destination RLOC

How should I see this? Does it even make sense to have a multicast address as (destination) RLOC?
- Sander

---

From: Luigi Iannone <[email-masked]>
Date: Mon, 7 Jan 2013 12:17:50 +0100

> How should I see this? Does it even make sense to have a multicast address as (destination) RLOC?

Why not?

Luigi

> - Sander
> 
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: Sander Steffann <[email-masked]>
Date: Mon, 7 Jan 2013 12:55:53 +0100

>> How should I see this? Does it even make sense to have a multicast address as (destination) RLOC?

It seems I need to re-read the lisp-multicast draft. I can't seem to understand how the mapping system works in relation to multicast traffic... Is there a introduction or presentation somewhere that explain it step-by-step?

Thanks,
Sander

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 7 Jan 2013 18:59:34 -0800

> It talks about source and destination RLOCs, which seems weird in the context of a map-reply message. My feeling is that this text belongs in a more generic section, or am I missing something here?…

Destination RLOCs are in the locator-set of an EID-record of the Map-Reply payload. You want the source and destination addresses to be RLOCs so the Map-Reply can be routed directly back to the requestor, by the core routers.

Dino

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 7 Jan 2013 19:00:42 -0800

> How should I see this? Does it even make sense to have a multicast address as (destination) RLOC?

Yes, when you are encapsulating a multicast packet from a source address that is an EID into an encapsulated packet that the core delivers as a multicast packet. We call the inner group address the "user's group address" and the other group address the "delivery group address".

Dino

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 7 Jan 2013 19:01:46 -0800

> It seems I need to re-read the lisp-multicast draft. I can't seem to understand how the mapping system works in relation to multicast traffic... Is there a introduction or presentation somewhere th…

You should also read the lisp-lcaf draft as well as the lisp-mr-signaling draft. There are many ways to do encapsulation of multicast packets.

Dino

---

From: Sander Steffann <[email-masked]>
Date: Tue, 8 Jan 2013 09:12:28 +0100

> You should also read the lisp-lcaf draft as well as the lisp-mr-signaling draft. There are many ways to do encapsulation of multicast packets.

Thanks, will do!
Sander

---

From: Sander Steffann <[email-masked]>
Date: Tue, 8 Jan 2013 09:15:51 +0100

Hi,

> Destination RLOCs are in the locator-set of an EID-record of the Map-Reply payload. You want the source and destination addresses to be RLOCs so the Map-Reply can be routed directly back to the req…

So (part of) this text is describing the RLOCs of the packet, not the RLOC in the content of the Locator field then? It now looks like the text is describing the content of the Locator field only.

Thanks,
Sander

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 8 Jan 2013 14:06:13 -0800

> So (part of) this text is describing the RLOCs of the packet, not the RLOC in the content of the Locator field then? It now looks like the text is describing the content of the Locator field only.

It is describing both. The "Loc-AFI" field is the locator-set encoding in the EID-record that I described above.

Dino