Subject: Re: [lisp] I-D Action: draft-iannone-lisp-eid-block-mgmnt-01.txt

From: Roger Jørgensen <[email-masked]>
Date: Wed, 27 Feb 2013 19:52:43 +0000

Sender: [email-masked]
On-Behalf-Of: [email-masked]
Subject: Re: [lisp] I-D Action: draft-iannone-lisp-eid-block-mgmnt-01.txt
Message-Id: <[email-masked]>
Recipient: [email-masked]

Subject: Re: [lisp] I-D Action: draft-iannone-lisp-eid-block-mgmnt-01.txt
From: Roger Jørgensen <[email-masked]>
To: "Joel M. Halpern" <[email-masked]>, "[email-masked] list list" <[email-masked]>
Cc: Roger Jørgensen <[email-masked]>
Date: Wed, 27 Feb 2013 20:52:26 +0100
List-Id: List for the discussion of the Locator/ID Separation Protocol <lisp.ietf.org>

On Wed, Feb 27, 2013 at 8:44 PM, Joel M. Halpern <[email-masked]> wrote:
> That similar.  My point is specifically to stay out fo "who" except for the
> root.

excellent, think we can agree on that really, and that's one direction to think.

I would really like to hear if any other have other possible direction
we can consider, either with or without existing RIR system.

-- 

Roger Jorgensen           | ROJO9-RIPE
[email-masked]          | - IPv6 is The Key!
http://www.jorgensen.no   | [email-masked]
_______________________________________________
lisp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lisp

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 27 Feb 2013 19:45:05 +0000

Sender: [email-masked]
On-Behalf-Of: [email-masked]
Subject: Re: [lisp] I-D Action: draft-iannone-lisp-eid-block-mgmnt-01.txt
Message-Id: <[email-masked]>
Recipient: [email-masked]

Subject: Re: [lisp] I-D Action: draft-iannone-lisp-eid-block-mgmnt-01.txt
From: "Joel M. Halpern" <[email-masked]>
To: Roger Jørgensen <[email-masked]>
Cc: "[email-masked] list list" <[email-masked]>
Date: Wed, 27 Feb 2013 14:44:38 -0500
List-Id: List for the discussion of the Locator/ID Separation Protocol <lisp.ietf.org>

That similar.  My point is specifically to stay out fo "who" except for 
the root.
Yours,
Joel

On 2/27/2013 2:38 PM, Roger Jørgensen wrote:
> On Wed, Feb 27, 2013 at 5:20 PM, Joel M. Halpern <[email-masked]> wrote:
>> Actually Luigi, in my personal opinion:
>> 1) It is not our job or our requirement to involve the RIRs.  It is our job
>> to come up with what we think LISP and the Internet need for EID allocation.
>> 2) I would be really surprised if EID allocation policies were at all
>> related to current RIR address allocation policies.  The behaviors are VERY
>> different, as are the assignment implications.
>
> Are you thinking something more along these lines
> http://www.ietf.org/mail-archive/web/lisp/current/msg04155.html ?
>
>
> In there I mention the RIR simple because they have the
> _infrastructure_ to support the operational side of any delegation,
> whois+dns+++...
> If we can get it to work any other way, maybe something along domain
> names, that is also another option.
>
>
>
> --- Roger J ---
>
>> Yours,
>> Joel
>>
>>
>> On 2/27/2013 6:59 AM, Luigi Iannone wrote:
>>>
>>> Hi,
>>>
>>>
>>> On 27 Feb. 2013, at 01:46 , Joel M. Halpern <[email-masked]> wrote:
>>>
>>>> As a participant, I have an even stronger pinion on the RIR references
>>>> than terry.
>>>>
>>>> I think that the block management needs to define
>>>> o who the root is
>>>> o what policy we require for allocating blocks to allocators (the root is
>>>> not an allocator
>>>> o What the behavioral requirements are for an allocator
>>>> o are there any special requirements for re-delegating to another
>>>> allocator?
>>>> o What policies allocators should respect for end site allocation
>>>>
>>>> Once we have this defined, then organizations that wish to participate
>>>> can do so.  If the RIRs want to come play, they may.  If not, then they
>>>> don't.
>>>>
>>>
>>> Got it, is what I've also understood from Terry's point.
>>>
>>> Again, there was no intention to put work on RIRs back, rather to show
>>> that we can come up with a framework that involves RIRs and is compatible
>>> with current RIRs' policies. (apparently the message was not clear ;-) ).
>>>
>>> It comes to my mind the question of what we are going to do with the EID
>>> block if in 10 years the IETF decides that LISP is the best thing ever and
>>> we need to assign the EID block permanently?
>>>
>>> Ideas are welcome :-)
>>>
>>> ciao
>>>
>>> L.
>>>
>>>
>>>> (Repeated for clarity, the above is a personal opinion, not a WG chair
>>>> position, nor associated with any other hats I may have.)
>>>>
>>>> Yours,
>>>> Joel
>>>>
>>>> On 2/26/2013 7:26 PM, Terry Manderson wrote:
>>>>>
>>>>> Speaking just as a WG participant.
>>>>>
>>>>> I would rather a document like this focus purely on the allocation
>>>>> criteria that needs to be applied to:
>>>>>          1) An experimental EID block
>>>>>          2) ongoing LISP allocations beyond the life of the experiment
>>>>>
>>>>> Given the expected (numbering) requirements of a LISP site.
>>>>>
>>>>> Simply, while it is temping to use the RIRs, and name them, it is not
>>>>> appropriate in my opinion to assign work to the RIRs. That is the job of
>>>>> their membership.
>>>>>
>>>>> Similarly, what policies the RIRs have now are all subject to change
>>>>> within their own policy development processes. Please don't re-codify
>>>>> them
>>>>> here. I would also prefer to see this document take the approach of
>>>>> defining what is best for LISP, not how can we use the RIRs as an
>>>>> allocation framework. The concern I have is that if LISP ends up
>>>>> requiring
>>>>> something very different to how the RIRs do it - we would be doing a
>>>>> disservice to both LISP and the RIRs by pushing it that way.
>>>>>
>>>>> The definition of terms is well stated elsewhere, perhaps you can point
>>>>> to
>>>>> those locations?
>>>>>
>>>>> Cheers
>>>>> Terry
>>>>>
>>>>> On 26/02/13 7:59 AM, "Luigi Iannone" <[email-masked]> wrote:
>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> FYI a new version is available.
>>>>>>
>>>>>>
>>>>>> Comments still welcome ;-)
>>>>>>
>>>>>>
>>>>>> L.
>>>>>>
>>>>>> Begin forwarded message:
>>>>>>
>>>>>>
>>>>>> From:
>>>>>> [email-masked]
>>>>>>
>>>>>> Subject:
>>>>>> I-D Action: draft-iannone-lisp-eid-block-mgmnt-01.txt
>>>>>>
>>>>>> Date:
>>>>>> 25 February 2013 21:47:29 GMT+01:00
>>>>>>
>>>>>> To:
>>>>>> [email-masked]
>>>>>>
>>>>>> Reply-To:
>>>>>> [email-masked]
>>>>>>
>>>>>>
>>>>>>
>>>>>> A New Internet-Draft is available from the on-line Internet-Drafts
>>>>>> directories.
>>>>>>
>>>>>>
>>>>>> Title           : LISP EID Block Management Guidelines
>>>>>> Author(s)       : Luigi Iannone
>>>>>>                           Roger Jorgensen
>>>>>> Filename        : draft-iannone-lisp-eid-block-mgmnt-01.txt
>>>>>> Pages           : 9
>>>>>> Date            : 2013-02-25
>>>>>>
>>>>>> Abstract:
>>>>>>    This document proposes an allocation framework for the management of
>>>>>>    the LISP EID address prefix (requested in a separate document).  Such
>>>>>>    framework relies on hierarchical distribution of the address space to
>>>>>>    RIRs (Regional Internet Registries), who will allocate on a temporary
>>>>>>    basis sub-prefixes to requesting organizations.
>>>>>>
>>>>>>
>>>>>> The IETF datatracker status page for this draft is:
>>>>>> https://datatracker.ietf.org/doc/draft-iannone-lisp-eid-block-mgmnt
>>>>>>
>>>>>> There's also a htmlized version available at:
>>>>>> http://tools.ietf.org/html/draft-iannone-lisp-eid-block-mgmnt-01
>>>>>>
>>>>>> A diff from the previous version is available at:
>>>>>> http://www.ietf.org/rfcdiff?url2=draft-iannone-lisp-eid-block-mgmnt-01
>>>>>>
>>>>>>
>>>>>> Internet-Drafts are also available by anonymous FTP at:
>>>>>> ftp://ftp.ietf.org/internet-drafts/
>>>>>>
>>>>>> I-D-Announce mailing list
>>>>>> [email-masked]
>>>>>> https://www.ietf.org/mailman/listinfo/i-d-announce
>>>>>> Internet-Draft directories: http://www.ietf.org/shadow.html
>>>>>> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>

---

From: Terry Manderson <[email-masked]>
Date: Wed, 27 Feb 2013 00:26:33 +0000

Sender: [email-masked]
On-Behalf-Of: [email-masked]
Subject: Re: [lisp] Fwd: I-D Action: draft-iannone-lisp-eid-block-mgmnt-01.txt
Message-Id: <[email-masked]>
Recipient: [email-masked]

Subject: Re: [lisp] Fwd: I-D Action: draft-iannone-lisp-eid-block-mgmnt-01.txt
From: Terry Manderson <[email-masked]>
To: Luigi Iannone <[email-masked]>, "[email-masked] list list" <[email-masked]>
Cc: Roger Jørgensen <[email-masked]>
Date: Tue, 26 Feb 2013 16:26:19 -0800
List-Id: List for the discussion of the Locator/ID Separation Protocol <lisp.ietf.org>

Similarly, what policies the RIRs have now are all subject to change
within their own policy development processes. Please don't re-codify them
here. I would also prefer to see this document take the approach of
defining what is best for LISP, not how can we use the RIRs as an
allocation framework. The concern I have is that if LISP ends up requiring
something very different to how the RIRs do it - we would be doing a
disservice to both LISP and the RIRs by pushing it that way.

The definition of terms is well stated elsewhere, perhaps you can point to
those locations?

Cheers
Terry

---

From: Roger Jørgensen <[email-masked]>
Date: Wed, 27 Feb 2013 19:42:24 +0000

Message-Id: <[email-masked]>

Subject: Re: [lisp] I-D Action: draft-iannone-lisp-eid-block-mgmnt-01.txt
From: Roger Jørgensen <[email-masked]>
To: "Joel M. Halpern" <[email-masked]>
Cc: "[email-masked] list list" <[email-masked]>
Date: Wed, 27 Feb 2013 20:38:28 +0100
List-Id: List for the discussion of the Locator/ID Separation Protocol <lisp.ietf.org>

--- Roger J ---

--

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 27 Feb 2013 16:21:41 +0000

Message-Id: <[email-masked]>

Subject: Re: [lisp] I-D Action: draft-iannone-lisp-eid-block-mgmnt-01.txt
From: "Joel M. Halpern" <[email-masked]>
To: Luigi Iannone <[email-masked]>
Cc: Roger Jørgensen <[email-masked]>, "[email-masked] list list" <[email-masked]>
Date: Wed, 27 Feb 2013 11:20:24 -0500
List-Id: List for the discussion of the Locator/ID Separation Protocol <lisp.ietf.org>

Actually Luigi, in my personal opinion:
1) It is not our job or our requirement to involve the RIRs.  It is our 
job to come up with what we think LISP and the Internet need for EID 
allocation.
2) I would be really surprised if EID allocation policies were at all 
related to current RIR address allocation policies.  The behaviors are 
VERY different, as are the assignment implications.

Yours,
Joel

On 2/27/2013 6:59 AM, Luigi Iannone wrote:
>> As a participant, I have an even stronger pinion on the RIR references than terry.
>>
>> o what policy we require for allocating blocks to allocators (the root is not an allocator
>> o are there any special requirements for re-delegating to another allocator?
>> Once we have this defined, then organizations that wish to participate can do so.  If the RIRs want to come play, they may.  If not, then they don't.
>>
>
> Again, there was no intention to put work on RIRs back, rather to show that we can come up with a framework that involves RIRs and is compatible with current RIRs' policies. (apparently the message was not clear ;-) ).
>
> It comes to my mind the question of what we are going to do with the EID block if in 10 years the IETF decides that LISP is the best thing ever and we need to assign the EID block permanently?
>
> Ideas are welcome :-)
>
> ciao
>
> L.
>
>
>> (Repeated for clarity, the above is a personal opinion, not a WG chair position, nor associated with any other hats I may have.)
>>
>> Yours,
>> Joel
>>

---

From: Luigi Iannone <[email-masked]>
Date: Wed, 27 Feb 2013 11:50:37 +0000

Sender: [email-masked]
On-Behalf-Of: [email-masked]
Subject: Re: [lisp] I-D Action: draft-iannone-lisp-eid-block-mgmnt-01.txt
Message-Id: <[email-masked]>
Recipient: [email-masked]

Subject: Re: [lisp] I-D Action: draft-iannone-lisp-eid-block-mgmnt-01.txt
From: Luigi Iannone <[email-masked]>
To: Terry Manderson <[email-masked]>
Cc: Roger Jørgensen <[email-masked]>, "[email-masked] list list" <[email-masked]>
Date: Wed, 27 Feb 2013 12:50:25 +0100
List-Id: List for the discussion of the Locator/ID Separation Protocol <lisp.ietf.org>

Hi,

> disservice to both LISP and the RIRs by pushing it that way.

The idea was not to impose anything to RIRs , but rather to use the document as starting point to discuss with them.

Having said that, I've got the point: "let's document EID allocation requirements and framework without referring to a specific entity".

Is that correct?

> The definition of terms is well stated elsewhere, perhaps you can point to

There is a pointer for each term. The terms are "duplicated" here just to offer an handy reading.
There is no harm in keeping them.

ciao

Luigi

---

From: Luigi Iannone <[email-masked]>
Date: Wed, 27 Feb 2013 12:00:04 +0000

Message-Id: <[email-masked]>

Subject: Re: [lisp] I-D Action: draft-iannone-lisp-eid-block-mgmnt-01.txt
From: Luigi Iannone <[email-masked]>
To: Joel M.Halpern <[email-masked]>
Cc: Roger Jørgensen <[email-masked]>, "[email-masked] list list" <[email-masked]>
Date: Wed, 27 Feb 2013 12:59:51 +0100
List-Id: List for the discussion of the Locator/ID Separation Protocol <lisp.ietf.org>

Hi,

Ideas are welcome :-)

ciao

L.