Subject: [lisp] Unidentified bit in Map-Register messages

From: Sander Steffann <[email-masked]>
Date: Wed, 13 Feb 2013 13:04:03 +0100

Hi all,

In a tcpdump of some Map-Register messages I see a bit two bits before the Want-Map-Notify bit set to 1. So in hex the Map-Register now starts with 32 00 05. The 3 is the type code for Map-Register, the 2 is the I bit and the 5 at the end is the Want-Map-Notify bit and some other bit.

What does that bit mean? Which draft am I missing this time? ;-)

Thanks!
Sander

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 13 Feb 2013 14:54:24 -0800

> In a tcpdump of some Map-Register messages I see a bit two bits before the Want-Map-Notify bit set to 1. So in hex the Map-Register now starts with 32 00 05. The 3 is the type code for Map-Register…

If you are talking to a cisco operating system, the format of the first 32-bits of a Map-Register is:

        0                   1                   2                   3         
        0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1       
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+      
       |Type=3 |P|S|I|        Reserved         |T|a|m|M| Record Count  |      
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+     

compared to RFC 6830:

        0                   1                   2                   3
        0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |Type=3 |P|            Reserved               |M| Record Count  |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

> What does that bit mean? Which draft am I missing this time? ;-)

The S-bit is for LISP-SEC, see the lisp-sec draft for details.
The I-bit is the xTR-ID, see the lisp-nat-traversal draft for details.
The m-bit is set when a LISP-MN registers, see the lisp-mn draft for details.
The a-bit is for requesting merge semantics (versus replacement semantics) for a register, see the lisp-nat-traversal draft for details.

The T-bit is used by cisco for experimenting with faster Map-Register timeouts. So when set, the TTL from the Map-Register is used to time out the registration. This is not documented anywhere.

Dino

---

From: Sander Steffann <[email-masked]>
Date: Thu, 14 Feb 2013 09:07:20 +0100

Thanks Dino!

Met vriendelijke groet,
Sander Steffann