Subject: [lisp] updated draft-lisp for sdn-nfv

From: Sharon Barkai <[email-masked]>
Date: Thu, 23 May 2013 02:58:54 +0000

There is an updated draft-lisp for sdn scaling network function virtualization.
http://www.ietf.org/id/draft-barkai-lisp-nfv-01.txt

The draft shows how LISP enhances SDN from (1) concentrated,  (2) hop-by-hop, (3) push control model, to (1) distributed, (2) overlay, (3) pull-pub-sub model, able to perform dynamic mapping the right flows, in the right sequence, from mobile users, to elastic functions.

Main additions to draft-01 by Vina clarify the terminology around LISP-SDN and the LISP messages, as well as explain the SDN-XTR flow-rule (exact and best match) affinity determination and forwarding model.

It will be good if during the next wg meeting Dino and Fabio will further elaborate on the LISP-SDN use-cases and the SDN open-source platforms LISP is being inserted to. Additional explanations on why and how to enhance SDN with LISP can be found on the (2page) paper bellow:

---

From: "Flinck, Hannu (NSN - FI/Espoo)" <[email-masked]>
Date: Wed, 29 May 2013 14:07:46 +0000

Thank you Sharon and other authors

I read this with great interest.  I have some questions though to better understand how this would work:

1) in the figure on page 6 what is the "Distribution-Center B"? Do you mean Data-Center B?

2) why do you need to co-locate Control-Agents with the SDN-xTRs?

3) Section 5 page 7: what is meant by LISP overlay in this context? Or do you mean SDN-outerlay instead here?

4) Section 5 page 7: for the selection of the best suited VNF you seem to use quite dynamic attributes, e.g. "health-load attributes". This seems to indicate a push type of mapping system. The current LISP mapping system is pull based. And if I am not mistaken that was the design choice.

5) Section 5.1 maybe you clarify in the terminology section what is "Function-Instance-EID" and "Function_EID"? Are they same of different?

6) The text suggest that Mapping system (also) subscribes the SDN-xTR to the Function-Instance-EID and Function EID to receive updates. How are these updates, I believe "health-load" attributes, distributed to Control Agents of SDN-xTRs? Maybe a push based mapping system is required? How much overhead traffic that would generate?

7) Can you, please clarify in the terminology what is App-Instance-Record and how it differs from Function ID and Function-Instance-ID? 

Best regards
Hannu