Subject: [lisp] Does Map resolver get map reply

From: "Rockson Li (zhengyli)" <[email-masked]>
Date: Fri, 28 Jun 2013 06:41:37 +0000

Hello experts,

I got a question on if map resolver should get map reply.
>From sec 4.3 of RFC6833
<snip>
Unless also acting as a Map-Resolver, a Map-Server should never receive Map-Replies
</snip>

It seems a map resolver could possibly get map reply.

However, from sec 4.4, it seems to me a map resolver should not get a map reply at all.

<snip>
  The Map-Resolver does not send any response
   to the ITR; since the source RLOC is that of the ITR, the ETR or
   Map-Server that receives the Map-Request over the ALT and responds
   will do so **directly** to the ITR.
</snip>

Can someone clarify please?

Thanks
Regards,
-Rockson

---

From: Dino Farinacci <[email-masked]>
Date: Fri, 28 Jun 2013 09:39:37 -0700

> It seems a map resolver could possibly get map reply.

A Map-Resolver would only get a Map-Reply if it *originated* a Map-Request. Versus, it forwarding one on behalf of an ITR. 

When a Map-Resolver is part of a LISP-DDT hierarchy, it receives Map-Referral messages in response to Map-Requests it forwards on behalf of ITRs. It does this, so it can build a *referral-cache* versus a *map-cache* which ITRs build.

> However, from sec 4.4, it seems to me a map resolver should not get a map reply at all.

And this text is correct.

> Can someone clarify please?

Here is the relative text in 4.3:

   If none of the ETRs have requested proxy reply service, then the  
   Map-Server re-encapsulates and forwards the resulting Encapsulated
   Map-Request to one of the registered ETRs.  It does not otherwise
   alter the Map-Request, so any Map-Reply sent by the ETR is returned
   to the RLOC in the Map-Request, not to the Map-Server.  Unless also
   acting as a Map-Resolver, a Map-Server should never receive
   Map-Replies; any such messages should be discarded without response,
   perhaps accompanied by the logging of a diagnostic message if the
   rate of Map-Replies is suggestive of malicious traffic.

An ETR returning a Map-Reply always goes to the RLOC from the ITR-RLOCs list in the Map-Request. So I wanted to clarify that first. The "Unless also acting as a Map-Resolver" is indeed misleading, making the reader think that if a Map-Server is also a Map-Resolver that it could receive Map-Replies. Well, there is really no reason for it to receive Map-Replies, because as I state above a proper Map-Resolver does not keep a map-cache, unless of course it is an ITR.  ;-)

We will fix the text in a future update. Thanks for the comment.

Dino

> Thanks
> Regards,
> -Rockson
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp