Subject: Re: [lisp] No LISP meeting for Berlin

From: "Jose Saldana" <[email-masked]>
Date: Thu, 4 Jul 2013 11:03:36 +0200

Hi all,

I had talked with Luigi about the possibility of presenting our LISP+TCM
optimization proposal in Berlin (
<http://diec.unizar.es/~jsaldana/personal/budapest_ICC_2013_presentation.pdf
http://diec.unizar.es/~jsaldana/personal/budapest_ICC_2013_presentation.pdf)
.

Since there is no formal LISP meeting, I would  also like to participate in
the “informal LISP+Beer event” and tell you about the idea, if you agree.
I think that LISP and TCM can obtain mutual benefits.

Please keep me informed about that informal event! I will be in Berlin for
the TCM BOF, and also for an “online games traffic session”, within the
Transport Area Open meeting on Thursday. You are invited of course:
<http://www.youtube.com/watch?v=_G96ULX7Iak&feature=em-upload_owner#action=s
hare>
http://www.youtube.com/watch?v=_G96ULX7Iak&feature=em-upload_owner#action=sh
are

Thanks!,

Jose

De: [email-masked] [mailto:[email-masked]] En nombre de cheng.
[email-masked]
Enviado el: jueves, 04 de julio de 2013 3:49
Para: Dino Farinacci
CC: [email-masked]; [email-masked]
Asunto: [lisp] 答复: Re: No LISP meeting for Berlin

Good idea, definitely support. 

Li Cheng

[email-masked] 写于 2013-07-04 00:25:16:

> > Hi,
> > 
> > I understand the rationale of this decision and I have no real
complains.
> > 
> > Yet,  I cannot stop thinking that Berlin would have been the right
> opportunity to empty a bit the pipeline. Latest meetings had always 
> a full agenda. 
> 
> I tend to agree.
> 
> > There are a bunch of presentations that were scheduled in Orlando 
> that did not make it (I am part of the problem since I was pretty 
> chatty in my slot….).
> > This was the opportunity to give them priority.
> 
> And there were a lot planned that I think people would have enjoyed.
> 
> > The idea (suggested by Dino) of having an informal LISP+Beer event
> in Berlin sounds good :-)
> > 
> > Luigi
> 
> I think the venue needs to following requirements:
> 
> (1) A quiet place so everyone can hear the presos.
> (2) A projector. Someone can volunteer one.
> (3) Allows enough time, I propose a 2.5 hour meeting.
> 
> I can run the meeting and take agenda items. So there are no 
> limitations. Anyone want to talk about LISP, what they think it 
> should be, what they think they can do with it, anything, is open 
> game. So you university types, you deployers, you implementors, 
> please all come and send agenda items to me. I will post a week before
IETF.
> 
> Thanks everyone for being open minded. At the end of the day, it is 
> solely about the technology, and in my mind everything else is secondary.
> 
> Dino
> 
> > 
> > 
> > 
> > On 28 Jun. 2013, at 04:03 , Terry Manderson <terry.
> [email-masked]> wrote:
> > 
> >> Dear LISP Work Group,
> >> 
> >> We, the Co-Chairs, have been watching the workgroup closely for
activity
> >> on the current set of documents that have been adopted. Apart from the
> >> items which have been passed to the IESG we do not believe there has
been
> >> significant progress, discussion, or review of these 'in-play' drafts
to
> >> warrant having a meeting in Berlin.
> >> 
> >> We have communicated our observations with the responsible AD and
amongst
> >> us there is full agreement to cancel the LISP session request for
Berlin.
> >> 
> >> Thus, we have done so.
> >> 
> >> To iterate, there will be NO MEETING FOR LISP at IETF87.
> >> 
> >> We do apologise if this note causes you concern. However, as chairs we
> >> must consider the LISP workgroup outputs on their merit, and at this
stage
> >> those outputs do not warrant using up agenda time.
> >> 
> >> If you would like to talk with us (the co-chairs) during IETF87, we are
> >> happy to
> >>  make hallway time to discuss ways of making progress on the WG
chartered
> >>  items.
> >> 
> >> 
> >> LISP Co-Chairs
> >> Joel and Terry
> >> _______________________________________________
> >> lisp mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/lisp
> > 
> > _______________________________________________
> > lisp mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/lisp
> 
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail (and
any attachment transmitted herewith) is privileged and confidential and is
intended for the exclusive use of the addressee(s).  If you are not an
intended recipient, any disclosure, reproduction, distribution or other
dissemination or use of the information contained is strictly prohibited.
If you have received this mail in error, please delete it and notify us
immediately.

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail (and
any attachment transmitted herewith) is privileged and confidential and is
intended for the exclusive use of the addressee(s).  If you are not an
intended recipient, any disclosure, reproduction, distribution or other
dissemination or use of the information contained is strictly prohibited.
If you have received this mail in error, please delete it and notify us
immediately.

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 4 Jul 2013 09:53:25 -0700

Jose - I will put you on the agenda. Thanks for offering. 

To the rest of the list - I will post the agenda next week. A lot of people have requested to present so I think we'll have a packed agenda. 

I would like to poll the list to see if the time slot of Wed 5:00-8:00pm works for most people. And we can move to a beer garden or restaurant to continue informal discussions afterwards. 

We really want the LISP WG chairs to make it. Terry told me he is free and Joel is working out if he can be free. So please send you opinions. 

Joel and Terry, since this time slot is during the Admin Plenary do you thing we can just grab an open breakout room that has a projector? 

Dino

On Jul 4, 2013, at 2:03 AM, "Jose Saldana" <[email-masked]> wrote:

> Hi all,
>  
> I had talked with Luigi about the possibility of presenting our LISP+TCM optimization proposal in Berlin (http://diec.unizar.es/~jsaldana/personal/budapest_ICC_2013_presentation.pdf).
>  
> Since there is no formal LISP meeting, I would  also like to participate in the “informal LISP+Beer event” and tell you about the idea, if you agree. I think that LISP and TCM can obtain mutual benefits.
>  
> Please keep me informed about that informal event! I will be in Berlin for the TCM BOF, and also for an “online games traffic session”, within the Transport Area Open meeting on Thursday. You are invited of course: http://www.youtube.com/watch?v=_G96ULX7Iak&feature=em-upload_owner#action=share
>  
> Thanks!,
>  
> Jose
>  
> De: [email-masked] [mailto:[email-masked]] En nombre de [email-masked]
> > > I understand the rationale of this decision and I have no real complains.
> > > 
> > please all come and send agenda items to me. I will post a week before IETF.
> > 
> > >> We, the Co-Chairs, have been watching the workgroup closely for activity
> > >> items which have been passed to the IESG we do not believe there has been
> > >> significant progress, discussion, or review of these 'in-play' drafts to
> > >> We have communicated our observations with the responsible AD and amongst
> > >> us there is full agreement to cancel the LISP session request for Berlin.
> > >> 
> > >> Thus, we have done so.
> > >> 
> > >> must consider the LISP workgroup outputs on their merit, and at this stage
> > >>  make hallway time to discuss ways of making progress on the WG chartered
> > >>  items.
> > >> 
> > >> 
> > >> LISP Co-Chairs
> > >> Joel and Terry
> ZTE Information Security Notice: The information contained in this mail (and any attachment transmitted herewith) is privileged and confidential and is intended for the exclusive use of the addressee(s).  If you are not an intended recipient, any disclosure, reproduction, distribution or other dissemination or use of the information contained is strictly prohibited.  If you have received this mail in error, please delete it and notify us immediately.
>  
>  
> 
>  
> ZTE Information Security Notice: The information contained in this mail (and any attachment transmitted herewith) is privileged and confidential and is intended for the exclusive use of the addressee(s).  If you are not an intended recipient, any disclosure, reproduction, distribution or other dissemination or use of the information contained is strictly prohibited.  If you have received this mail in error, please delete it and notify us immediately.
>  
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 04 Jul 2013 14:24:43 -0400

I do not know if I will be able to make it.  (As the IAB liaison to the 
IESG, I really should be at the administrative plenary.)

As for rooms, procedurally even during the plenary you are supposed to 
have secretariat approval for using a room for a meeting.  And that will 
require AD signoff.

Yours,
Joel

On 7/4/2013 12:53 PM, Dino Farinacci wrote:
> To the rest of the list - I will post the agenda next week. A lot of
> people have requested to present so I think we'll have a packed agenda.
>
> I would like to poll the list to see if the time slot of Wed 5:00-8:00pm
> works for most people. And we can move to a beer garden or restaurant to
> continue informal discussions afterwards.
>
> We really want the LISP WG chairs to make it. Terry told me he is free
> and Joel is working out if he can be free. So please send you opinions.
>
> Joel and Terry, since this time slot is during the Admin Plenary do you
> thing we can just grab an open breakout room that has a projector?
>
> Dino
>
>
> On Jul 4, 2013, at 2:03 AM, "Jose Saldana" <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>> Hi all,
>>
>> I had talked with Luigi about the possibility of presenting our
>> LISP+TCM optimization proposal in Berlin
>> (http://diec.unizar.es/~jsaldana/personal/budapest_ICC_2013_presentation.pdf).
>>
>> Since there is no formal LISP meeting, I would  also like to
>> participate in the “informal LISP+Beer event” and tell you about the
>> idea, if you agree. I think that LISP and TCM can obtain mutual benefits.
>>
>> Please keep me informed about that informal event! I will be in Berlin
>> for the TCM BOF, and also for an “online games traffic session”,
>> within the Transport Area Open meeting on Thursday. You are invited of
>> course:
>> http://www.youtube.com/watch?v=_G96ULX7Iak&feature=em-upload_owner#action=share
>>
>> Thanks!,
>>
>> Jose
>>
>> *De:[email-masked] <mailto:[email-masked]>
>> [mailto:[email-masked]] *En nombre de [email-masked]
>> <mailto:[email-masked]>
>> *Enviado el:* jueves, 04 de julio de 2013 3:49
>> *Para:* Dino Farinacci
>> *CC:* [email-masked] <mailto:[email-masked]>;
>> [email-masked] <mailto:[email-masked]>
>> *Asunto:* [lisp] 答复: Re: No LISP meeting for Berlin
>>
>>
>> [email-masked] <mailto:[email-masked]> 写于 2013-07-04
>> 00:25:16:
>>
>> > > Hi,
>> > >
>> >[email-masked] <mailto:[email-masked]>> wrote:
>> > >
>> > >> Dear LISP Work Group,
>> > >>
>> > >>[email-masked] <mailto:[email-masked]>
>> > >[email-masked] <mailto:[email-masked]>
>> >[email-masked] <mailto:[email-masked]>
>> [email-masked] <mailto:[email-masked]>

---

From: "Jose Saldana" <[email-masked]>
Date: Fri, 5 Jul 2013 09:26:13 +0200

Ok. I will prepare the presentation. Is a 10 minutes presentation ok?

Jose

De: Dino Farinacci [mailto:[email-masked]] 
Enviado el: jueves, 04 de julio de 2013 18:53
Para: [email-masked]
CC: <[email-masked]>
Asunto: Re: [lisp] No LISP meeting for Berlin

Dino

Hi all,

I had talked with Luigi about the possibility of presenting our LISP+TCM optimization proposal in Berlin ( <http://diec.unizar.es/~jsaldana/personal/budapest_ICC_2013_presentation.pdf> http://diec.unizar.es/~jsaldana/personal/budapest_ICC_2013_presentation.pdf).

Please keep me informed about that informal event! I will be in Berlin for the TCM BOF, and also for an “online games traffic session”, within the Transport Area Open meeting on Thursday. You are invited of course:  <http://www.youtube.com/watch?v=_G96ULX7Iak&feature=em-upload_owner#action=share> http://www.youtube.com/watch?v=_G96ULX7Iak&feature=em-upload_owner#action=share

Thanks!,

Jose

Li Cheng

---

From: [email-masked]
Date: Sat, 6 Jul 2013 05:58:26 -0400 (EDT)

My "Mass" for the LISP beer garden meeting:

The LISP's dependency on special servers (DDT, formerly ALT) is a perfect invitation for abuse  - 
either by malicious hackers or by malicious owners, or the alliance of both. Who is able to control these servers is able to control  internet forwarding.
I can imagine that the RSA would like LISP very much.

Heiner

---

From: Damien Saucez <[email-masked]>
Date: Sat, 6 Jul 2013 13:21:45 +0200

> I can imagine that the RSA would like LISP very much.

Don't worry, before you traffic to be encapsulated by LISP you will use DNS...

Damien Saucez

---

From: Dino Farinacci <[email-masked]>
Date: Sat, 6 Jul 2013 11:01:32 -0700

There are servers everywhere. Even not on the Internet. We leave in a world of abuse. But I would like to think we live in a world where people help things that serve. 

Dino

---

From: [email-masked]
Date: Sun, 7 Jul 2013 14:11:52 -0400 (EDT)

"...But I would like to think we live in a world where people help things that serve. "

Dino,really?

By our last dispute a while ago I learnt that LISP does NOTHING to ease the IPv4 adress depletion issue (well, it rather eats up some extra addresses).
While by involving the user as well as the DNS (i.e. by mapping a FQDN to IPv4 address + Locator) the IPv4 address space could easily do for another thousand years (all it takes is to ensure that any IPv4-address is unique per associated locator) LISP-DDT prevents that for good, and you make us believe that LISP would be of any service to IPv4 ?!

The bad thing is that very very precious time goes by while (naive) people/observers trust in LISP on this respect.
Just like myself when I argued that LISP-DDT cannot work assuming that LISP were after a 4+4 octet unicast address space extension.

But you let all up to NAT. This is really not a serve.

Sorry,
Heiner
 (having nothing said about the dooming malicious/political problems yet)

-----Ursprüngliche Mitteilung----- 
Von: Dino Farinacci <[email-masked]>
An: Damien Saucez <[email-masked]>
Cc: heinerhummel <[email-masked]>; lisp <[email-masked]>
Verschickt: Sa, 6 Jul 2013 8:01 pm
Betreff: Re: [lisp] No LISP meeting for Berlin

Dino 

Damien Saucez

Heiner

---

From: Dino Farinacci <[email-masked]>
Date: Sun, 7 Jul 2013 11:59:38 -0700

> "...But I would like to think we live in a world where people help things that serve. "

Yes - really. When you post an email like you did (and you do it repeatedly with little technical data), I have to respond that way. 

> By our last dispute a while ago I learnt that LISP does NOTHING to ease the IPv4

And it never claimed to solve this problem.  It you know what? It does help because you can use other address spaces to help the allocation of devices.  So you can use IPv6 EIDs for site devices versus IPv4 addresses. Allowing more IPv4 addresses to be used for RLOCs and therefore be able to address more sites. 

> adress depletion issue (well, it rather eats up some extra addresses).
> While by involving the user as well as the DNS (i.e. by mapping a FQDN to IPv4

How is LISP involving the user?

> address + Locator) the IPv4 address space could easily do for another thousand years (all it takes is to ensure that any IPv4-address is unique per associated locator) LISP-DDT prevents that for good, and you make us believe that LISP would be of any service to IPv4 ?!

LISP-DDT is a database to move Map-Request around. It says nothing about how and how much address is allocated. 

> The bad thing is that very very precious time goes by while (naive) people/observers trust in LISP on this respect.

Because it is becoming proven in their experience. 

> But you let all up to NAT. This is really not a serve.

I cannot parse the above. 

Dino

---

From: [email-masked]
Date: Mon, 8 Jul 2013 06:10:47 -0400 (EDT)

See my notes starting with HH inside.
Heiner

-----Ursprüngliche Mitteilung----- 
Von: Dino Farinacci <[email-masked]>
An: heinerhummel <[email-masked]>
Cc: damien.saucez <[email-masked]>; lisp <[email-masked]>
Verschickt: So, 7 Jul 2013 8:59 pm
Betreff: Re: [lisp] No LISP meeting for Berlin

Dino,really?

HH: Here is all technical detail:   http://www.igi-global.com/chapter/topology-aggregating-routing-architecture-tara/77501

HH: But anyone who sees that the IPv4-address is enhanced by another 4 octets locator is tempted to assume that uniqueness is provided by some unique combination of IPv4 address + locator. Just as if a postal letter is sent to some Mr. Smith, or Mr. Li, or Herr Meier or Mr. Dupont. And btw, I am not sure whether that wasn't an initial argument in favor of LISP, otherwise I would have brought up this issue years earlier.

HH: LISP is not involving the user, that is my reproach. If there were no IPv4 address depletion issue then it would be a pro-argument not to involve the user. But a) we are used to getting WINDOW-updates every now and then, and b) by expanding the IPv4 address space by O(2^32) that pro-argument is overruled by far. (TARA would even provide an IPv4-address space extension of O(2^40) !!! )

HH: Right,  sounds very innocently. But even LISP 2.0 (I guess) had once been better .

Because it is becoming proven in their experience. 
HH: I never doubted that LISP would just work as you have had it in your mind, nor that you would be able to adjust it such that it suits all existing forwarding mechanisms.

Dino

Sorry,
Heiner

-----Ursprüngliche Mitteilung----- 
Von: Dino Farinacci <[email-masked]>
An: Damien Saucez <[email-masked]>
Cc: heinerhummel <[email-masked]>; lisp <[email-masked]>
Verschickt: Sa, 6 Jul 2013 8:01 pm
Betreff: Re: [lisp] No LISP meeting for Berlin

Dino 

Damien Saucez

Heiner

---

From: Sharon Barkai <[email-masked]>
Date: Mon, 8 Jul 2013 11:14:03 +0000

really don't want to interrupt this great dialog, just one comment.

don't think is about a bigger address space for routing,
but rather combining 2 completely different lookup schemes.

Step1: you lookup  the routing location  of Mr. Smith, or Mr. Li, or Herr Meier or Mr. Dupont in a huge ID "phone book" a (secure) distributed database lookup problem, strictly overlay not a routing problem.

Step 2: you insert the letter into an outer envelope with a postal-service (routable) address, leverage whatever hop to hop routing lookup solution you have at the moment scale, cost, efficiency wise.  FedEx, ups etc.

Lots of use cases and benefits.

--szb

On Jul 8, 2013, at 13:11, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:

-----Ursprüngliche Mitteilung-----
Von: Dino Farinacci <[email-masked]<mailto:[email-masked]>>
An: heinerhummel <[email-masked]<mailto:[email-masked]>>
Cc: damien.saucez <[email-masked]<mailto:[email-masked]>>; lisp <[email-masked]<mailto:[email-masked]>>
Verschickt: So, 7 Jul 2013 8:59 pm
Betreff: Re: [lisp] No LISP meeting for Berlin

Dino,really?

Dino

Sorry,
Heiner

-----Ursprüngliche Mitteilung-----
Von: Dino Farinacci <[email-masked]>
An: Damien Saucez <[email-masked]>
Cc: heinerhummel <[email-masked]>; lisp <[email-masked]>
Verschickt: Sa, 6 Jul 2013 8:01 pm
Betreff: Re: [lisp] No LISP meeting for Berlin

Dino

Damien Saucez

Heiner

_______________________________________________
lisp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lisp
_______________________________________________
lisp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lisp

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 8 Jul 2013 09:50:04 -0700

> HH: But anyone who sees that the IPv4-address is enhanced by another 4 octets locator is tempted to assume

The other 4 octets is the RLOC. That is basically ephemeral and is the "current location" of the IPv4 address. Where the IPv4 address is more "static" and assigned to the layer-4 communicating entity.

> that uniqueness is provided by some unique combination of IPv4 address + locator. Just as if a postal letter is sent to some Mr. Smith, or Mr. Li, or Herr Meier or Mr. Dupont. And btw, I am not sure whether that wasn't an initial argument in favor of LISP, otherwise I would have brought up this issue years earlier.

Not true at the transport layer and for any application referrals to addresses. The EID must be unique because that is the transport architecture requirement. We have NATs so we can reuse addresses in a local scope but still communicate globally.

> HH: Right,  sounds very innocently. But even LISP 2.0 (I guess) had once been better .

Heiner, please don't be stuck in one point of time. The LISP design has evolved over the past 6.5 years. We don't have 1.0 or 2.0 anymore. We have simply this:

(1) A data-plane made up of ITRs, ETRs, RTRs, PxTRs. That do map-and-encap.
(2) A control-plane that defines an API for the components in (1) to access the mapping database. That API is the use of Map-Requests, Map-Replies, Map-Registers, and Map-Notify messages among mapping database components which are Map-Resolvers and Map-Servers.
(3) We connect all the Map-Resolvers and Map-Servers together with LISP-DDT nodes using the DNS iterative model lookup approach.

That is LISP today. That is what vendors are shipping and that is how it is being deployed. The LISP-DDT in (3) is viewed or defined as a "mapping database transport system", which is modular and can be pulled out and another MDTS can be put. In some to mention are ALT, SH-DHT, or NERD.

Dino

---

From: [email-masked]
Date: Tue, 9 Jul 2013 05:46:43 -0400 (EDT)

Indeed, there are immensely many useful capabilities provided that  addressing would serve routing which is about the WHERE, WHERE-TO and WHERE-FROM.
Consider E.164 : There are country codes and inside which ever country where Siemens EWSD switches were deployed each rotary dialed digit did select link after link electro-mechanically !!! down to the destination. Inside Germany the leading digit "3" was spared for the Eastern part while most the Western politician had given up hope for the reunion and all of the Eastern part did everything to prevent it.

Whereas IP addressing is as WHERE-agnostic as is MAC-addressing or AS numbering. No WHERE-knowledge nowhere. Conex doesn't recognize areas of congestion, multi-homing is a "let's try the other link"-game as to await what might happen. Columbus-Routing (knowing that the earth is a ball) is out of question being against the holy DV-doctrine.
DiffServ is proud to operate without any knowledge about what is beyond the waiting queues for incoming packets. IPv6 defines an Anycast address space without scopes that  limited the area of being advertised. Examples: A Anycast-destination "free parking lot" might only be disseminated inside the own city i.e. not outside of it. A Anycast-destination "gas station" might only be disseminated over some area whose radius corresponds with the remaining miles indicated by a warning display to the driver.Etc.Etc. But such scope
is not intended at all and wouldn't even help because IPv6 is as WHERE-agnostic as is IPv4.

With the upcoming of the loc-id-split paradigm I saw the chance for a change and indeed TARA, being a loc-id-split solution, would end this WHERE-agnosticism.
LISP however keeps up with it. As well as IPv6 :-(

Heiner

-----Ursprüngliche Mitteilung----- 
Von: Sharon Barkai <[email-masked]>
An: heinerhummel <[email-masked]>
Cc: farinacci <[email-masked]>; lisp <[email-masked]>
Verschickt: Mo, 8 Jul 2013 1:14 pm
Betreff: Re: [lisp] No LISP meeting for Berlin

--szb

On Jul 8, 2013, at 13:11, "[email-masked]" <[email-masked]> wrote:

-----Ursprüngliche Mitteilung-----
Von: Dino Farinacci <[email-masked]>
An: heinerhummel <[email-masked]>
Cc: damien.saucez <[email-masked]>; lisp <[email-masked]>
Verschickt: So, 7 Jul 2013 8:59 pm
Betreff: Re: [lisp] No LISP meeting for Berlin

Dino,really?

Dino

Sorry,
Heiner

-----Ursprüngliche Mitteilung-----
Von: Dino Farinacci <[email-masked]>
An: Damien Saucez <[email-masked]>
Cc: heinerhummel <[email-masked]>; lisp <[email-masked]>
Verschickt: Sa, 6 Jul 2013 8:01 pm
Betreff: Re: [lisp] No LISP meeting for Berlin

Dino 

Damien Saucez

Heiner

---

From: Marc Binderberger <[email-masked]>
Date: Wed, 10 Jul 2013 10:23:56 +0200

Hello Heiner,

I have to say your emails are difficult to parse.

Anyway, I get the impression you talk about two different things. If 
you want a hierarchical address space for better scale or a global view 
of your routing with respect to congestion etc. then LISP is not 
solving this.  LISP may help to decouple existing end point 
infrastructure from your transport network though. This allows you to 
introduce new schemes in the EID or RLOC space, including TARA if you 
wish.

If you feel disappointed that IPv6 is "more of the same" you are not 
alone - but that's another story, not LISP. LISP is pragmatic, the 
separation opens the door for a new transport if needed - no more, no 
less.

My $0.02

Regards, Marc

On Tue, 9 Jul 2013 05:46:43 -0400 (EDT), [email-masked] wrote:
> Indeed, there are immensely many useful capabilities provided that  
> addressing would serve routing which is about the WHERE, WHERE-TO and 
> WHERE-FROM.
> Consider E.164 : There are country codes and inside which ever 
> country where Siemens EWSD switches were deployed each rotary dialed 
> digit did select link after link electro-mechanically !!! down to the 
> destination. Inside Germany the leading digit "3" was spared for the 
> Eastern part while most the Western politician had given up hope for 
> the reunion and all of the Eastern part did everything to prevent it.
> 
> 
> Whereas IP addressing is as WHERE-agnostic as is MAC-addressing or AS 
> numbering. No WHERE-knowledge nowhere. Conex doesn't recognize areas 
> of congestion, multi-homing is a "let's try the other link"-game as 
> to await what might happen. Columbus-Routing (knowing that the earth 
> is a ball) is out of question being against the holy DV-doctrine.
> DiffServ is proud to operate without any knowledge about what is 
> beyond the waiting queues for incoming packets. IPv6 defines an 
> Anycast address space without scopes that  limited the area of being 
> advertised. Examples: A Anycast-destination "free parking lot" might 
> only be disseminated inside the own city i.e. not outside of it. A 
> Anycast-destination "gas station" might only be disseminated over 
> some area whose radius corresponds with the remaining miles indicated 
> by a warning display to the driver.Etc.Etc. But such scope
> With the upcoming of the loc-id-split paradigm I saw the chance for a 
> change and indeed TARA, being a loc-id-split solution, would end this 
> WHERE-agnosticism.
> Step1: you lookup  the routing location  of Mr. Smith, or Mr. Li, or 
> Herr Meier or Mr. Dupont in a huge ID "phone book" a (secure) 
> distributed database lookup problem, strictly overlay not a routing 
> problem.
> 
> 
> Step 2: you insert the letter into an outer envelope with a 
> postal-service (routable) address, leverage whatever hop to hop 
> routing lookup solution you have at the moment scale, cost, 
> efficiency wise.  FedEx, ups etc.
> 
> 
> Yes - really. When you post an email like you did (and you do it 
> repeatedly with little technical data), I have to respond that way. 
> 
> 
> HH: Here is all technical detail:   
> 
http://www.igi-global.com/chapter/topology-aggregating-routing-architecture-tara/77501
> And it never claimed to solve this problem.  It you know what? It 
> does help because you can use other address spaces to help the 
> allocation of devices.  So you can use IPv6 EIDs for site devices 
> versus IPv4 addresses. Allowing more IPv4 addresses to be used for 
> RLOCs and therefore be able to address more sites. 
> 
> 
> HH: But anyone who sees that the IPv4-address is enhanced by another 
> 4 octets locator is tempted to assume that uniqueness is provided by 
> some unique combination of IPv4 address + locator. Just as if a 
> postal letter is sent to some Mr. Smith, or Mr. Li, or Herr Meier or 
> Mr. Dupont. And btw, I am not sure whether that wasn't an initial 
> argument in favor of LISP, otherwise I would have brought up this 
> issue years earlier.
> 
> 
> 
> HH: LISP is not involving the user, that is my reproach. If there 
> were no IPv4 address depletion issue then it would be a pro-argument 
> not to involve the user. But a) we are used to getting WINDOW-updates 
> every now and then, and b) by expanding the IPv4 address space by 
> O(2^32) that pro-argument is overruled by far. (TARA would even 
> provide an IPv4-address space extension of O(2^40) !!! )
> 
> 
> 
> address + Locator) the IPv4 address space could easily do for another 
> thousand years (all it takes is to ensure that any IPv4-address is 
> unique per associated locator) LISP-DDT prevents that for good, and 
> you make us believe that LISP would be of any service to IPv4 ?!
> 
> 
> 
> LISP-DDT is a database to move Map-Request around. It says nothing 
> about how and how much address is allocated. 
> 
> 
> The bad thing is that very very precious time goes by while (naive) 
> people/observers trust in LISP on this respect.
> 
> 
> 
> HH: I never doubted that LISP would just work as you have had it in 
> your mind, nor that you would be able to adjust it such that it suits 
> all existing forwarding mechanisms.
>        
> 
> 
> 
> Just like myself when I argued that LISP-DDT cannot work assuming 
> that LISP were after a 4+4 octet unicast address space extension.
> 
> 
> There are servers everywhere. Even not on the Internet. We leave in a 
> world of abuse. But I would like to think we live in a world where 
> people help things that serve. 
> 
> 
> Dino 
> 
> 
> 
> either by malicious hackers or by malicious owners, or the alliance 
> of both. Who is able to control these servers is able to control  
> internet forwarding.