Subject: [lisp] EID Block Drafts

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 23 Oct 2013 16:07:45 -0400

I look forward to discussing these drafts at the meeting.

Personally I am a bit confused and uncertain as to what to think about 
whether the allocation is useful.

The draft starts with some motivations which seem to depend upon 
everyone using IPv6 EIDs from the block, as otherwise it appears that 
the decision can not be made as described

Then it gets to the argument about needing EIDs that are not advertised 
in BGP.  This seems to make sense.  That is where we want to end up. 
And blocks which are not for Internet advertisement are not apparently 
what you get from RIRs or even requests for PI space.

But then I wondered.  What about PITRs?  Even if we say that the EID 
block is for cases where addresses are not in the BGP table, the PITRs 
will need to advertise portions of the block.  As far as I can tell from 
the deployment models, we can not even require that the EID block only 
be advertised as a whole, since there seem to be cases for partial 
advertisement by PITRs that only serve part of the space.

So I am back to not knowing quite what works.
Yours,
Joel

---

From: Sander Steffann <[email-masked]>
Date: Thu, 24 Oct 2013 00:25:56 +0200

Hi,

> And blocks which are not for Internet advertisement are not apparently what you get from RIRs or even requests for PI space.

This is incorrect. It is perfectly fine to go to an RIR to get address space even if you choose not to announce/route it on the internet (for any value of 'internet').

Cheers,
Sander

---

From: Luigi Iannone <[email-masked]>
Date: Mon, 28 Oct 2013 16:33:03 +0100

Hi,

On 24 Oct. 2013, at 00:25 , Sander Steffann <[email-masked]> wrote:

> This is incorrect. It is perfectly fine to go to an RIR to get address space even if you choose not to announce/route it on the internet (for any value of 'internet’)

The new document about the EID block management does not require nor exclude RIRs. According with what discussed during last meeting it discusses only the “how” but not the “who”. 

ciao

Luigi 

> .

> Cheers,
> Sander
> 
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: Luigi Iannone <[email-masked]>
Date: Mon, 28 Oct 2013 16:43:35 +0100

Hi Joel,

a couple of comments inline.

On 23 Oct. 2013, at 22:07 , Joel M. Halpern <[email-masked]> wrote:

> Personally I am a bit confused and uncertain as to what to think about whether the allocation is useful.
> 

Well… having the slots at the meeting will give the opportunity to clarify ;-

> The draft starts with some motivations which seem to depend upon everyone using IPv6 EIDs from the block, as otherwise it appears that the decision can not be made as described

The point was more about avoiding penalizing non-LISP traffic while identifying LISP traffic. With such information different policies/TE can be applied on each traffic type.

But I can agree that the text needs more clarification.

> 
> Then it gets to the argument about needing EIDs that are not advertised in BGP.  This seems to make sense.  That is where we want to end up. And blocks which are not for Internet advertisement are not apparently what you get from RIRs or even requests for PI space.
> 
> But then I wondered.  What about PITRs?  Even if we say that the EID block is for cases where addresses are not in the BGP table, the PITRs will need to advertise portions of the block.  As far as I can tell from the deployment models, we can not even require that the EID block only be advertised as a whole, since there seem to be cases for partial advertisement by PITRs that only serve part of the space.
> 

True. 
Yet, we may propose some specific policies to apply to PITR (e.g., not deaggregating more than a certain point, if a certain PITR does not service a certain part of the block it can tunnel the traffic to someone that does).

Thanks for your comments

Luigi