Subject: [lisp] Q: draft-ietf-lisp-introduction-04.txt

From: DaeYoung KIM <[email-masked]>
Date: Thu, 17 Jul 2014 21:57:12 +0200

Hi,

Now that this document seems to be for a novice like me, may I ask some
stupid questions?

In the basic model where cases of multiple or virtual RLOCs for a xTR are
excluded:

1) When a node moves from one subnet to another within a LISP site, does
the EID change or not?

2) Is my understanding correct that all EIDs within a site would be mapped
to a single RLOC as a result of query to the map server?

-- 
DY

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 17 Jul 2014 13:03:00 -0700

> Hi,
> 
> Now that this document seems to be for a novice like me, may I ask some stupid questions?
> 
> In the basic model where cases of multiple or virtual RLOCs for a xTR are excluded:
> 
> 1) When a node moves from one subnet to another within a LISP site, does the EID change or not?

In general, when an EID is assigned to a node, it shouldn't change. So if the node moved outside of the LISP site, the RLOCs associated with the new location would be used. But when an EID is assigned to a node (either static or via DHCP) and the node moves around inside of the LISP site, it is up to existing mechanisms to allow the mobility. So in the static case, that would mean a host route would need to be injected into the IGP if the node's address stays the same or in the DHCP case, the node gets a new address associated with the subnet it just attached on and starts using that address (and all previous connections are dropped).

> 2) Is my understanding correct that all EIDs within a site would be mapped to a single RLOC as a result of query to the map server?

Yes, if all those EIDs are in the same power-of-2 prefix which is registered to the mapping system as an EID-prefix.

Dino

> 
> -- 
> DY
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: DaeYoung KIM <[email-masked]>
Date: Thu, 17 Jul 2014 22:19:19 +0200

On Thu, Jul 17, 2014 at 10:03 PM, Dino Farinacci <[email-masked]>
wrote:

> But when an EID is assigned to a node (either static or via DHCP)

Is there a case in LISP that EID would be assigned to its interface rather
than to a node?

Somewhere, it is said that the behavior of network elements within a site
doesn't change, which is thought to be one of the major strong feature of
LISP. If that is the case, then the EID would be assigned to the interface
like with the current Internet.

> and the node moves around inside of the LISP site, it is up to existing
> mechanisms to allow the mobility.
>

Assuming you really meant the node, not the interface, which existing
mechanism would allow the mobility? OSPF or ISIS?

If you meant, in fact, the interface but not the node in your discussion of
the EID assignment, do you mean a MIP like mechanism would provide the
mobility within a site?

> So in the static case, that would mean a host route would need to be
> injected into the IGP if the node's address stays the same

I cannot catch what you exactly mean here by 'injection'. Sorry...

> or in the DHCP case, the node gets a new address associated with the
> subnet it just attached on and starts using that address (and all previous
> connections are dropped).

Yes, no special mobility is provided by LISP itself...

So, in short, what mobility solution is provided by LISP in addition to the
existing mobility mechanisms?

-- 
DY

---

From: DaeYoung KIM <[email-masked]>
Date: Thu, 17 Jul 2014 22:26:42 +0200

On Thu, Jul 17, 2014 at 10:03 PM, Dino Farinacci <[email-masked]>
wrote:

> > 2) Is my understanding correct that all EIDs within a site would be
> mapped to a single RLOC as a result of query to the map server?
>
> Yes, if all those EIDs are in the same power-of-2 prefix which is
> registered to the mapping system as an EID-prefix.

By mapping, I'd mean mapping an EID to a RLOC so that the remote node would
know which RLOC should be used to reach a LISP site where the node of the
very EID belongs. I don't think this mapping has anything to do with an
EID-prefix. Am I mistaken?

Another related question might be.... is there any compelling reason why
EIDs within a site should better be assigned in the same power-of-2 prefix?

If the EID would be assigned to a node, it wouldn't matter much. Or is it
to save entry space in the mapping server?

The power-of-2 might make sense if the EID is, in fact, assigned to the
interface just like the Internet. Then, you would benefit from more
efficient interior routing by subnet masks.

Where am I lost?

-- 
DY

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 17 Jul 2014 13:33:41 -0700

> On Thu, Jul 17, 2014 at 10:03 PM, Dino Farinacci <[email-masked]> wrote:
> Is there a case in LISP that EID would be assigned to its interface rather than to a node?

That is independent of LISP. I have done both while doing development and test. And a node can have multiple EIDs if one chooses to do that. In fact, a dual-stack host will have two EIDs, one IPv4 and one IPv6.

> Somewhere, it is said that the behavior of network elements within a site doesn't change, which is thought to be one of the major strong feature of LISP. If that is the case, then the EID would be assigned to the interface like with the current Internet.

Right, there are no requirements how EIDs are assigned locally within a system. Remember, the EID is on a unchanged host. From that host's point of view, it is just an address. From the LISP site's point of view, that address is reachable via local routing.

> and the node moves around inside of the LISP site, it is up to existing mechanisms to allow the mobility. 
> 
> Assuming you really meant the node, not the interface, which existing mechanism would allow the mobility? OSPF or ISIS?

What I meant is the "IP address" is moving. Saying it that way means no matter how it is assigned on the local device, what is moving is the IP address.

> If you meant, in fact, the interface but not the node in your discussion of the EID assignment, do you mean a MIP like mechanism would provide the mobility within a site?

I didn't and don't need to make that distinction.

> So in the static case, that would mean a host route would need to be injected into the IGP if the node's address stays the same
> 

When a host 10.1.1.1 moves off subnet 10.1.0.0/16 to subnet 11.1.0.0/16, the routers attached to 11.1 need to advertise a 10.1.1.1/32 route into the routing system.

> or in the DHCP case, the node gets a new address associated with the subnet it just attached on and starts using that address (and all previous connections are dropped).
> 
> So, in short, what mobility solution is provided by LISP in addition to the existing mobility mechanisms? 
> 
> -- 
> DY

There are different scopes of mobility. When you roam across LISP site, you use LISP mobility. When you roam within LISP sites you use IP-mobility or host routes.

Dino

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 17 Jul 2014 13:39:34 -0700

> By mapping, I'd mean mapping an EID to a RLOC so that the remote node would know which RLOC should be used to reach a LISP site where the node of the very EID belongs. I don't think this mapping has anything to do with an EID-prefix. Am I mistaken?

Say you have a cluster of VMs that work together at the applicaiton-layer. And you want to move them together to a cloud provider. In this case the EIDs of the VMs in the cluster are part of the same power-of-2 prefix. In this case, that is an EID-prefix that moves so the new set of RLOCs are the one that reside at the cloud provider.

> Another related question might be.... is there any compelling reason why EIDs within a site should better be assigned in the same power-of-2 prefix?

If they fate-share RLOC changes, they should be assigned in power-of-2 blocks.

> If the EID would be assigned to a node, it wouldn't matter much. Or is it to save entry space in the mapping server?

The only real issue with assigning addresses to nodes versus interfaces (this is a general comment), is if the routers know directly how to reach the address. When the address is assigned to an interface, routers are directly attached to the subnet of node's interface address. When it is assigned say to a loopback interface, the routers need more information to know what physical interface the node is reachable on.

This discussion happened in the 80s when designing DECnet and the OSI network layer. And the discussion came up again for IPng. As you know by now, IPv6 has interface assigned addresses much like IPv4.

> The power-of-2 might make sense if the EID is, in fact, assigned to the interface just like the Internet. Then, you would benefit from more efficient interior routing by subnet masks.
> 
> Where am I lost?

I don't think you are. You just want to get a deeper understanding, which is great!

Dino

---

From: DaeYoung KIM <[email-masked]>
Date: Thu, 17 Jul 2014 23:14:40 +0200

On Thu, Jul 17, 2014 at 10:33 PM, Dino Farinacci <[email-masked]>
wrote:

> That is independent of LISP.

Yes, in principle. But if you'd maintain the assertion (if such an
assertion has ever been made) that the network elements within a site
doesn't change, it would automatically assumed that

  - nodes in a site maintains the IP address (already) assigned, and
  - the IP addresses would have been assigned to the interfaces.

And a node can have multiple EIDs if one chooses to do that. In fact, a
> dual-stack host will have two EIDs, one IPv4 and one IPv6.
>

This multiple EIDs for a node is not my immediate concern in this
discussion. I'm try to confine myself to the most basic model of LISP, in
order better to understand it.

> > Somewhere, it is said that the behavior of network elements within a
> site doesn't change, which is thought to be one of the major strong feature
> of LISP. If that is the case, then the EID would be assigned to the
> interface like with the current Internet.
>
> Right, there are no requirements how EIDs are assigned locally within a
> system. Remember, the EID is on a unchanged host. From that host's point of
> view, it is just an address. From the LISP site's point of view, that
> address is reachable via local routing.
>

This means... (if an EID is assigned to an interface)... the e2e transport
connection would break if a node move from one subnet to another within a
site. LISP doesn't contribute to solving/improving the intra-site mobility.
Right?

> What I meant is the "IP address" is moving. Saying it that way means no
> matter how it is assigned on the local device, what is moving is the IP
> address.
>

I'm still in the same hole. Does this IP address change when a node moves
from one subnet to another or not?

> > If you meant, in fact, the interface but not the node in your discussion
> of the EID assignment, do you mean a MIP like mechanism would provide the
> mobility within a site?
>

So, you don't care about the intra-site problems at all. You focus on the
inter-site routing, don't you?

The whole idea of LIS(locator/id separation) is to solve, among many
things, the mobility problem. To ensure that, an ID would be kept constant
at moving of a node while locator would be updated at every such moving. Am
I correct?

However, if behavior of the all network elements within a site doesn't have
to change, as asserted somewhere in the main documents, (this would mean
that ARP is also at work as usual), the ID (in fact, the IP address) would
change at any such moving, which would not keep the EID constant. Such move
would not only break a intra-site connection but also a connection between
sites.

So, you cannot just ignore the intra-site problems. If the EID(IP address)
has to change at every node moving across subnets within a site, the whole
purpose of ID (in LIS) would be questioned. Isn't this in contradiction to
the whole idea of LIS?

If the EID would be kept constant even at moving within a site, then some
network elements within a site have to change their behavior, don't they?
Even the host behavior might have to change like, for example, shutting off
the ARP operation.

Also, EIDs can be flat, as with other usual LIS proposals, and need not
necessarily be out of a power-of-2 EID prefix. Correct?

> When a host 10.1.1.1 moves off subnet 10.1.0.0/16 to subnet 11.1.0.0/16,
> the routers attached to 11.1 need to advertise a 10.1.1.1/32 route into
> the routing system.
>

Got it. This is exactly what ISIS is doing, right?

> There are different scopes of mobility. When you roam across LISP site,
> you use LISP mobility.

You mean the tunneling..? Tunneling implicitly provides some sort of
mobility... like that?

> When you roam within LISP sites you use IP-mobility or host routes.
>

So, no additional contribution by LISP as far as intra-site mobility is
concerned. Right?

-- 
DY

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 17 Jul 2014 14:19:11 -0700

DY and I are going private. If anyone wants a summary of this discussion DY will provide one.

Dino

On Jul 17, 2014, at 2:14 PM, DaeYoung KIM <[email-masked]> wrote:

> On Thu, Jul 17, 2014 at 10:33 PM, Dino Farinacci <[email-masked]> wrote:
> 
> Yes, in principle. But if you'd maintain the assertion (if such an assertion has ever been made) that the network elements within a site doesn't change, it would automatically assumed that
> 
> And a node can have multiple EIDs if one chooses to do that. In fact, a dual-stack host will have two EIDs, one IPv4 and one IPv6.
> 
> This multiple EIDs for a node is not my immediate concern in this discussion. I'm try to confine myself to the most basic model of LISP, in order better to understand it.
>  
> This means... (if an EID is assigned to an interface)... the e2e transport connection would break if a node move from one subnet to another within a site. LISP doesn't contribute to solving/improving the intra-site mobility. Right?
> 
> I'm still in the same hole. Does this IP address change when a node moves from one subnet to another or not?
>  
> So, you don't care about the intra-site problems at all. You focus on the inter-site routing, don't you?
> 
> The whole idea of LIS(locator/id separation) is to solve, among many things, the mobility problem. To ensure that, an ID would be kept constant at moving of a node while locator would be updated at every such moving. Am I correct?
> 
> However, if behavior of the all network elements within a site doesn't have to change, as asserted somewhere in the main documents, (this would mean that ARP is also at work as usual), the ID (in fact, the IP address) would change at any such moving, which would not keep the EID constant. Such move would not only break a intra-site connection but also a connection between sites.
> 
> So, you cannot just ignore the intra-site problems. If the EID(IP address) has to change at every node moving across subnets within a site, the whole purpose of ID (in LIS) would be questioned. Isn't this in contradiction to the whole idea of LIS?
> 
> If the EID would be kept constant even at moving within a site, then some network elements within a site have to change their behavior, don't they? Even the host behavior might have to change like, for example, shutting off the ARP operation.
> 
> Also, EIDs can be flat, as with other usual LIS proposals, and need not necessarily be out of a power-of-2 EID prefix. Correct?
> 
> There are different scopes of mobility. When you roam across LISP site, you use LISP mobility.
> 
> You mean the tunneling..? Tunneling implicitly provides some sort of mobility... like that?
>  
> So, no additional contribution by LISP as far as intra-site mobility is concerned. Right? 
> 
> -- 
> DY

---

From: DaeYoung KIM <[email-masked]>
Date: Thu, 17 Jul 2014 23:32:02 +0200

On Thu, Jul 17, 2014 at 10:39 PM, Dino Farinacci <[email-masked]>
wrote:

Say you have a cluster of VMs that work together at the applicaiton-layer.
> And you want to move them together to a cloud provider. In this case the
> EIDs of the VMs in the cluster are part of the same power-of-2 prefix.

If only the EIDs already had been assigned out of the same power-of-2
prefix since the cluster of VMs is part of the usual Internet.

What if they had not?

> In this case, that is an EID-prefix that moves so the new set of RLOCs are
> the one that reside at the cloud provider.
>

An EID-prefix needs only one RLOC, doesn't it? The whole EIDs in the same
site would be mapped to the one single RLOC (in the basic model) for the
purpose of inter-site routing...

> If they fate-share RLOC changes, they should be assigned in power-of-2

Why should EIDs fate-share RLOC changes? EID are for e2e connection while
RLOCs are for routing...

> The only real issue with assigning addresses to nodes versus interfaces
> (this is a general comment), is if the routers know directly how to reach
> the address. When the address is assigned to an interface, routers are
> directly attached to the subnet of node's interface address. When it is
> assigned say to a loopback interface, the routers need more information to
> know what physical interface the node is reachable on.
>

Not a problem in link-state routing like ISIS or OSPF... or..?

-- 
DY

---

From: DaeYoung KIM <[email-masked]>
Date: Thu, 17 Jul 2014 23:35:32 +0200

Sorry to others for bothering.

On Thu, Jul 17, 2014 at 11:19 PM, Dino Farinacci <[email-masked]>
wrote:

> > This means... (if an EID is assigned to an interface)... the e2e
> transport connection would break if a node move from one subnet to another
> within a site. LISP doesn't contribute to solving/improving the intra-site
> mobility. Right?
> >
> > > If you meant, in fact, the interface but not the node in your
> discussion of the EID assignment, do you mean a MIP like mechanism would
> provide the mobility within a site?
> >
> > However, if behavior of the all network elements within a site doesn't
> have to change, as asserted somewhere in the main documents, (this would
> mean that ARP is also at work as usual), the ID (in fact, the IP address)
> would change at any such moving, which would not keep the EID constant.
> Such move would not only break a intra-site connection but also a
> connection between sites.
> >
> > So, you cannot just ignore the intra-site problems. If the EID(IP
> address) has to change at every node moving across subnets within a site,
> the whole purpose of ID (in LIS) would be questioned. Isn't this in
> contradiction to the whole idea of LIS?
> >
> > If the EID would be kept constant even at moving within a site, then
> some network elements within a site have to change their behavior, don't
> they? Even the host behavior might have to change like, for example,
> shutting off the ARP operation.
> >

-- 
DY

---

From: DaeYoung KIM <[email-masked]>
Date: Fri, 18 Jul 2014 01:28:13 +0200

> If they fate-share RLOC changes, they should be assigned in power-of-2

Now I think I begin to understand what you mean here...

  - With power-of-2 EID assignment, the whole EIDs of a site would be
reduced to a single entry (EID-prefix) in the mapping database.
  - So, one EID to one (or multiple for multi-homing?) RLOC, one-to-one
correspondence, and so fate-sharing...?

This would mean... if any specific node would move to a different site, it
would be given a new EID from a new power-of-2 blocks.

If all EID prefixes of different sites would be kept different, this means
EIDs are each globally unique.

Have you ever thought of the possibility that EIDs of different sites would
consume the same number space? This would mean the same EID-prefix could be
share by different site. This would correspond to local addressing (of
nodes). Have you thought of extending LISP in this direction?

-- 
DY

---

From: DaeYoung KIM <[email-masked]>
Date: Fri, 18 Jul 2014 01:28:54 +0200

Sorry, I mistakenly posted to the list. Will get back to private.

On Fri, Jul 18, 2014 at 1:28 AM, DaeYoung KIM <[email-masked]> wrote:

> Have you ever thought of the possibility that EIDs of different sites
> would consume the same number space? This would mean the same EID-prefix
> could be share by different site. This would correspond to local addressing
> (of nodes). Have you thought of extending LISP in this direction?
>
>
>
> --
> DY
>

-- 
DY

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 17 Jul 2014 16:46:00 -0700

> Have you ever thought of the possibility that EIDs of different sites would consume the same number space? This would mean the same EID-prefix could be share by different site. This would correspond to local addressing (of nodes). Have you thought of extending LISP in this direction?

That is the LISP-VPN use-case. We use instance-IDs to distinguish sites in differnet VPNs.

Dino