Subject: [lisp] Current state of NAT traversal in beta network

From: Rene Bartsch <[email-masked]>
Date: Sat, 16 Aug 2014 11:31:48 +0200

Hi,

Lispmob 4.1 with NAT traversal support is available.

Is there any kind of list which PxTRs in the beta network support RTR 
functionality for NAT traversal?

Do mapping servers/resolvers need special functionality for NAT 
traversal?

Renne

-- 
Best regards,

Rene Bartsch, B. Sc. Informatics

---

From: "Gregg Schudel (gschudel)" <[email-masked]>
Date: Sun, 17 Aug 2014 19:41:54 +0000

On Aug 16, 2014, at 2:31 AM, Rene Bartsch <[email-masked]> wrote:

> Is there any kind of list which PxTRs in the beta network support RTR functionality for NAT traversal?
> 
> Do mapping servers/resolvers need special functionality for NAT traversal?
> 
> 
> Renne
> 
> -- 
> Best regards,
> 
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

Hey Rene

This mailer ([email-masked]) (I would assume) is best used for IETF LISP Working 
Group questions.

The LISP Beta Network is a multi-company/university effort to educate and inform about the 
LISP protocol. While it’s (obviously) running various LISP implementations, the operation 
and support is not tied to the IETF or the working group. As noted on www.lisp4.net, 
questions about operations can be sent to [email-masked] (we happen to host
the mailer).

With regard to LISP NAT-Traversal, 
* yes - lispmob (and also an appropriate place to ask questions -- lispmob.org) does have 
  experimental code for NAT-T, and LISP Beta Network does have a few PxTRs running experimental 
  NAT-T code (meaning they are now RTRs) for this purpose. 
* yes, Map-Server/Map-Resolver functionality is also applied for NAT-T. This relationship 
  (between an MSMR and an RTR) is covered quite well in "draft-ermagan-lisp-nat-traversal.06”
  (http://tools.ietf.org/id/draft-ermagan-lisp-nat-traversal-06.txt)

If you’d like to experiment with lispmob and NAT-T on LISP Beta Network, please send an email
to the lispmob team and they can help. (see the lispmob.org “contact” page)

Best regards,
Gregg

--------------------------------------------------------------------
.:|:.:|:. | gregg schudel (ccie#9591) LISP technical marketing engr
  cisco   | mobile: +1 571 332 2222   email: [email-masked]
--------------------------------------------------------------------
cisco corporate legal statement: 
http://www.cisco.com/web/about/doing_business/legal/cri/index.html
--------------------------------------------------------------------