Subject: [lisp] draft-ietf-lisp-introduction-04 (Part 3)

From: Ronald Bonica <[email-masked]>
Date: Wed, 6 Aug 2014 18:57:54 +0000

Folks,

The editors correctly observe that Section 6.2 needs to be rewritten. A better approach would be to note that LISP is a map-and-encap strategy. An ingress encapsulation endpoint:

- accepts a packet that is addressed from one address space (EID)
- maps the EID addresses to corresponding addresses in another space (LOC)
- encapsulates the incoming packet in another that is addressed using LOC space
- forwards the packet to the egress encapsulation endpoint where it is de-encapsulated

In this regard, LISP is similar to many other encapsulation and VPN technologies (e.g., GRE, L3VPN). 

LISP is different from GRE and L3VPN because it pulls mapping information to itself. By contrast, GRE mapping information is generally configured statically. L3VPN mapping information is pushed by BGP. Therefore, LISP must deal with the problems of stale mapping information and cache misses. Also, LISP must deal with the problem of egress encapsulation node liveness.

Ron Bonica

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 6 Aug 2014 14:06:34 -0700

> LISP is different from GRE and L3VPN because it pulls mapping information to itself. By contrast, GRE mapping information is generally configured statically. L3VPN mapping information is pushed by…

Ron, I have to keep you honest here. It doesn't matter if you pull or push, ANY information that is distributed can be stale. 

If a route changes in BGP and there is a congested path and the Update is continually being retransmitted by TCP to get to the BGP peer, that BGP peer has stale information.

Dino

---

From: Ronald Bonica <[email-masked]>
Date: Mon, 11 Aug 2014 16:59:43 +0000

Dino,

You have a very good point! 

In order to help the reader understand the difference between LISP and BGP, it might be a good idea to add a few pages that compare and contrast the two. It should answer the following questions:

- In BGP, how does the producer of a route know that it is time to push it
- In LISP, how does the consumer of a route know that it is time to pull it
- In BGP, what happens when the control path between the producer and consumer of a route becomes degraded or unusable
- In LISP, what happens when the control path between the producer and consumer of a route becomes degraded or unusable

                                                                                                   Ron

> -----Original Message-----
> From: Dino Farinacci [mailto:[email-masked]]
> Sent: Wednesday, August 06, 2014 5:07 PM
> To: Ronald Bonica
> Cc: LISP mailing list list
> Subject: Re: [lisp] draft-ietf-lisp-introduction-04 (Part 3)
> 
> 
> > LISP is different from GRE and L3VPN because it pulls mapping information
> to itself. By contrast, GRE mapping information is generally configured
> statically. L3VPN mapping information is pushed by BGP. Therefore, LISP
> must deal with the problems of stale mapping information and cache misses.
> Also, LISP must deal with the problem of egress encapsulation node liveness.
> 
> Ron, I have to keep you honest here. It doesn't matter if you pull or push,
> ANY information that is distributed can be stale.
> 
> If a route changes in BGP and there is a congested path and the Update is
> continually being retransmitted by TCP to get to the BGP peer, that BGP peer
> has stale information.
> 
> Dino

---

From: "Darrel Lewis (darlewis)" <[email-masked]>
Date: Mon, 11 Aug 2014 17:28:56 +0000

> - In LISP, what happens when the control path between the producer and consumer of a route becomes degraded or unusable

I eagerly await your suggested text.

-D

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 11 Aug 2014 15:08:17 -0700

It is not a LISP versus BGP comparison we need to do. Because if we did that, then we would have to compare LISP with mobile-IP, IPsec, DNS, and other similar features that overlap.

Plus there are enivronments where LISP is used where BGP doesn't exist, so how could we compare.

Dino

---

From: Ronald Bonica <[email-masked]>
Date: Mon, 11 Aug 2014 22:55:54 +0000

<This time adding the folks who I dropped accidentally>

Darrel,

Fair enough. 

Could the editors leave an empty section between the sections that are now numbered 6.4 and 6.5. The Title of that section is "Differences Between LISP and BGP". I will provide text within the next week or so.

                                                       Ron

> From: Darrel Lewis (darlewis) [mailto:[email-masked]]
> Sent: Monday, August 11, 2014 1:29 PM
> To: Ronald Bonica
> Cc: Darrel Lewis (darlewis); Dino Farinacci; LISP mailing list list
> > In order to help the reader understand the difference between LISP and
> BGP, it might be a good idea to add a few pages that compare and contrast
> the two. It should answer the following questions:
> >
> > - In BGP, what happens when the control path between the producer and
> consumer of a route becomes degraded or unusable
> > - In LISP, what happens when the control path between the producer and
> consumer of a route becomes degraded or unusable
> >
> >                                                                                                   Ron
>

---

From: "Darrel Lewis (darlewis)" <[email-masked]>
Date: Mon, 11 Aug 2014 23:09:41 +0000

<Doing the same>

I mentioned that I’d want to see the text before supporting (or opposing) its inclusion…  So adding sections seems somewhat premature.

-D

---

From: Ronald Bonica <[email-masked]>
Date: Mon, 11 Aug 2014 23:13:28 +0000

Darrel,

Clearly, this is a WG document and the entire WG gets a chance to review, accept or reject a contribution. That goes without saying for any document.

                                                                                      Ron

> Sent: Monday, August 11, 2014 7:10 PM
> To: Ronald Bonica
> I mentioned that I'd want to see the text before supporting (or opposing) its
> inclusion...  So adding sections seems somewhat premature.
> 
> 
> -D
> > Could the editors leave an empty section between the sections that are
> now numbered 6.4 and 6.5. The Title of that section is "Differences Between
> LISP and BGP". I will provide text within the next week or so.
> >
> >                                                       Ron
> >
> >
> >> BGP, it might be a good idea to add a few pages that compare and
> >> contrast the two. It should answer the following questions:
> >>>

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 11 Aug 2014 16:32:52 -0700

We should not compare LISP to any other protocol. We should define what LISP is. BGP and LISP solve different problems.

Dino

---

From: "Victor Moreno (vimoreno)" <[email-masked]>
Date: Tue, 12 Aug 2014 00:51:58 +0000

+1

I am however interested in the comparison, but I don't see it as part of an introduction or other lisp specification document 
Victor

> On Aug 11, 2014, at 4:33 PM, "Dino Farinacci" <[email-masked]> wrote:
> 
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: Albert Cabellos <[email-masked]>
Date: Tue, 12 Aug 2014 23:46:36 +0200

+1

The main goal of the document is to introduce LISP, we should avoid comparisons.

Albert

---

From: Luigi Iannone <[email-masked]>
Date: Wed, 13 Aug 2014 16:57:34 +0200

As a personal opinion, I tend to agree with Dino. 

It might be better to compare pull vs push model without the specifics of BGP (or nay other push-based solution).

Independently from whether we compare vs BGP or not, it is still worth to have such discussion in the document IMHO.

Luigi

---

From: Ronald Bonica <[email-masked]>
Date: Thu, 14 Aug 2014 00:59:21 +0000

Luigi,

You and Dino both have a good point. We don't want to turn the LISP intro document into a beauty contest between BGP and LISP. However, we do want to explain what LISP is and what makes it unique.

The pull model is certainly among LISP's salient characteristics. So, the new section should discuss the following:

- benefits of the pull model
- challenges presented by the pull model
- LISP machinery designed to address those challenges

I would be glad to propose some text for that section.

                                           Ron

> From: Luigi Iannone [mailto:[email-masked]]
> Sent: Wednesday, August 13, 2014 10:58 AM
> To: Dino Farinacci
> Cc: Ronald Bonica; LISP mailing list list
> Independently from whether we compare vs BGP or not, it is still worth to
> have such discussion in the document IMHO.
> 
> Luigi
> 
> 
> 
> > We should not compare LISP to any other protocol. We should define what
> LISP is. BGP and LISP solve different problems.
> >
> > Dino
> >
> >> Clearly, this is a WG document and the entire WG gets a chance to review,
> accept or reject a contribution. That goes without saying for any document.
> >>
> >>
> >> Ron
> >>
> >>> I mentioned that I'd want to see the text before supporting (or
> >>> opposing) its inclusion...  So adding sections seems somewhat
> premature.
> >>>
> >>>
> >>> -D
> >>> now numbered 6.4 and 6.5. The Title of that section is "Differences
> >>> Between LISP and BGP". I will provide text within the next week or so.
> >>>>
> >>>>                                                     Ron
> >>>>
> >>>>
> >>>>>> - In BGP, what happens when the control path between the
> producer
> >>>>>> and