Subject: [lisp] Proposed LISP WG Charter

From: Luigi Iannone <[email-masked]>
Date: Fri, 15 Jan 2016 10:14:37 +0100

Hi Deborah,

The LISP WG had a final round of discussion (on the mailing list) 
earlier this month on the new proposed charter.

Hereafter you can find the outcome.
This version includes all items the WG is ready to work on.

thanks

ciao

Luigi

%%%%%%%% LISP WG PROPOSED CHARTER %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

The LISP WG has completed the first set of Experimental RFCs describing the Locator/ID Separation Protocol (LISP). LISP supports a routing architecture which decouples the routing locators and identifiers, thus allowing for efficient aggregation of the routing locator space and providing persistent identifiers in the identifier space. LISP requires no changes to end-systems or to routers that do not directly participate in the LISP deployment. LISP aims for an incrementally deployable protocol. The scope of the LISP techology is recognized to range from unicast and multicast overlays at Layer 2 as well as at Layer 3, including NAT traversal, VPNs,  and supporting mobility as a general feature, independently of wheter it is a mobile user or a migrating VM, hence being applicable in both Data Centers and public Internet environments.

The LISP WG is chartered to continue work on the LISP base protocol with the main objective to develop a standard solution based on the completed Experimental RFCs and the experience gained from early deployments.

This work will include reviewing the existing set of Experimental RFCs and doing the necessary enhancements to support a base set of standards track RFCs. The group will review the current set of Working Group documents to identify potential standards-track documents and do the necessary enhancements to support standards-track. It is recognized that some of the work will continue on the experimental track, though the group is encouraged to move the documents to standards track in support of network use, whereas the work previously was scoped to experimental documents.

Beside this main focus, the LISP WG work on the following items:

·       Multi-protocol support: Specifying the required extensions to support multi-protocol encapsulation (e.g.,   L2 or NSH – Network Service Headers). Rather than developing new encapsulations the work will aim at using existing well-established encapsulations or emerging from other Working Grops such as  NVO3 and SFC.  

·       Alternative Mapping System Design. By extenting LISP with  new protocols support it is also necessary to develop the required mapping function and control plane extensions to operate LISP map-assisted  networks (which might include Hierarchical Pull, Publish/Subscribe, or Push models, independent mapping systems interconnection, security extensions, or alternative transports of the LISP control protocol).

·       Mobility

·       Multicast: Support for overlay multicast by means of replication as well as interfacing with existing underlay multicast support.

·       Data-Plane Encryption

·       NAT-Traversal

·       Models for managing the LISP protocol and deployments that include data models, as well as allowing for programmable management interfaces. These managament methods should be considered for both the data-plane, control-plane, and mapping system components.

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Tue, 19 Jan 2016 22:58:35 +0000

Hi Luigi,

Looks good - can you add a few words to scope better the three bullet items: mobility, data-plane encryption, NAT-Traversal?

Thanks,
Deborah

-----Original Message-----
From: Luigi Iannone [mailto:[email-masked]] 
Sent: Friday, January 15, 2016 4:15 AM
To: BRUNGARD, DEBORAH A <[email-masked]>; Joel Halpern Direct <[email-masked]>
Cc: LISP mailing list list <[email-masked]>
Subject: Proposed LISP WG Charter

Hi Deborah,

thanks

ciao

Luigi

·       Mobility

·       Data-Plane Encryption

·       NAT-Traversal

---

From: Luigi Iannone <[email-masked]>
Date: Wed, 20 Jan 2016 12:01:06 +0100

This can be surely be done.

Will update the proposed charter before the end of the week.

ciao

L.

> On 19 Jan 2016, at 23:58, BRUNGARD, DEBORAH A <[email-masked]> wrote:
> 
> Hi Luigi,
>

---

From: Luigi Iannone <[email-masked]>
Date: Fri, 22 Jan 2016 13:21:53 +0100

Hi Deborah,

Hereafter you can find an updated charter with additional wording on the items you suggested.

Let us know what you think.

ciao

Luigi

·       Alternative Mapping System Design. By extenting LISP with  new protocols support it is also necessary to develop the required mapping function and control plane extensions to operate LISP map-assisted  networks (which might include Hierarchical Pull, Publish/Subscribe, or Push models, independednt mapping systems interconnection, security extensions, or alternative transports of the LISP control protocol).

·       Mobility: Some LISP deployment scenario include mobile nodes (in mobile environments ) or Virtual Machines – VMs (in data centers), hence support needs to be provided in order to achieve seamless connectivity.   

·       Data-Plane Encryption: In some scenarios it may be desirable to encrypt LISP encapsulated traffic. In this case, the data-plane encryption mechanism itself and support for control-plane security material exchange needs to be specified.

·       NAT-Traversal: Support for NAT-traversal solution in deployments where a LISP xTR is separated from correspondent xTR(s) by a NAT (e.g., LISP mobile node).

 

> On 20 Jan 2016, at 12:01, Luigi Iannone <[email-masked]> wrote:
>

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Tue, 26 Jan 2016 22:18:05 +0000

Hi Luigi,

Looks good - I will start the rechartering process.
Thanks,
Deborah

-----Original Message-----
From: Luigi Iannone [mailto:[email-masked]] 
Sent: Friday, January 22, 2016 7:22 AM
To: BRUNGARD, DEBORAH A <[email-masked]>
Cc: Joel Halpern Direct <[email-masked]>; LISP mailing list list <[email-masked]>
Subject: Re: Proposed LISP WG Charter

Hi Deborah,

ciao

Luigi