Subject: Re: [lisp] Ben Campbell's No Objection on draft-ietf-lisp-eid-block-12: (with COMMENT)

From: Luigi Iannone <[email-masked]>
Date: Thu, 18 Feb 2016 01:31:06 +0100

HI Ben,

thanks for reading the document.

> On 17 Feb 2016, at 22:01, Ben Campbell <[email-masked]> wrote:
> 
> Ben Campbell has entered the following ballot position for
> draft-ietf-lisp-eid-block-12: No Objection
> 
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
> 
> 
> Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
> 
> 
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/draft-ietf-lisp-eid-block/
> 
> 
> 
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
> 
> Substantive:
> 
> - section 6:
> Predictions that the IETF will or will not do something  are risky
> propositions at best. I suggest stating a default result that will occur
> _unless_ the IETF chooses to take action.
> 

That is what the whole document aim. The 3+3 plan is: let’s experiment for 3 year and finish _unless_ the IETF thinks otherwise.

Certainly we can improve the wording in making that _unless_ more clear.

> Editorial:
> There's quite a number of grammar and word choice errors. I list some
> below, but I am sure I did not catch everything. I suggest another pass
> at proofreading before publication.
> 
> -3:
> s/"avoid penalize"/"avoid penalizing"
> s/"ask an allocation"/"ask for an allocation"  ; or "request an
> allocation"
> s/"avoid non-LISP domains to fragment " / "allow non-LISP domains to
> avoid fragmenting"
> "... which would negatively impact the BGP routing infrastructure"
> Which would cause negative impact, the fragmentation, or the avoidance of
> the fragmentation?
> s/"worth to mention"/"worth mentioning"
> 
> -4
> s/"Such prefix"/"Such prefixes"  ; or "This prefix"
> /"As the LISP adoption progress"/"As the LISP adoption progresses"
> 
> "... the EID block will potentially help in reducing the impact on the
> BGP routing infrastructure with respect to the case of the same number of
> adopters using global unicast space allocated by RIRs "
> Convoluted sentence. Can it be simplified?
> s/"Such trend"/"Such trends" ; or "This trend"
> 
> "With the exception of PITR case (described above)"
> Which case is the PITR case? This is the first use of PITR.
> 
> -5:
> s/"looks as sufficiently large"/"appears sufficiently large"
> 
> -9:
> s/"provided by IANA before published"/"provided by IANA before
> publication"
> 
> 
Thanks. Will fix all fo this.

ciao

Luigi

---

From: "Ben Campbell" <[email-masked]>
Date: Wed, 17 Feb 2016 13:01:47 -0800

Substantive:

- section 6:

Editorial:

-3:

-4

-5:

-9: