Subject: [lisp] A question regarding draft-boucadair-lisp-v6-compact-header

From: "Jose Saldana" <[email-masked]>
Date: Fri, 1 Apr 2016 10:48:54 +0200

Dear Mohamed and Christian,
 
I have read your draft about a compact header for LISP to avoid MTU issues.
 
However, have you also considered bandwidth savings for small packets as an
additional benefit? I mean, when you use LISP to send small packets between
two locations, the overhead is huge:
 
a) For example, if you are sending an IPv4 TCP ACK (40 bytes), with standard
LISP over IPv6 you need 96 bytes:
 
OH (IPv6): 40 bytes
UDP: 8 bytes
LISP: 8 bytes
IH (IPv4): 20 bytes
TCP: 20 bytes
 
However, if you use the compact header proposed in your draft, you will only
need 72 bytes (if I am right), so you are saving 25% of the bandwidth.
Taking into account that there is a high amount of TCP ACKs, this may
perhaps have an impact.

b) Or if you are sending an RTP sample with e.g. 20 bytes of payload, using
standard LISP over IPv6, you need 116 bytes:
 
OH (IPv6): 40 bytes
UDP: 8 bytes
LISP: 8 bytes
IH (IPv4): 20 bytes
UDP: 8 bytes
RTP: 12 bytes
Payload: 20 bytes
 
But if you use the compact header, you will only need 88 bytes (24% saving).

In order to increase these savings, we are currently considering the
possibility of submitting a draft adding header compression with ROHC, and
multiplexing a number of small packets into a single LISP one, if the ITR
has a number of small packets in its buffer. Reducing the number of packets
will reduce the processing in intermediate routers, also reducing e.g.
energy consumption and perhaps some processing delays.

BR,
 
Jose

---

From: <[email-masked]>
Date: Fri, 1 Apr 2016 12:31:24 +0000

Dear Jose,

Thank you for sharing the comment.

Please see inline.

Cheers,
Med

De : Jose Saldana [mailto:[email-masked]]
Envoyé : vendredi 1 avril 2016 10:49
À : [email-masked]; [email-masked]
Objet : A question regarding draft-boucadair-lisp-v6-compact-header

However, have you also considered bandwidth savings for small packets as an additional benefit? I mean, when you use LISP to send small packets between two locations, the overhead is huge:

a) For example, if you are sending an IPv4 TCP ACK (40 bytes), with standard LISP over IPv6 you need 96 bytes:

OH (IPv6): 40 bytes
UDP: 8 bytes
LISP: 8 bytes
IH (IPv4): 20 bytes
TCP: 20 bytes

However, if you use the compact header proposed in your draft, you will only need 72 bytes (if I am right), so you are saving 25% of the bandwidth.

[Med] You are right about the bandwidth saving. In fact, the saving depends on the version of the compact header you consider. Indeed:
* Compact header 1 requires: 68 (40 (IPv6 OH) + 8 (UDP) + 12 (Truncated TCP) + 8 (LISP))
* Compact header 2 requires: 64 (40 (IPv6 OH) + 8 (UDP) + 12 (Truncated TCP) + 4 (LISP)).

The gain is much more important compared to the legacy LISP IPv4-in-IPv6 encapsulation: 29% or 33%.

Taking into account that there is a high amount of TCP ACKs, this may perhaps have an impact.

b) Or if you are sending an RTP sample with e.g. 20 bytes of payload, using standard LISP over IPv6, you need 116 bytes:

OH (IPv6): 40 bytes
UDP: 8 bytes
LISP: 8 bytes
IH (IPv4): 20 bytes
UDP: 8 bytes
RTP: 12 bytes
Payload: 20 bytes

[Med] Yes, modulo the following clarifications. The size of the packet will be:

* Compact header 1: 80 (40 (IPv6 OH) + 8 (UDP) + 8 (LISP) + 12 (RTP) + 20 (Payload))
* Compact header 2: 76 (40 (IPv6 OH) + 8 (UDP) + 4 (LISP) + 12 (RTP) + 20 (Payload)).

Which means, a saving of 31% (Compact header 1) and 34% (Compact header 2).

In order to increase these savings, we are currently considering the possibility of submitting a draft adding header compression with ROHC, and multiplexing a number of small packets into a single LISP one, if the ITR has a number of small packets in its buffer. Reducing the number of packets will reduce the processing in intermediate routers, also reducing e.g. energy consumption and perhaps some processing delays.

[Med] that's another complementary interesting approach to investigate.

BR,

Jose