Subject: Re: [lisp] IPv6 examples in lisp documents

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 6 Apr 2016 11:18:48 -0400

First, the LISP protocol has been specified from the beginning to 
support and to run over IPv6.  Full IPv4 and IPv6 support has been in there.

With regard to the examples in the lisp-threats draft, I would be very 
reluctant to try to make any such changes.  The draft is already in THE 
RFC Editor queue, and as such we would need a serious problem before we 
would even attempt to reopen the draft.

With regaard to lisp-ddt it is probably quite reasonable to add IPv6 
examples to the draft before we complete work on that document.

Yours,
Joel

On 4/6/16 11:01 AM, [email-masked] wrote:
> Hello:
>
> I'd like to bring something to your attention with regard to
> draft-ietf-lisp-threats, if I may.  It uses IPv4 examples (examples
> using addresses in 192.0.2.0/24, 198.51.100.0/24, or 203.0.113.0/24), but
> presents no IPv6 examples (which would use 2001:db8::/32, as specified
> in RFC 6890).  This suggests that at some future time the protocol will
> likely need to be updated to use IPv6 in addition to IPv4.
>
> draft-robachevsky-mandating-use-of-ipv6-examples makes a very practical
> suggestion, which is that drafts should consider IPv6, as it is the
> direction the Internet is headed, and therefore provide either only IPv6
> examples or both IPv4 and IPv6 examples. This has not been agreed to in
> the IETF, nor is it a mandate in any sense. However, it seems practical.
>
> I can imagine that you just didn't think about IPv6,
> on the assumption that it is not a current reality in the
> Internet; while not true, that is a common perception.  However, as
> https://www.vyncke.org/ipv6status/compare.php?metric=p&countries=be,ch,us,pt,de,gr,lu,pe,ec,ee,jp,fr,cz,my,fi,no,br,ca,ro,nl
> displays, Google, APNIC, and Akamai are reporting that at least 39
> countries worldwide have non-negligible IPv6 deployment (at least 1%
> of the traffic each of them sees uses IPv6 in those markets), 20 of
> them have at least 5%, and, in one case and one measurement, over 50%
> of their traffic. Additionally, AT&T, Comcast, Google, and T-Mobile
> indicate that a significant pecentage (around half to three quarters) of
> their mobile handsets or home computers are using IPv6 - in some cases,
> accessing IPv4 sites only through NAT64 translation.
>
> In that spirit, would you please consider duplicating your IPv4 examples,
> or augmenting them, to display both the IPv4 and IPv6 variants?
>
> Thanks.
>
> Fred
>

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 6 Apr 2016 08:34:46 -0700

> First, the LISP protocol has been specified from the beginning to support and to run over IPv6.  Full IPv4 and IPv6 support has been in there.

And to carry IPv6 on the overlay as well.

> With regard to the examples in the lisp-threats draft, I would be very reluctant to try to make any such changes.  The draft is already in THE RFC Editor queue, and as such we would need a serious problem before we would even attempt to reopen the draft.
> 
> With regaard to lisp-ddt it is probably quite reasonable to add IPv6 examples to the draft before we complete work on that document.

Also, the LCAF draft that describes general encoding rules for many types of addresses and objects includes IPv6 addresses. Just an FYI.

Dino

> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp