Subject: [lisp] Brief comments to draft-boucadair-lisp-type-iana-01

From: Dino Farinacci <[email-masked]>
Date: Mon, 27 Jun 2016 14:30:35 -0700

Mohamed/Christian, some minor comments.

I think adding a new type so we can define new types is a good idea. But I would not call the subtype “Experiment ID” because we may want to allocate values for real production use. So I suggest just calling the field “sub-type”.

I would add packet types that not have been defined in RFC6830 (but will go into RFC6830bis) which are in use today in several implementations. That is Map-Notify-Ack, Info-Request, and Info-Reply.

I would also change “LISP Experimental Message” to “LISP Extension Types”.

Thanks,
Dino

---

From: <[email-masked]>
Date: Tue, 28 Jun 2016 06:09:34 +0000

Hi Dino,

Thank you for the comments.

Please see inline.

Cheers,
Med

De : Dino Farinacci [mailto:[email-masked]]
Envoyé : lundi 27 juin 2016 23:31
À : BOUCADAIR Mohamed IMT/OLN; JACQUENET Christian IMT/OLN
Cc : LISP mailing list list
Objet : Brief comments to draft-boucadair-lisp-type-iana-01

[Med] Works for me.

I would add packet types that not have been defined in RFC6830 (but will go into RFC6830bis) which are in use today in several implementations. That is Map-Notify-Ack, Info-Request, and Info-Reply.
[Med] I suggest to restrict the initial table to RFC6830 + the new type in the draft. Documents defining other messages should include an IANA section to formally request a code; a preferred value can be indicated to IANA. I added this NEW sentence to the draft:

   Documents that request for a new LISP packet type may indicate a

   preferred value in the corresponding IANA sections.

I would also change “LISP Experimental Message” to “LISP Extension Types”.
[Med] I prefer “LISP Experimental Message” to reflect that the message is reserved for experimental use.

Thanks,
Dino

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 28 Jun 2016 08:29:34 -0700

> [Med] I suggest to restrict the initial table to RFC6830 + the new type in the draft. Documents defining other messages should include an IANA section to formally request a code; a preferred value…

That is fine to not include Info-Request and Info-Reply but Map-Notify-Ack has been in implementations for a long time so value 5 has been assigned and will be included in RFC6830bis. So I think you should include at least Map-Notify-Ack.

> [Med] I prefer “LISP Experimental Message” to reflect that the message is reserved for experimental use.

That is fine. Thanks.

Dino