Subject: [lisp] Fwd: [pim] WGLC draft-ietf-pim-join-attributes-for-lisp-03

From: Stig Venaas <[email-masked]>
Date: Wed, 1 Jun 2016 10:15:28 -0700

Hi

We're doing a last call on this document in the pim wg right now. As
this is used to support LISP multicast (RFC 6831) we would appreciate
review and feedback from the lisp wg as well. This document has been
presented and discussed in the lisp wg before.

Stig

---------- Forwarded message ----------
From: Michael McBride <[email-masked]>
Date: Tue, May 31, 2016 at 9:57 PM
Subject: [pim] WGLC draft-ietf-pim-join-attributes-for-lisp-03
To: "[email-masked]" <[email-masked]>

PIMers,

Today begins a two week WGLC for
draft-ietf-pim-join-attributes-for-lisp-03. Please review and comment
as to this draft's readiness to be published as an experimental
document.

https://tools.ietf.org/html/draft-ietf-pim-join-attributes-for-lisp-03

thank you.

mike

_______________________________________________
pim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pim

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 1 Jun 2016 13:21:16 -0400

Thank you Stig.
Folks, please! Review this, and comment.

Yours,
Joel

On 6/1/16 1:15 PM, Stig Venaas wrote:
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp
>

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 2 Jun 2016 09:18:23 -0700

> presented and discussed in the lisp wg before.

I have some comments. See inline.

>    To support mobility of EIDs, the root xTR must keep track of ALL
>    receiver RLOCs even when the corresponding downstream site has not
>    requested unicast replication.  The root xTR may detect that a local
>    multicast source "root-EID" has moved to a remote LISP site.  Under
>    such circumstances LISP sends a SMR message to all receiver xTRs,
>    prompting them to update their map cache.  This is only possible if
>    LISP can obtain from PIM the set of all receiver RLOCS that have
>    active Join state for the root-EID.

This paragraph does not make it clear if the EID that is moving is the root-EID or the receiver host that moves to another LISP site where there may be a new receiver-RLOC for head-end replication.

The reason I say that is because the way the paragraph starts, but as it continues, it is referring to the root-EID changing. And when you say “LISP sends a SMR message” it doesn’t say if the old root-xTR sends it or the new root-xTR the root-EID move into does.

So are you trying to inform the receiver-xTRs to tell the new root-xTR about some new state? Like for instance, start joining the (root-RLOC, G) in the underlay? If so, this paragraph I thought was for head-end replication.

So in any event, I’m completely confused on (1) what event is occurring, and (2) what the mechanism is and (3) why you are doing the action you are doing.

Dino