Subject: Re: [lisp] [pim] WGLC draft-ietf-pim-join-attributes-for-lisp-03

From: "Jesus Arango (jearango)" <[email-masked]>
Date: Thu, 2 Jun 2016 23:58:36 +0000

Hi Dino,

The paragraph refers to the root EID moving. Do you think the following corrections are sufficient?

To support mobile multicast sources, the root xTR must keep track of ALL receiver RLOCs even when the corresponding receiver XTRs have not requested unicast replication.  If the root xTR detects that the root-EID has moved to a new root xTR, it sends an SMR message to all receiver xTRs,  prompting them to update their map cache.  This is only possible if  LISP can obtain from PIM the set of all receiver RLOCS that have active Join state for the root-EID.

Thanks
Jesus

> We're doing a last call on this document in the pim wg right now. As
> this is used to support LISP multicast (RFC 6831) we would appreciate
> review and feedback from the lisp wg as well. This document has been
> presented and discussed in the lisp wg before.

I have some comments. See inline.

>    To support mobility of EIDs, the root xTR must keep track of ALL
>    receiver RLOCs even when the corresponding downstream site has not
>    requested unicast replication.  The root xTR may detect that a local
>    multicast source "root-EID" has moved to a remote LISP site.  Under
>    such circumstances LISP sends a SMR message to all receiver xTRs,
>    prompting them to update their map cache.  This is only possible if
>    LISP can obtain from PIM the set of all receiver RLOCS that have
>    active Join state for the root-EID.

This paragraph does not make it clear if the EID that is moving is the root-EID or the receiver host that moves to another LISP site where there may be a new receiver-RLOC for head-end replication.

The reason I say that is because the way the paragraph starts, but as it continues, it is referring to the root-EID changing. And when you say "LISP sends a SMR message" it doesn't say if the old root-xTR sends it or the new root-xTR the root-EID move into does.

So are you trying to inform the receiver-xTRs to tell the new root-xTR about some new state? Like for instance, start joining the (root-RLOC, G) in the underlay? If so, this paragraph I thought was for head-end replication.

So in any event, I'm completely confused on (1) what event is occurring, and (2) what the mechanism is and (3) why you are doing the action you are doing.

Dino

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 2 Jun 2016 20:35:42 -0400

> To support mobile multicast sources, the root xTR must keep track of ALL receiver RLOCs even when the corresponding receiver XTRs have not requested unicast

It is better for clarity of the text. Now I will comment on the design. 

> replication.  If the root xTR detects that the root-EID has moved to a new root xTR, it sends an SMR message to all receiver xTRs,  

You don't need SMRs. You can use Map-Notify messages from the map-server. It converges better. 

See draft-ietf-lisp-signal-free-multicast for
details. The same machinery can be used. And it is simple. 

> prompting them to update their map cache.  

Receiver xTRs are receiving and decapsulating packets. They are ETRs. They don't have map-caches. So this doesn't make sense. 

> This is only possible if  LISP can obtain from PIM the set of all receiver RLOCS that have active Join state for the root-EID.

Well they could register to the mapping system. That is where all receiver xTRs can be tracked (and perhaps not used for forwarding like it is in draft-ietf-lisp-signal-free-multicast). 

So try again. 

Dino

---

From: "Jesus Arango (jearango)" <[email-masked]>
Date: Fri, 3 Jun 2016 01:26:19 +0000

Hi Dino,

I don't think map-notifies are relevant in the context of this draft. Keep in mind that this draft is written for "pim-signaled" head-end replication. In your "signal-free" draft, map-notifies are the correct message because you are tracking changes in the set of receiver RLOCS and that translates into changes in the merged RLOC set. In this draft, we are tracking changes in source EID location and the proper message for that is an SMR.

The receivers do have map-caches. They have a map-cache entry mapping the source EID to the RLOC of the source XTR. This is the map-cache entry that we want the SMR to refresh. The creation of this map-cache was not triggered by traffic. It was triggered by an RPF lookup by PIM in the receiver XTR.

Jesus

-----Original Message-----
From: Dino Farinacci [mailto:[email-masked]] 
Sent: Thursday, June 2, 2016 5:36 PM
To: Jesus Arango (jearango) <[email-masked]>
Cc: [email-masked]; [email-masked]; Stig Venaas (svenaas) <[email-masked]>
Subject: Re: [lisp] [pim] WGLC draft-ietf-pim-join-attributes-for-lisp-03

> To support mobile multicast sources, the root xTR must keep track of 
> ALL receiver RLOCs even when the corresponding receiver XTRs have not 
> requested unicast

> replication.  If the root xTR detects that the root-EID has moved to a 
> new root xTR, it sends an SMR message to all receiver xTRs,

See draft-ietf-lisp-signal-free-multicast for details. The same machinery can be used. And it is simple. 

So try again. 

Dino

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 2 Jun 2016 22:46:56 -0400

> I don't think map-notifies are relevant in the context of this draft. Keep in mind that this draft is written for "pim-signaled" head-end replication. In your "signal-free" draft, map-notifies are…

I was thinking of using Map-Notifies in this application not in the signal-free one. 

What you do is have the root-xTR register as  a receiver-xTR so when a move occurs the new root-xTR changes which causes the map-server to trigger a Map-Notify to each RLOC in the RLIC-set  because there was an RLOC-set change. 

> The receivers do have map-caches. They

In this data forwarding direction, this is an ETR. ETRs have database-entries which are registered. Used for decapsulation. 

Mao-caches are used for encapsulation. There is no encapsulation in these receiver-ETRs when data flows from a multicast source to the receivers the receiver-ETR supports. 

> have a map-cache entry mapping the source EID to the RLOC of the source XTR.

That is a map-cache entry in the root-ITR not in the ETRs. 

> This is the map-cache entry that we want the SMR to refresh. The creation of this

That is why this is backwards. 

> map-cache was not triggered by traffic. It was triggered by an RPF lookup by PIM in the receiver XTR.

Understand. But it should be called another data structure. Like an RPF data structure, like a RIB is used in normal native routing. 

In any event, if you don't clear up this text, it will be hard for anyone to understand this. 

Dino

---

From: "Jesus Arango (jearango)" <[email-masked]>
Date: Wed, 8 Jun 2016 06:47:24 +0000

FYI,

I am collaborating with Dino on his comments. We agreed to do some changes and are actively working on them. I will share the changes and publish a new draft version once we reach an agreement on the exact wording to use.

Thanks
Jesus

-----Original Message-----
From: Dino Farinacci [mailto:[email-masked]] 
Sent: Thursday, June 2, 2016 7:47 PM
To: Jesus Arango (jearango) <[email-masked]>
Cc: [email-masked]; [email-masked]; Stig Venaas (svenaas) <[email-masked]>
Subject: Re: [lisp] [pim] WGLC draft-ietf-pim-join-attributes-for-lisp-03

Dino

---

From: "Jesus Arango (jearango)" <[email-masked]>
Date: Tue, 14 Jun 2016 19:24:06 +0000

FYI,

A new version has been uploaded with all the revisions that were brought up during the last-call. Here is the new version:

https://tools.ietf.org/html/draft-ietf-pim-join-attributes-for-lisp-04

Jesus

-----Original Message-----
From: Jesus Arango (jearango) 
Sent: Tuesday, June 7, 2016 11:47 PM
To: 'Dino Farinacci' <[email-masked]>
Cc: [email-masked]; [email-masked]; Stig Venaas (svenaas) <[email-masked]>
Subject: RE: [lisp] [pim] WGLC draft-ietf-pim-join-attributes-for-lisp-03

FYI,

Thanks
Jesus

-----Original Message-----
From: Dino Farinacci [mailto:[email-masked]] 
Sent: Thursday, June 2, 2016 7:47 PM
To: Jesus Arango (jearango) <[email-masked]>
Cc: [email-masked]; [email-masked]; Stig Venaas (svenaas) <[email-masked]>
Subject: Re: [lisp] [pim] WGLC draft-ietf-pim-join-attributes-for-lisp-03

Dino

---

From: Michael McBride <[email-masked]>
Date: Wed, 15 Jun 2016 00:26:47 +0000

Hi Jesus,

Have all comments (Dino's) been addressed in this rev? If so we will forward the draft to Alvaro (iesg). Otherwise we will wait until everyone is happy.

thanks,
mike

-----Original Message-----
From: pim [mailto:[email-masked]] On Behalf Of Jesus Arango (jearango)
Sent: Tuesday, June 14, 2016 12:24 PM
To: Dino Farinacci
Cc: [email-masked]; [email-masked]; Stig Venaas (svenaas)
Subject: Re: [pim] [lisp] WGLC draft-ietf-pim-join-attributes-for-lisp-03

FYI,

Jesus

-----Original Message-----
From: Jesus Arango (jearango) 
Sent: Tuesday, June 7, 2016 11:47 PM
To: 'Dino Farinacci' <[email-masked]>
Cc: [email-masked]; [email-masked]; Stig Venaas (svenaas) <[email-masked]>
Subject: RE: [lisp] [pim] WGLC draft-ietf-pim-join-attributes-for-lisp-03

FYI,

Thanks
Jesus

-----Original Message-----
From: Dino Farinacci [mailto:[email-masked]] 
Sent: Thursday, June 2, 2016 7:47 PM
To: Jesus Arango (jearango) <[email-masked]>
Cc: [email-masked]; [email-masked]; Stig Venaas (svenaas) <[email-masked]>
Subject: Re: [lisp] [pim] WGLC draft-ietf-pim-join-attributes-for-lisp-03

Dino

_______________________________________________
pim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pim

---

From: "Jesus Arango (jearango)" <[email-masked]>
Date: Wed, 15 Jun 2016 00:30:05 +0000

Hi Mike,

Yes, all comments were addressed. I received approval from Dino and from all other authors.

Thank you
Jesus

-----Original Message-----
From: Michael McBride [mailto:[email-masked]] 
Sent: Tuesday, June 14, 2016 5:27 PM
To: Jesus Arango (jearango) <[email-masked]>; Dino Farinacci <[email-masked]>
Cc: [email-masked]; [email-masked]; Stig Venaas (svenaas) <[email-masked]>
Subject: RE: [pim] [lisp] WGLC draft-ietf-pim-join-attributes-for-lisp-03

Hi Jesus,

thanks,
mike

-----Original Message-----
From: pim [mailto:[email-masked]] On Behalf Of Jesus Arango (jearango)
Sent: Tuesday, June 14, 2016 12:24 PM
To: Dino Farinacci
Cc: [email-masked]; [email-masked]; Stig Venaas (svenaas)
Subject: Re: [pim] [lisp] WGLC draft-ietf-pim-join-attributes-for-lisp-03

FYI,

Jesus

-----Original Message-----
From: Jesus Arango (jearango) 
Sent: Tuesday, June 7, 2016 11:47 PM
To: 'Dino Farinacci' <[email-masked]>
Cc: [email-masked]; [email-masked]; Stig Venaas (svenaas) <[email-masked]>
Subject: RE: [lisp] [pim] WGLC draft-ietf-pim-join-attributes-for-lisp-03

FYI,

Thanks
Jesus

-----Original Message-----
From: Dino Farinacci [mailto:[email-masked]] 
Sent: Thursday, June 2, 2016 7:47 PM
To: Jesus Arango (jearango) <[email-masked]>
Cc: [email-masked]; [email-masked]; Stig Venaas (svenaas) <[email-masked]>
Subject: Re: [lisp] [pim] WGLC draft-ietf-pim-join-attributes-for-lisp-03

Dino