Subject: RE: updating GSE for the new millennium

From: "Tony Li" <[email-masked]>
Date: Sat, 3 May 2003 17:08:55 -0700

Root name servers are also a service deserving of anycast
addresses.

Tony

|    Joe is absolutely on the right path.
|    
|    > contributed the following to RFC 1958:
|    >
|    >    3.11 Circular dependencies must be avoided.
|    >
|    >       For example, routing must not depend on look-ups 
|    in the Domain
|    >       Name System (DNS), since the updating of DNS 
|    servers depends on
|    >       successful routing
|    
|    And if you change this to:
|    
|    >       For example, core default free routing must not 
|    depend on look-ups in
|    >       the Domain Name System (DNS), since the updating 
|    of DNS servers depends
|    >       on successful defaul free routing
|    
|    Long ago there was a discussion about whether or not DNS 
|    servers were 
|    things that needed to be multihomed - the answer was that 
|    they were not.
|    
|    One does far better with multiple DNS servers on unique PA 
|    addresses.
|    DNS already deals with failover, etc...
|    
|    ]       ON HUMILITY: to err is human. To moo, bovine.      
|         |  firewalls  [
|    ]   Michael Richardson, Sandelman Software Works, Ottawa, 
|    ON    |net architect[
|    ] [email-masked] 
|    http://www.sandelman.ottawa.on.ca/ |device |    driver[
|    ] 
|    panic("Just another Debian GNU/Linux using, kernel 
|    hacking, security guy"); [
|    
|    
|    
|    
|    -----BEGIN PGP SIGNATURE-----
|    Version: GnuPG v1.0.7 (GNU/Linux)
|    Comment: Finger me for keys
|    
|    iQCVAwUBPrQ1noqHRg3pndX9AQHv3AQAxEjFFT5i5nuNorEJaexeB28KxtUn+XTw
|    Bky8s56cFGl8o6+oigxAQ0Z/EtcnUdJCrJsifxArQtwBzlSmqkR16sQcybdKlEjB
|    +/tNYDQvVO68CW2TNwHI37KzzFp+K+tNNSR6SQ/HMXXiqnix466+U4Ni1kvL99NV
|    w0LOMZx0/xI=
|    =6cUF
|    -----END PGP SIGNATURE-----
|    
|

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 04 May 2003 11:29:10 +0200

Indeed. Getting back to GSE, I think the question we have
to ask about any solution is: how would we bootstrap
the Internet, or a large portion of it, if the power went
off everywhere for a while? If the solution isn't robust
in that case (e.g. due to circular dependencies) then it
doesn't measure up. As Tony said, you can arrange things so
that DNS-based GSE doesn't create circularity, but only if you 
think about it.

   Brian

---

From: Michael Richardson <[email-masked]>
Date: Sun, 04 May 2003 12:31:48 -0400

>>>>> "Tony" == Tony Li <[email-masked]> writes:
    Tony> Root name servers are also a service deserving of anycast
    Tony> addresses.

  But, this is multiple systems with the "same" address rather than
a single system with multiple addresses. 
  So, I don't see the relevance to multi6 :-)

]       ON HUMILITY: to err is human. To moo, bovine.           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
] panic("Just another Debian GNU/Linux using, kernel hacking, security guy"); [