Subject: RE: MIPv6 hopeless

From: "Tony Li" <[email-masked]>
Date: Wed, 20 Aug 2003 23:30:43 -0700

Indeed.  What's the difference between a zero homed host and
one that simply acquired a DHCP address?

Also, the protocol should not require modifications to support
multiple home agents.  That should be a property of the implementation
since the interaction should only be pairwise at any given time.

Tony

|    -----Original Message-----
|    From: Masataka Ohta [mailto:[email-masked]] 
|    Sent: Wednesday, August 20, 2003 7:26 PM
|    To: Tim Shepard
|    Cc: [email-masked]
|    Subject: Re: MIPv6 hopeless
|    
|    
|    Tim Shepard;
|    
|    > > A properly designed mobility protocol should support multiple
|    > > home agents at multiple locations.
|    > 
|    > And I would also like to see support for the homeless 
|    mobile node.
|    > So "multiple home agents" should range from zero to many.
|    
|    I'm afraid that the analogy between multihoming and mobility
|    works here and that the homeless mobile node will be as useful
|    as a zero homed sites in which hosts have zero prefixes.
|    
|    							Masataka Ohta
|    
|

---

From: Masataka Ohta <[email-masked]>
Date: Thu, 21 Aug 2003 20:07:37 +0859 ()

Tony;

> one that simply acquired a DHCP address?

The number of addresses.

> since the interaction should only be pairwise at any given time.

Which protocol?

As for the multihoming protocol, yes.

						Masataka Ohta

---

From: "marcelo bagnulo" <[email-masked]>
Date: Thu, 21 Aug 2003 10:29:56 -0300

Hi Tony,

> -----Mensaje original-----
> De: [email-masked] 
> [mailto:[email-masked]] En nombre de Tony Li
> Enviado el: jueves, 21 de agosto de 2003 3:31
> Para: Masataka Ohta; Tim Shepard
> CC: [email-masked]
> Asunto: RE: MIPv6 hopeless
> 
> 
> 
> 
> Also, the protocol should not require modifications to 
> support multiple home agents.

I guess you are talking about MIPv6 here, right?

If not, stop reading.

If yes, i think that in order tu use the mipv6 protocol in a multi-homed
scenario, there is no need of a home agent.
I mean, a host within the multi-homed site has multiple prefixes, and
suppose that all of them can be used to initiate a communication. So
dependin on a number of considerations (policing, availability, which
prefix is selected by the other end, etc) one of those prefixes (PrefA)
is selected to be used in a certain communication.
T that moment, PrefA::Host becomes the Home address and all the other
addresses available becomes potential Care-off addresses. Whene there is
a failure, the host send a BU to move the communication from the HoA to
one of the other CoA available.
So no need of HA (or if you want, the mobile node is also the HA)

Regards, marcelo    

>  That should be a property of 
> the implementation since the interaction should only be 
> pairwise at any given time.
> 
> Tony
> 
>