Subject: Re: Consensus on identifier/locator split?

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 06 Aug 2003 13:45:02 -0400

Yes, I think we should go down the path of explicitly splitting locators 
and identifiers.
Yours,
Joel M. Halpern

t 10:22 AM 8/6/2003 -0700, Tony Li wrote:

>Folks,
>
>I don't mean to disrupt other constructive conversations,
>so please carry on with those.
>
>I'd just like to get a sense from the group about where
>we are so far.  Do we have consensus about splitting
>the address into locators and identifiers?  Note that
>I'm NOT asking about specifics, like "how big", "what
>mappings exist", "is it secure", etc. Do we agree that
>we want to go down this path?
>
>Silence is not assent...
>
>Thanks,
>Tony

---

From: "Christian Huitema" <[email-masked]>
Date: Wed, 6 Aug 2003 11:07:20 -0700

> we want to go down this path?

No, I don't believe we have this consensus. Specifically, we don't have a consensus that a new category of identifiers should be created, and that this new category should be used by all applications and processed by all nodes. We also definitely don't have a consensus that any such identifiers should be visible "in the network", by opposition to say, session identifiers that are only visible end-to-end.
 
-- Christian Huitema

---

From: "Christian Huitema" <[email-masked]>
Date: Wed, 6 Aug 2003 11:35:18 -0700

> You're getting specific on me and I was trying to stay at the
> broad architectural level, in the hopes of making baby steps
> forward.  Is there some version of the identifier/locator
> split that you WOULD agree to?
 
I believe the question cannot be resolved in a general sense, and specifically not if you ask for a "locator/identifier split", which by its very wording is tied to the Internet Protocol layer. If you are going to change the IP protocol, then you should move the debate to the IPv6 working group. The proper way for multi6 to proceed is to evaluate a set of possibilities, and to look at the operational issues associated with the different possibilities.
 
-- Christian Huitema

---

From: "J. Noel Chiappa" <[email-masked]>
Date: Wed, 6 Aug 2003 18:40:05 -0400

> From: "Christian Huitema" <[email-masked]>

    >> Do we have consensus about splitting the address into locators and
    >> identifiers? Note that I'm NOT asking about specifics, like "how big",
    >> "what mappings exist", "is it secure", etc.

    > Specifically, we don't have a consensus that a new category of
    > identifiers should be created, and that this new category should be
    > used by all applications and processed by all nodes.

True, but that's not the question Tony is asking.

If you have a problem with Tony's question, what's your answer to my
reformulated question "do we want to do things that inherently separate
location and identity, like keep TCP connections open when switching
providers"?

    > We also definitely don't have a consensus that any such identifiers
    > should be visible "in the network", by opposition to say, session
    > identifiers that are only visible end-to-end.

Another good question, and one I also believe Tony was putting off for now.

	Noel

---

From: "Ayyasamy, Senthilkumar (UMKC-Student)" <[email-masked]>
Date: Thu, 7 Aug 2003 23:39:02 -0500

>How ought we (if at all) deal with the notion of a virtual end point 
>such as a "content routed" service like CNN?  Particularly in the face 
>of mobile nodes.  If we deal with it at all we don't want TCP 
>connections breaking, and yet one wants to find the closest server 
>hosting this identity (whatever that means).  I raise this because one 
>way of looking at the answer would be to simply have a server appear 
>with multiple agencies in the routing system.  That's inelegant and 
>expensive.  DNS and anycast is incomplete due to mobility.

Currently, content routing is done by putting the burden onto 
DNS. The scheme is attractive, because it requires no change 
to both the router and host. But, makes changes to DNS (like 
CNAME record etc) depending on the content distribution type.
I guess, many in IETF are so much concerned about overloading 
critical infrastructures like BGP and DNS. Other than that,
a lot of measurement based local optimization and assumptions
affect the granularity of the server selection process. so,
we need a solution which does not depend on DNS. 

as you mention above, content routing can be done using IP 
mobility; there by preserving transport level connectivity.
MIP6 can be used for redirection without the need for DNS. 
For example, consider CNN server (replicated) as a mobile 
node, request router being the home agent and the client be
the correspodent node. In our case, the request router(home
agent) must make a server selection based on server load, 
available BW info and proximity etc; unlike DNS based 
server selection. Here, the load/proximity information is
the equivalent of "location update" as in MIP. 

btw, I agree with you that it is one way of looking at 
the locator/identifier separation.

>If CNN doesn't do it for you,

CNN doesn't do the request routing. They are just a 
content provider. All the intelligent routing control 
is done by third party distribution service providers 
like akamai. 

[ from your other mail ]
>It's already done below the application layer in many cases, 
>particularly when trying to determine the "closest" data 
>center. All I'm asking really is that we consider all the 
>knobs that exist today, across a broad set of areas, when 
>looking at architectural choices.  I'm not asking anything 
>more specific.

something more tangible? so, whatever solutions proposed in 
multi6 should purely be judged by:

o its dependence on previous loc/id separation solutions,like 
  MIP. major architectural changes (like new  namespace) 
  should be done else where.

o required change to routers/hosts

o offcourse, other requirements listed in the draft.

MIP6 based proposals seems like a way to move forward. 

[replying to Tony's post]
> Do we have consensus about splitting the address into 
> locators and identifiers?

Yes. But, a dedicated group of experts (NSRG) was not 
able to come to a conclusion on the "type" of loc/id
split. so, multi6 should avoid making major long term
architectural changes. 

  -- senthil

---

From: Wassim Haddad <[email-masked]>
Date: 19 Aug 2003 14:24:57 -0400

Hi,

I believe that an explicit split between locator and identifier will
solve many problems.
I personally support this idea.

Regards,

Wassim Haddad
Ericsson Research Canada