Subject: RE: Consensus on identifier/locator split?

From: "Tony Li" <[email-masked]>
Date: Wed, 6 Aug 2003 11:16:08 -0700

Christian,  

You're getting specific on me and I was trying to stay at the
broad architectural level, in the hopes of making baby steps
forward.  Is there some version of the identifier/locator
split that you WOULD agree to?

Tony

|    -----Original Message-----
|    From: Christian Huitema [mailto:[email-masked]] 
|    Sent: Wednesday, August 06, 2003 11:07 AM
|    To: Tony Li; [email-masked]
|    Subject: RE: Consensus on identifier/locator split?
|    
|    
|    > I'd just like to get a sense from the group about where
|    > we are so far.  Do we have consensus about splitting
|    > the address into locators and identifiers?  Note that
|    > I'm NOT asking about specifics, like "how big", "what
|    > mappings exist", "is it secure", etc. Do we agree that
|    > we want to go down this path?
|    
|    No, I don't believe we have this consensus. Specifically, 
|    we don't have a consensus that a new category of 
|    identifiers should be created, and that this new category 
|    should be used by all applications and processed by all 
|    nodes. We also definitely don't have a consensus that any 
|    such identifiers should be visible "in the network", by 
|    opposition to say, session identifiers that are only 
|    visible end-to-end.
|     
|    -- Christian Huitema
|

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Wed, 6 Aug 2003 23:02:21 +0200

> split that you WOULD agree to?

I would like to note at this point that consensus isn't the same as 
unanimity, and rough consensus certainly isn't.

I agree that we should follow the loc/id split path.

If this path leads to a dead end, that's unfortunate, but still a very 
valuable result if we document it well.

---

From: David Kessens <[email-masked]>
Date: Wed, 6 Aug 2003 16:07:52 -0700

Iljitsch,

> I agree that we should follow the loc/id split path.

It's bit a hard to talk about a seperation while everybody seems to
have a different definition of what that seperation could entail.

It seems that the correct question to ask is whether people think it
is useful if the designteam will go further on it's choosen path and
come up with a more concrete proposal so that we have a chance to
really evaluate a more fully baked proposal. 

I don't think there is consensus though that the designteam choices
are the only possible route to a solution or that only one solution is
the answer to the problem. We are still in a stage where other groups
could work on quite different ideas and they are not well defined
enough (yet) so that we are able to do a full analysis and make a final
choice (if we even need to do that).

David K.
---