Subject: Re: Comments on draft-ohta-multi6-8plus8-00.txt

From: [email-masked] (Noel Chiappa)
Date: Tue, 20 Jan 2004 11:15:32 -0500 (EST)

> From: Brian E Carpenter <[email-masked]>

    > There should be an acknowledgement here to Mike O'Dell, who invented
    > both the name and the original 8+8 proposal. 

My memory may be failing here, but IIRC it was Dave Clark (in a long email
message to some mailing list - the IPv6 or Big-I lists, maybe?) who first came
up with the concept of splitting the IPv6 address field into two halves, for
location and identity.

I think the main think Mike added, in coming up with GSE, was the concept that
the border routers would fill in the high order parts of the locator portion.

	Noel

---

From: Eliot Lear <[email-masked]>
Date: Tue, 20 Jan 2004 08:40:06 -0800

I think Noel's right.  I remember Dave discussing something like this in 
Amsterdam in '93.

Eliot

---

From: Scott W Brim <[email-masked]>
Date: Tue, 20 Jan 2004 11:45:56 -0500

> up with the concept of splitting the IPv6 address field into two halves, for

Copying what was done with NSAPs?  I don't think anyone could lay claim
to this idea in the last 20 years.  However, 

> I think the main think Mike added, in coming up with GSE, was the
> concept that the border routers would fill in the high order parts of
> the locator portion.

I think so too.  We could ask him.

---

From: Masataka Ohta <[email-masked]>
Date: Wed, 21 Jan 2004 08:01:44 +0900

Scott W Brim;

> Copying what was done with NSAPs?

XNS.

However, the important difference to old proposals is existence
of scalable reverse mapping from structured ID, which is common
practice with IPv4 addresses and DNS, which may be attributed
to someone in ISI, perhaps PVM. But, it is one thing to map from
address to domain name and another to map from ID (to domain name
and then) to locators.

>>concept that the border routers would fill in the high order parts of

GSE mostly concentrate on source address spoofing and it
mostly proposes rewriting of source locator portion.

> I think so too.  We could ask him.

You may ask him. But, rewriting by the border routers is a bad
idea w.r.t. the end to end principle that my 8+8 proposal does
not use it.

							Masataka Ohta