Subject: Re: Consensus on identifier/locator split?

From: Brian E Carpenter <[email-masked]>
Date: Fri, 09 Jan 2004 17:57:06 +0100

Margaret Wasserman wrote:
> 
> Hi Tony,
> 
> >I'd just like to get a sense from the group about where
> >we are so far.  Do we have consensus about splitting
> >the address into locators and identifiers?  Note that
> >I'm NOT asking about specifics, like "how big", "what
> >mappings exist", "is it secure", etc. Do we agree that
> >we want to go down this path?
> 
> Is it good enough to say that I think we should explore
> options in this area?
> 
> I have two reservations about making a sweeping statement
> that this is the right solution to site multihoming in
> IPv6:
> 
> (1) It isn't 100% well-defined.  The NOID proposal, for
>      example, doesn't really split the ID and locator into
>      separate fields -- the same value serves different
>      functions at different layers.

True, but conceptually the split is still quite clear
(as it is in LIN6 and HIP if you look at them the right way)

> 
> (2) We don't have a completely worked example.  So, we
>      can't be sure that this type of approach will meet
>      the requirements with an acceptable impact on the
>      other layers of the system, acceptable performance,
>      etc.

True. But we have a lot of specifics, e.g. in the LIN6 and
HIP drafts.

   Brian

---

From: Dave Crocker <[email-masked]>
Date: Fri, 9 Jan 2004 16:26:06 -0800

Folks,

> >  Do we have consensus about splitting
...  
>  But, I do think that this solution space is promising
>  enough to be worth investigating further.  Is that close
>  enough?

"Splitting the address"?  No.  

Carefully distinguishing the role of identifier from the role of locator? Yes.

My point is that there are quite a number of ways to satisfy that distinction 
and only some of them involve messing with IP Addresses.  For others, the public 
uses of IP Addresses are mostly restricted to locator.

--
Dave Crocker <dcrocker-at-brandenburg-dot-com>
Brandenburg InternetWorking <http://brandenburg.com>