Subject: RE: Draft of updated WG charter

From: "Tony Li" <[email-masked]>
Date: Fri, 9 Jan 2004 13:37:24 -0800

Well, then I would pose to you the obvious question: what is
it that you want multihoming to do?  If the end host behavior
does not change, then all you are left with changing is the
routing subsystem.  And the only thing that you can now do
is to declare all multihomed prefixes global or do an absurd
amount of tunneling to repair the topology.  For obvious reasons,
I hope we agree that both of those alternatives are even less
pleasant.

Tony

|  -----Original Message-----
|  From: vijay gill [mailto:[email-masked]] 
|  Sent: Friday, January 09, 2004 12:56 PM
|  To: Tony Li
|  Cc: Noel Chiappa; [email-masked]
|  Subject: Re: Draft of updated WG charter
|  
|  
|  On Fri, Jan 09, 2004 at 11:34:47AM -0800, Tony Li wrote:
|  > 
|  > Vijay,
|  > 
|  > Would you accept changes to the NAT box?
|  > 
|  > Would you allow the insertion of a NAT layer in the end host stack?
|  > 
|  > Tony
|  
|  _I'd_ accept a lot of things. However, I am not planning to go around
|  upgrading multiple millions of linksys wifi/cable/dsl gateways,
|  netscreens, pixes, and toshiba/motorola cable boxes.
|  
|  Jay Ford captured what I was trying to say in a much more eloquently.
|  
|  These are things we really need to pay attention to if we are not to
|  spend another 2 years working on a brilliantly engineered, elegant
|  solution that is used by no one.
|  
|  /vijay
|

---

From: vijay gill <[email-masked]>
Date: Fri, 9 Jan 2004 21:47:44 +0000

> I hope we agree that both of those alternatives are even less

Tony, if it was an easy answer, we wouldn't be having this discussion.

Whatever solution we come up with must somehow account for the realities
on the ground. I can see there being multiple methods in use, with
people hiding deep inside networks willing to accept the fact
that their sessions may not survive rehoming.

IFF we can get a solution working as transparently as say, tcp/ip
congestion control or dns,  then we have a shot I'd think.

/vijay