Subject: RE: Draft of updated WG charter

From: "Tony Li" <[email-masked]>
Date: Fri, 9 Jan 2004 11:34:47 -0800

Vijay,

Would you accept changes to the NAT box?

Would you allow the insertion of a NAT layer in the end host stack?

Tony

|  -----Original Message-----
|  From: vijay gill [mailto:[email-masked]] 
|  Sent: Friday, January 09, 2004 9:40 AM
|  To: Noel Chiappa
|  Cc: [email-masked]
|  Subject: Re: Draft of updated WG charter
|  
|  
|  On Fri, Jan 09, 2004 at 08:58:18AM -0500, Noel Chiappa wrote:
|  
|  > If the WG as a whole agrees with you (and this is an 
|  important point to nail
|  > down - my guess would be that they do not), then you've 
|  basically eliminated
|  > all solutions to the problem other than recycling 
|  Mobile-IPv6 mechanisms
|  > (since the charter rules out "let the routing do it", 
|  which means it has to
|  > be done via use of multiple addresses).
|  > 
|  > I'm curious as to why you want to rule out any changes to 
|  the end-hosts. I
|  > note that Mobile-IPv6 didn't restrict themselves in this way.
|  
|  Significant amount of users that are multihomed have a setup that
|  accepts defaults from two providers, and anounces their blocks to
|  both upstreams. They receive no more information than the fact
|  that their connection is up. No routing tables, no prefixes, just
|  a quadzero.
|  
|  (users defined as an enterprise, not the invididual computer user
|  obviously)
|  
|  The end user system is often nat'd, and run through a stateful
|  firewall and all the information _they_ have is an ip address
|  of the gateway via dhcp.
|  
|  Any end-host updating solution must work through this gobbledegook.
|  
|  /vijay
|  
|

---

From: vijay gill <[email-masked]>
Date: Fri, 9 Jan 2004 20:55:32 +0000

> Would you allow the insertion of a NAT layer in the end host stack?

_I'd_ accept a lot of things. However, I am not planning to go around
upgrading multiple millions of linksys wifi/cable/dsl gateways,
netscreens, pixes, and toshiba/motorola cable boxes.

Jay Ford captured what I was trying to say in a much more eloquently.

These are things we really need to pay attention to if we are not to
spend another 2 years working on a brilliantly engineered, elegant
solution that is used by no one.

/vijay