Subject: RE: I-D ACTION:draft-coene-multi6-sctp-00.txt

From: Coene Lode <[email-masked]>
Date: Tue, 24 Feb 2004 10:28:14 +0100

I am not a specialist on socket issues.. But Michael & Randall might know a
bit more on that...

>-----Original Message-----
>From: Barany, Pete [mailto:[email-masked]] 
>Sent: zaterdag 21 februari 2004 19:29
>To: [email-masked]
>Subject: RE: I-D ACTION:draft-coene-multi6-sctp-00.txt
>
>
>In the SCTP sockets API Internet draft
>(draft-ietf-tsvwg-sctpsocket-07.txt), there is a sendmsg() flag
>(MSG_ADDR_OVER) for the one-to-many style that allows the application to
>request that the SCTP stack override the primary destination address. Do
>implementations honor (mandatory) this request, or can the SCTP stack
>override it? Thanks.

My take is:
The implementation must send the msg on the IP address provided
instead of the primary destination address. 
But if the address provided by the application is not reachable at that
particular moment, then the SCTP implementation will try any of the
alternative addresses of the association(including the primary destination
address)

>Pete

Yours sincerely,
Lode

---

From: Michael Tuexen <[email-masked]>
Date: Tue, 24 Feb 2004 13:38:06 +0100

[ post by non-subscriber.  with the massive amount of spam, it is easy to miss
  and therefore delete posts by non-subscribers.  if you wish to regularly
  post from an address that is not subscribed to this mailing list, send a
  message to <listname>[email-masked] and ask to have the alternate
  address added to the list of addresses from which submissions are
  automatically accepted. ]

Dear all,

the way Lode describes it is OK. However, there is some
room for implementations...

Best regards
Michael

---

From: "Randall R. Stewart (home)" <[email-masked]>
Date: Tue, 24 Feb 2004 12:56:17 -0600

[ post by non-subscriber.  with the massive amount of spam, it is easy to
miss

Michael:

I agree, the way Lode describes it is generally correct... but an
implementation MAY not follow this .. one never knows :->

I believe KAME does as Lode describes.. however I can't
rememeber how I coded the "Unconfirmed" address case. Either
I thus consider it "confirmed" or refuse to send to it :-D... its
the CRS syndrom ... I will look into this when I get a few cycles
to see how I did it :-D

R

-- 
Randall R. Stewart
815-477-2127 (office)
815-342-5222 (cell phone)

---

From: Michael Tuexen <[email-masked]>
Date: Tue, 24 Feb 2004 20:33:14 +0100

Randy,
see my comments below.
Best regards
Michael

> implementation MAY not follow this .. one never knows :->
That's why I wrote 'there is room for implementations'.
> the CRS syndrom ... I will look into this when I get a few cycles
I remember that you said that you would handle this as an
implicit 'confirmation', like using connect_x and then send it.
But I do not know if this is what the code does...