Subject: RE: I-D ACTION:draft-coene-multi6-sctp-00.txt

From: <[email-masked]>
Date: Tue, 24 Feb 2004 18:17:24 +0200

John,

> In the ADDIP I-D (draft-ietf-tsvwg-addip-sctp-08.txt), addresses can be
> added/deleted as described therein. However, in the sockets API I-D
> (draft-ietf-tsvwg-sctpsocket-07.txt), I see a system call
> 'sctp_getpaddrs()' which allows the upper layer to get all peer
> addresses in an association. However, I do not see a notification
> primitive informing the upper layer when an address has been
> added/deleted per the ADDIP I-D. It would be relatively easy to code
> this into an implementation, but shouldn't something like 
> this be in the sockets API I-D? Thanks.

That would probably be best addressed to Randy ...

John

---

From: "Randall R. Stewart (home)" <[email-masked]>
Date: Tue, 24 Feb 2004 13:01:25 -0600

[ post by non-subscriber.  with the massive amount of spam, it is easy to
miss
  and therefore delete posts by non-subscribers.  if you wish to regularly
  post from an address that is not subscribed to this mailing list, send a
  message to <listname>[email-masked] and ask to have the alternate
  address added to the list of addresses from which submissions are
  automatically accepted. ]

>That would probably be best addressed to Randy ...
Section 5.3.1.2 covers the adding and deleting of
socket addresses in the -07 socket draft... a socket-api
conformant implementation that supports ADD-IP SHOULD
(at least in theory) give such a notification.

R

-- 
Randall R. Stewart
815-477-2127 (office)
815-342-5222 (cell phone)