Subject: RE: Newbie Question about addressing impacts

From: "Bound, Jim" <[email-masked]>
Date: Fri, 13 Aug 2004 10:11:07 -0400

I agree with Brian on this point strongly.
/jim 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Brian E Carpenter
> Sent: Friday, August 13, 2004 4:01 AM
> To: Multi6
> Subject: Re: Newbie Question about addressing impacts
> 
> Tony Li wrote:
> > 
> > On Aug 12, 2004, at 6:31 AM, Fleischman, Eric wrote:
> > 
> >> This is an interesting idea. However, if we embed proxy functions 
> >> into border routers it would potentially add overhead (as well as 
> >> latency) and make them harder to manage. Specifically, the 
> number of 
> >> border routers is likely to increase as network perimeters become 
> >> more porous. Thus, this idea carries with it the need to 
> ensure that 
> >> these distributed routers can be configured with 
> consistent policies.
> >>
> >> Simple is good in operations.
> >>
> > 
> > 
> > Well, then the other architectural alternative that I can see is to 
> > embed NAT-like functionality in all of the hosts.
> > 
> > I find this scarier.
> 
> Chair hat off:
> 
> I repeat my comment from when I first saw Mike O'Dell's original 8+8
> proposal: "It's architected NAT." I think anything that 
> massages locators, whether it's in the host stack or in a 
> proxy, comes down to architected NAT. Which means there is 
> going to be state, so that the massage can be reversed, so 
> that the ULP always sees the same e2e identifier. It's a 
> design choice whether that state is in hosts, proxies, or both.
> 
> Actually, we're kidding ourselves if we don't admit that this 
> is what we are going to end up doing.
> 
> Chair hat on:
> 
> The design team has been asked to develop one specific 
> approach to this, namely the IP wedge layer approach, because 
> that is where the proposals and interest in the WG seem to be 
> concentrated.
> 
>     Brian
> 
> 
>

---

From: "Bound, Jim" <[email-masked]>
Date: Fri, 13 Aug 2004 10:12:11 -0400

And I think it wise to table the complete solution space to define and
get something working now.  
/jim

> [mailto:[email-masked]] On Behalf Of Tony Li
> Sent: Friday, August 13, 2004 5:29 AM
> To: Brian E Carpenter
> Cc: Multi6
> > proposal: "It's architected NAT." I think anything that massages 
> > locators, whether it's in the host stack or in a proxy, 
> comes down to 
> > architected NAT. Which means there is going to be state, so 
> that the 
> > massage can be reversed, so that the ULP always sees the same e2e 
> > identifier. It's a design choice whether that state is in hosts, 
> > proxies, or both.
> >
> > Actually, we're kidding ourselves if we don't admit that 
> this is what 
> > we are going to end up doing.
> >
> 
> 
> I think that it is vitally important that we all understand 
> this and how we got here.  If we want a host to respond 
> flexibly to multiple addresses, then either (a) the protocol 
> stack needs to know about the various addresses and can swap 
> between them on the fly, OR
> (b) something NATty outside of the protocol stack has to 
> "fool" the protocol stack into responding consistently.
> 
> Years ago, we rejected (a) on the grounds that it would change IPv6.
> Folks who want to reject (b) now need to understand that they 
> will be rejecting the entire solution space...
> 
> Tony
> 
> 
>

---

From: "Bound, Jim" <[email-masked]>
Date: Sun, 15 Aug 2004 09:03:15 -0400

Prefix conservation or any type of forced VPN within the answer with NAT
is immoral view as technologist.
/jim 

> Sent: Sunday, August 15, 2004 4:19 AM
> To: Christian Huitema
> Cc: Fleischman, Eric; Brian E Carpenter; Multi6
> > I am sorry, but I don't get the VPN point. The number of VPN is 
> > proportional to the number of sites willing to establish VPN 
> > connections, and not linked to the availability of global addresses 
> > for these sites.
> 
> 
> If PI addresses are made widely available, then the routing 
> table will grow.  As the routing table grows, each carrier 
> must grow its tables to support default-free routing.  To be 
> able to provide VPN services, the carrier must be able to 
> support all of the routes that his customers wish to support. 
>  Since several of these customers could reasonably be Tier 1 
> backbones, they will be carrying the full table.  Thus, there 
> is an amplification factor (currently about 10x) of the size 
> of the table vs. what routers have to hold.  If that grows 
> (as seems likely as the size of the DFZ grows), then the 
> amplification times the natural growth of the table will 
> continue to push technology.
> 
> >
> > Eric is making a basic point of economics. Large companies 
> will want 
> > to get a global address, effectively shifting network 
> management cost 
> > from their IT department to the ISP community. A number of folks in 
> > this group believe this is a bad idea, and are essentially 
> trying to 
> > write in the standards that such cost shifting should be illegal. I 
> > personally don't think it should be illegal, although I am ready to 
> > admit that it should be expensive, as in "no free lunch".
> 
> 
> Well, I don't think that "illegal" is possible, given that we 
> are not a legislative entity.  I don't think that anyone 
> would object to a market for routing table entries, but it 
> has yet to appear.
> 
> >
> > Your mention that routers commonly support 1E6 routing 
> entries seems 
> > to indicate that some amount of "cost shifting" is indeed feasible.
> 
> 
> No, I don't think that's sufficient.  We have yet to see any 
> type of cost shifting occur.  For that to happen, we would 
> have to have a market and the fact that it does NOT exist 
> means that we don't have a mechanism to work with.  Yes, this 
> is an economic, not technical issue.  However, we as 
> technologists have the responsibility to raise the awareness 
> of this and to promote prefix conservation.
> 
> 
> Tony
> 
> 
>