Subject: [netmod] FW: I-D Action:draft-bierman-netmod-yang-usage-00.txt

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 25 Jan 2009 11:57:33 +0100

This is a very welcome contribution IMO. I do not believe that it can
be completed before the basic YANG The YANG data modeling language and
semantics document is approved and published, but it should follow it
not much later. Maybe the WG can consider chartering this as an addition
to the existing charter, so that the work is not fully serialized. 

As initial comment - the document would benefit from a section or annex
including a YANG modules review checklist similar to Annex A in RFC
4181. 

Dan

(speaking as AD and contributor)

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Saturday, January 24, 2009 4:00 AM
To: [email-masked]
Subject: I-D Action:draft-bierman-netmod-yang-usage-00.txt 

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title           : Guidelines for Authors and Reviewers of YANG
Data Model Documents
	Author(s)       : A. Bierman
	Filename        : draft-bierman-netmod-yang-usage-00.txt
	Pages           : 25
	Date            : 2009-01-23

This memo provides guidelines for authors and reviewers of standards
track specifications containing YANG data model modules.  Applicable
portions may be used as a basis for reviews of other YANG data model
documents.  Recommendations and procedures are defined, which are
intended to increase interoperability and usability of NETCONF
implementations which utilize YANG data model modules.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-bierman-netmod-yang-usage-00.t
xt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Andy Bierman <[email-masked]>
Date: Sun, 25 Jan 2009 08:15:26 -0800

> to the existing charter, so that the work is not fully serialized. 

The intent is that this BCP would follow the YANG RFC,
and get finalized after YANG is finalized (of course).

My concern is that YANG has insufficient standards value
without some guidelines.  YANG data modelers who
plan on getting YANG modules approved by the IETF
need to understand the criteria used to review YANG modules.

IMO, the conformance specified in the YANG draft
allows for modules with minimal documentation value,
so that RFC alone will not be sufficient to meet
IETF documentation quality expectations.

> including a YANG modules review checklist similar to Annex A in RFC

agreed, that is TBD

> Dan

Andy

> ------------------------------------------------------------------------
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 26 Jan 2009 11:53:02 +0100

I agree and I would like to add one more point. To help the authors of
future YANG modules and the reviewers we need at least one set of stable
public domain tools that can be used during design and verification and
be freely accessible. It would be desirable that these tools are
integrated in the IETF tools set, but referring them from a place like
the OPS Area Web pages could be an acceptable solution as well.

Dan

> From: Andy Bierman [mailto:[email-masked]] 
> Sent: Sunday, January 25, 2009 6:15 PM
> To: Romascanu, Dan (Dan)
> Cc: [email-masked]
> Subject: Re: [netmod] FW: I-D 
> Action:draft-bierman-netmod-yang-usage-00.txt
> 
> > not much later. Maybe the WG can consider chartering this as an 
> > addition to the existing charter, so that the work is not 
> fully serialized.
> > 
> 
> The intent is that this BCP would follow the YANG RFC, and 
> get finalized after YANG is finalized (of course).
> 
> without some guidelines.  YANG data modelers who plan on 
> getting YANG modules approved by the IETF need to understand 
> the criteria used to review YANG modules.
> 
> IMO, the conformance specified in the YANG draft allows for 
> modules with minimal documentation value, so that RFC alone 
> will not be sufficient to meet IETF documentation quality 
> expectations.
> 
> 
> > As initial comment - the document would benefit from a section or 
> > annex including a YANG modules review checklist similar to 
> Annex A in 
> > RFC 4181.
> > 
> 
> agreed, that is TBD
> 
> > Dan
> > 
> 
> Andy
>

---

From: Andy Bierman <[email-masked]>
Date: Mon, 26 Jan 2009 08:19:47 -0800

> the OPS Area Web pages could be an acceptable solution as well.

good point.
There are more people working on tools for YANG than
any unpublished work I have ever seen in the IETF,
especially for something as complex as a data modeling
language.  YANG has also changed dramatically over its 1 year
of I-D history.  Yet, despite all the "extra work for nothing"
that has been incurred already, I think tools will be
available soon after YANG stabilizes.  I don't believe
YANG will be stable until IETF Approval is reached.

Andy

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 26 Jan 2009 21:31:30 +0100 (CET)

> > the OPS Area Web pages could be an acceptable solution as well.

If the WG accepts this doc, I plan to implement a 'ietf-check' plugin
to one of those tools (pyang) which checks all the extra MUSTs and
SHOULDs.

/martin