Subject: [netmod] nested uses-stmt and refine

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 26 Jan 2009 15:39:59 +0100

Hi,

if the following is a valid module (pyang doesn't complain), which of
the two default values applies?

module test {
    namespace "http://example.com/test";
    prefix test;
    grouping foo {
        container feuillage {
            uses bar {
                refine "feuille" {
                    default 42;
                }
            }
        }
    }
    grouping bar {
        leaf feuille {
            type int8;
        }
    }
    uses foo {
	refine "feuillage/feuille" {
	    default 64;
	}
    }
}

Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 26 Jan 2009 21:34:05 +0100 (CET)

> the two default values applies?

Yes it is legal.

In the grouping 'foo', there is a leaf feuillage/feuille with the
default '42'.

In the data tree, there is a leaf /feuillage/feuille with the
default '64'.

/martin