Subject: [netmod] modules and submodules - order of data

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 27 Jan 2009 16:35:48 +0100

Hi,

is it correct that the relative order of data tree contributions from
the main module and included submodules is arbitrary?

Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Andy Bierman <[email-masked]>
Date: Tue, 27 Jan 2009 07:41:36 -0800

> the main module and included submodules is arbitrary?

IMO, yes, because includes can be nested.

> Lada

Andy

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 27 Jan 2009 17:11:16 +0100

> IMO, yes, because includes can be nested.

I think it is necessary to allow arbitrary order for trees appearing in
the same (sub)module as well, since otherwise refactoring a module into
submodules would be impossible:

module my-module {
  container foo {
    ...
  }
  container bar {
    ...
  }
}

defines a different schema than

module my-module {
  include my-submodule;
  container bar {
    ...
  }
}

module my-submodule {
  container foo {
    ...
  }
}

Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: WashamFan <[email-masked]>
Date: Sun, 01 Feb 2009 10:29:41 +0800

>  submodules would be impossible:

Yes. The compiling result modules of below two should be equalivent semantically.

washam