Subject: [netmod] require-instance bug

From: Andy Bierman <[email-masked]>
Date: Sat, 31 Jan 2009 14:58:12 -0800

Hi,

The revision notes do not show that the 'require-instance'
sub-statement was added to leafref and instance-identifier.
The normative sections are updated correctly, but the
ABNF for identityref (not instance-identifier) got
changed by mistake.  The leafref ABNF looks OK.

Andy

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: WashamFan <[email-masked]>
Date: Sun, 01 Feb 2009 12:09:52 +0800

Hi,
from last part of sec 9.9.6:
The following notification defines two leafrefs to refer to an
   existing ifIndex:

     notification link-failure {
         leaf if-name {
             path "/interfaces/interface/name";
         }
         leaf index {
             path "/interfaces/interface[name = current()/../if-name]"
                + "/ifIndex";
         }
     }

Washam: Seems "type leafdef{ ... }" was omitted.
 
   An example of a corresponding XML notification:

     <notification
       xmlns="urn:ietf:params:xml:ns:netconf:notification:1.0">
       <eventTime>2008-04-01T00:01:00Z</eventTime>
       <link-failure xmlns="http://acme.example.com/system">
         <if-name>eth0</if-name>
         <index>2</index>
       </link-failure>
     </notification>

Washam: I suggest adding referred data tree for complete.

washam