Subject: [netmod] Multi step derivation and strings with patterns

From: Balazs Lengyel <[email-masked]>
Date: Thu, 26 Feb 2009 17:46:34 +0100

Hello,
I am missing from chapter 9.4.6 The pattern Statement the following:

If a pattern restriction is applied to an already pattern restricted type, then values for that 
type must conform to both the current pattern and any pattern restriction valid for the base 
type(s).

Or was the decision the opposite? Anyway state it please.

Balazs

---

From: Martin Bjorklund <[email-masked]>
Date: Fri, 27 Feb 2009 00:04:29 +0100 (CET)

Balazs Lengyel <[email-masked]> wrote:
> If a pattern restriction is applied to an already pattern restricted type, then
> values for that type must conform to both the current pattern and any pattern
> restriction valid for the base type(s).

Ok.  I will add this.

/martin