Subject: [netmod] Separate namespace per YAM?

From: Balazs Lengyel <[email-masked]>
Date: Thu, 26 Feb 2009 17:34:07 +0100

Hello,
In chapter 5.3 it is written that
"All YANG definitions are specified within a module that is bound to a particular XML Namespace 
[XML-NAMES], which is a globally unique URI [RFC3986]. "

According to my English knowledge this does not mean that two different modules can not use the 
same namespace; the namespace is unique even if it is used by multiple YAMs.

Do we allow different modules to use the same namespace? If not, I propose to change this to:

"All YANG definitions are specified within a module that is bound to -- its own unique --- XML 
Namespace [XML-NAMES], which is a globally unique URI [RFC3986]. "

Balazs

---

From: Andy Bierman <[email-masked]>
Date: Thu, 26 Feb 2009 09:06:31 -0800

Balazs Lengyel wrote:
> "All YANG definitions are specified within a module that is bound to a 
> particular XML Namespace [XML-NAMES], which is a globally unique URI 
> [RFC3986]. "
> 
> According to my English knowledge this does not mean that two different 
> modules can not use the same namespace; the namespace is unique even if 
> it is used by multiple YAMs.
> 
> "All YANG definitions are specified within a module that is bound to -- 
> its own unique --- XML Namespace [XML-NAMES], which is a globally unique 
> URI [RFC3986]. "
> 

The current text seems fine.
'A particular' means 'one', and 'globally unique' is plain enough.
One XML namespace per module is the rule.

> Balazs

Andy