Subject: [netmod] FW: Lisa's Apps area Activity Report for Jan 2009

From: "David Harrington" <[email-masked]>
Date: Mon, 2 Feb 2009 15:27:21 -0500

Hi,
 
Thought I would point out that there is a YAM BOF being consdiered for
ietf74 (see http://trac.tools.ietf.org/bof/trac/wiki/YamCharter)
 
If you want to call YANG models YAMs, you probably should move to
protect the acronym from other IETF usage. You will probably need to
demonstrate a WG consensus to adopt that term for YANG models.
 
Personally, i think anything based on "yet another" is likely to
continually hit conflicts. 
I think for the users of yang models, who probably already have
experience in SMI MIBs, it will be apparent what a YANG MIB would be -
a management information base written using YANG. YMMV
 
dbh

  _____  

From: [email-masked]
[mailto:[email-masked]] On Behalf Of Lisa Dusseault
Sent: Monday, February 02, 2009 1:45 PM
To: Lisa Dusseault's Chairs; Apps Discuss
Subject: Lisa's Apps area Activity Report for Jan 2009

News, Updates
Quite a few BOFs getting requested for the next meeting, see
http://trac.tools.ietf.org/bof/trac/wiki for more details on each:
 - OAUTH - charter revised recently on list
 - YAM, BOF on advancing core email standards
 - MMOX, BOF on Massive Multiplayer Online Interactions
 - XMPP, revising base specs and doing some transport and security
stuff
 - Interest in other HTTP topics: Cookies, Origin header -- not sure
if there will be a BOF around this

The BOF approval call is Feb 5 and scheduling of these BOFs will
happen after that.

Document Status and Progress
Active documents, my action:

Active documents, waiting on other:
 - draft-reschke-webdav-post (Exp): Cyrus Daboo is doing shepherd
review and writeup
 - drat-montemurro-gsma-imei-urn (Exp): Waiting on revision from
authors
 - draft-ietf-sieve-mime-loop (PS): Waiting on authors to respond to
GenArt review
 - draft-ietf-usefor-usepro (PS): Waiting for last WG issue to get
resolved
 - draft-ietf-calsify-2446bis (PS): Waiting for a revision
 - draft-ietf-calsify-rfc2445bis (PS): Waiting for a revision
 - draft-snell-atompub-bidi (PS): Waiting for a revision
 - draft-wilde-sms-uri (PS): Waiting for a revision

Finished processing -- new in RFC Ed queue and new RFCs
 - draft-melnikov-sieve-imapext-metadata (PS): approved, announcement
sent
 - draft-freed-sieve-ihave (PS): In RFC Ed queue
 - draft-ietf-sieve-managesieve (PS): In RFC Ed queue
 - draft-kucherawy-sender-auth-header (PS): In RFC Ed queue

WG Status

ALTO, HTTPBIS, IDNABIS and SIEVE are meeting in SF / IETF74

ALTO: mostly quiet 
CALSIFY: Working through open issues
HTTPBIS: Interesting issues and great discussion on "Origin" header or
other fix/replacement to "Referer" header
IDNABIS: Great discussion on goals and tradeoffs e.g. simplicity and
invariability of assignments
SIEVE: Published several documents and pushing more through
USEFOR: Prompted the WG last week to close their last one or two
issues, to finish their last doc
--- Scanned by M+ Guardian Messaging Firewall --- Messaging Architects
sponsors The Spamhaus Project. 
_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Andy Bierman <[email-masked]>
Date: Mon, 02 Feb 2009 22:30:02 -0800

David Harrington wrote:
> experience in SMI MIBs, it will be apparent what a YANG MIB would be - a 
> management information base written using YANG. YMMV
>  

The term 'YANG data model module or submodule' is verbose.
Even 'YANG module or submodule' is verbose.  Most of the time,
the term 'module' is generic, but not close to all the time.
I don't care what the acronym is.  YAM does not stand for
Yet Another Module.

> dbh

Andy

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 3 Feb 2009 11:43:28 +0100

Acronyms clashes have already happened in the past in the IETF. Of
course, if they can be avoided it's better. If there was a published WG
document that already uses the YAM acronyms I could point it to the IESG
and IAB and try to prevent the clash using the prior usage argument.
However there is none that I am aware about in NETMOD. 
 
Dan
 
PS - this led me looking at the status of the documents in NETMOD and it
looks like you guys start accumulating delay relative to the charter
milestones - but the chairs and the rest of the WG probably know it and
are taking the appropriate measures - right? 

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of David Harrington
	Sent: Monday, February 02, 2009 10:27 PM
	To: [email-masked]
	Subject: [netmod] FW: Lisa's Apps area Activity Report for Jan
2009

	Hi,
	 
	Thought I would point out that there is a YAM BOF being
consdiered for ietf74 (see
http://trac.tools.ietf.org/bof/trac/wiki/YamCharter)
	 
	If you want to call YANG models YAMs, you probably should move
to protect the acronym from other IETF usage. You will probably need to
demonstrate a WG consensus to adopt that term for YANG models.

	dbh

________________________________

	News, Updates
	Quite a few BOFs getting requested for the next meeting, see
http://trac.tools.ietf.org/bof/trac/wiki for more details on each:
	 - OAUTH - charter revised recently on list
	 - YAM, BOF on advancing core email standards
	 - MMOX, BOF on Massive Multiplayer Online Interactions
	 - XMPP, revising base specs and doing some transport and
security stuff
	 - Interest in other HTTP topics: Cookies, Origin header -- not
sure if there will be a BOF around this

	Active documents, waiting on other:
	 - draft-reschke-webdav-post (Exp): Cyrus Daboo is doing
shepherd review and writeup
	 - drat-montemurro-gsma-imei-urn (Exp): Waiting on revision from
authors
	 - draft-ietf-sieve-mime-loop (PS): Waiting on authors to
respond to GenArt review
	 - draft-ietf-usefor-usepro (PS): Waiting for last WG issue to
get resolved
	 - draft-ietf-calsify-2446bis (PS): Waiting for a revision
	 - draft-ietf-calsify-rfc2445bis (PS): Waiting for a revision
	 - draft-snell-atompub-bidi (PS): Waiting for a revision
	 - draft-wilde-sms-uri (PS): Waiting for a revision

	 - draft-melnikov-sieve-imapext-metadata (PS): approved,
announcement sent

	WG Status

	ALTO: mostly quiet 
	CALSIFY: Working through open issues
	HTTPBIS: Interesting issues and great discussion on "Origin"
header or other fix/replacement to "Referer" header
	IDNABIS: Great discussion on goals and tradeoffs e.g. simplicity
and invariability of assignments
	SIEVE: Published several documents and pushing more through
	USEFOR: Prompted the WG last week to close their last one or two
issues, to finish their last doc
	--- Scanned by M+ Guardian Messaging Firewall --- Messaging
Architects sponsors The Spamhaus Project.

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 3 Feb 2009 11:52:05 +0100

> However there is none that I am aware about in NETMOD. 

For written documents, the term "YANG module" just seems to be right.
For everything else, I do not really care.
  
> are taking the appropriate measures - right? 

Yes, there is more important work to do than find the ultimate
acronym. While it is your job to check progress against the charter, I
am sure you also noted that some important but not chartered work is
being done as well. (Andy posted two new individual drafts and I
posted another one and I believe all these documents are important for
the overall success of what the WG is chartered to deliver.)

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 3 Feb 2009 11:57:49 +0100

> -----Original Message-----
> From: Juergen Schoenwaelder 

>   
> > PS - this led me looking at the status of the documents in 
> NETMOD and 
> > it looks like you guys start accumulating delay relative to the 
> > charter milestones - but the chairs and the rest of the WG probably 
> > know it and are taking the appropriate measures - right?
> 
> Yes, there is more important work to do than find the 
> ultimate acronym. While it is your job to check progress 
> against the charter, I am sure you also noted that some 
> important but not chartered work is being done as well. (Andy 
> posted two new individual drafts and I posted another one and 
> I believe all these documents are important for the overall 
> success of what the WG is chartered to deliver.)
> 

Of course. And I am concerned not that much about the execution of every
intermediate step, as by the danger of accumulating delays which would
result in the WG being late with its core pieces of work. There was a
lot of debate about urgency and time to market by the time the WG was
discussed and approved. Should I not be concerned? 

Dan

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 3 Feb 2009 13:17:06 +0100

> discussed and approved. Should I not be concerned? 

You should, it is your job. ;-)

/js