Subject: [netmod] CLRs and use-cases

From: Andy Bierman <[email-masked]>
Date: Thu, 02 Apr 2009 08:43:35 -0700

Hi,

This thread on identifier length got out of control,
and it is partly my fault.  I apologize to the WG for that.

I think it would be really helpful to have some (one?)
guiding principle when resolving these debates.

First of all, every standard could be called a CLR
in itself.  Unless we specify rules for interoperability,
it will not happen.  If multi-vendor distributed systems
could work just because everybody (of course)
will do the right thing, we would not need any SDOs.

Second, the WG should examine the use-cases for
the text that gets added or removed from the drafts.
Claiming "this is just a CLR" is not a use-case.
If somebody has a legitimate use-case (e.g. SMIv2
compatibility or tools compatibility) then it should
not be ignored.

Andy

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 03 Apr 2009 00:36:37 +0200

> in itself.  Unless we specify rules for interoperability,

In my view, every rule is a CLR unless and until it is proven to be
necessary, and I am not convinced it is the case with the identifier
length. If XML can live without such a restriction, why couldn't YANG?

Lada

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: Andy Bierman <[email-masked]>
Date: Thu, 02 Apr 2009 15:42:44 -0700

> length. If XML can live without such a restriction, why couldn't YANG?

Because XML is just a generic encoding mechanism
that doesn't actually do anything by itself.

But the most important reason is to protect
operator readability and usability, not to
protect implementors.  Code can always be changed.

Andy