Subject: Re: [netmod] must-stmt usage example

From: Martin Bjorklund <[email-masked]>
Date: Mon, 01 Jun 2009 09:22:42 +0200 (CEST)

Andy Bierman <[email-masked]> wrote:
> Andy Bierman wrote:
> > Hi,
> > [Warning: enhancement request up ahead!]
> 
> 
> I just remembered that the create-subscription operation
> defines some useless <error-info> added to it (bad-element).
> Modeling all the error-info is more than I had in mind,
> and the error-tag alone is not enough to automate the
> error response correctly.  Perhaps YANG2 should model
> every error detail, but not now.

Does this mean that your 'error-tag' statement should wait until YANG2
as well, or do you think it must be added now?

/martin

---

From: Andy Bierman <[email-masked]>
Date: Mon, 01 Jun 2009 04:58:58 -0700

> as well, or do you think it must be added now?

wait until YANG2.
I actually prefer the error construct you
proposed awhile back, which is part of the 'rpc'
construct (not part of range/length/etc.)

> /martin

Andy