Subject: Re: [netmod] [apps-discuss] Apps Area review of draft-ietf-netmod-interfaces-cfg-10

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 2 May 2013 09:33:43 +0200

[switched to NETMOD list]

On Apr 30, 2013, at 10:38 AM, Martin Bjorklund <[email-masked]> wrote:

>> 3.1 “The data model for interfaces presented in this document uses a flat
>> list of interfaces.” - does this mean that the model in section 3. should
>> have “interface*” rather than just “interface” as a child of “interfaces”?
> 
> In this tree diagram, the notion "interface [name]" means that it is a
> YANG list, with "name" as key.

But what about keyless list, i.e. operational state? They are indistinguishable from containers, so I'd suggest to append '*' to their names as well.

Lada

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 02 May 2013 09:57:37 +0200 (CEST)

Ladislav Lhotka <[email-masked]> wrote:
> But what about keyless list, i.e. operational state? They are
> indistinguishable from containers, so I'd suggest to append '*' to
> their names as well.

Yes, makes sense.  And it also makes sense for lists with keys in
general.

(I have updated the pyang plugin to use this notation).

/martin

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 2 May 2013 12:10:04 +0200

> Yes, makes sense.  And it also makes sense for lists with keys in

Right, that's what I meant.

> (I have updated the pyang plugin to use this notation).

Good, thanks,

Lada