Subject: Re: [netmod] draft-ietf-netmod-system-mgmt-06

From: Andy Bierman <[email-masked]>
Date: Wed, 15 May 2013 15:40:13 -0700

Hi,

I hope it was clear 20 days ago from Martin's email that both co-authors
agree
this is ready for another WGLC.  I hope you are not waiting because I did
not
not send an ACK email in addition to Martin's ACK.

Andy

On Thu, Apr 25, 2013 at 11:21 PM, Juergen Schoenwaelder <
[email-masked]> wrote:

> On Thu, Apr 25, 2013 at 01:21:58PM -0700, Andy Bierman wrote:
> > Hi,
> >
> > The ietf-system module draft has been updated:
> > http://www.ietf.org/id/draft-ietf-netmod-system-mgmt-06.txt
> >
> > We think all requested changes were addressed except
> > adding additional parameters to control server auto-population
> > of entries. This should be left for future work.
>
> Thanks for the update. Do I understand correctly that the authors
> believe this document is complete and ready for WG last call?
>
> /js
>
> --
> Juergen Schoenwaelder           Jacobs University Bremen gGmbH
> Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
> Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
>

---

From: Xiang Li <[email-masked]>
Date: Wed, 15 May 2013 18:06:05 -0500

On 5/15/2013 5:40 PM, Andy Bierman wrote:
> Hi,
>
> I hope it was clear 20 days ago from Martin's email that both 
> co-authors agree
> this is ready for another WGLC.  I hope you are not waiting because I 
> did not

I saw Juergen's email about  the new 
draft-ietf-netmod-interfaces-cfg-11.txt, where
interfaces and interfaces-state are introduced. I actually liked that 
idea since it clearly
separates  config and state.

"We like to receive feedback about this approach since we have similar
issues with other data models..."

Does that approach apply to this model? Or no...

--Xiang

>
> Andy
>
>
> On Thu, Apr 25, 2013 at 11:21 PM, Juergen Schoenwaelder 
> <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Andy Bierman <[email-masked]>
Date: Wed, 15 May 2013 16:54:10 -0700

On Wed, May 15, 2013 at 4:06 PM, Xiang Li <[email-masked]> wrote:

> interfaces and interfaces-state are introduced. I actually liked that idea
> since it clearly
> Does that approach apply to this model? Or no...

Not sure.  I do not know how much state information real devices
keep for interfaces that do not exist.  I don't think the interfaces
model should be changed.

There are only 3 config=false nodes in the ietf-system module:

   /system/platform container
   /system/clock/current-datetime leaf
   /system/clock/boot-datetime leaf

What if a client deletes the entire /system container?
What if a client deletes the /system/clock container?
IMO, if that's what the operator wants, then these config=false
objects must not be of interest.

Andy

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 16 May 2013 09:00:04 +0200 (CEST)

>    /system/clock/boot-datetime leaf

Right, and for this reason I also do not think it is necessary to move
these to a separate tree.

> What if a client deletes the /system/clock container?

Note that these nodes are non-presence containers, which means that
they exist solely for organizational purposes.  Their presence has no
semantic meaning.  So this means that /system/clock/current-datetime
always exists (*) when you do <get/>.

(*) actually, it is not mandatory, so this is not true.

/martin

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 16 May 2013 13:41:17 +0200

On Wed, May 15, 2013 at 03:40:13PM -0700, Andy Bierman wrote:
> co-authors agree this is ready for another WGLC.  I hope you are not
> waiting because I did not not send an ACK email in addition to
> Martin's ACK.

Yes, Andy, I understood Martin's message that way.

I wanted to give this document a detailed read before starting WGLC.
But then I got somewhat sidetracked because the discussions around the
other NETMOD documents we did send towards the IESG did keep me quite
busy (and the NETCONF over TLS revision I worked on last week as
well). I apologize for this delay and will focus on the systems-mgmt
document now.

/js