Subject: [netmod] open issue draft-ietf-netmod-ip-cfg-10

From: Martin Bjorklund <[email-masked]>
Date: Tue, 15 Oct 2013 12:51:34 +0200 (CEST)

Hi,

There is one open issue left in the ip-cfg document.

Currently, neighbors are configured per interface, but the neighbor
operational state is global:

  Config:   /interfaces/interface[name]/ipvX/neighbor[ip]

  Oper:     /ip-state/ipvX/neigbor[interface ip]

It was suggested that we harmonize this, so that the neighbor
operational state is also per interface:

  New oper: /interfaces-state/interface[name]/ipvX/neighbor[ip]

The other ip-related state is already per interface.

Note that the data available is exactly the same.

So we have two alternatives:

  A)  Keep current design

  B)  Move neighbor operational state to the interface state

In the previous thread, Lada preferres A, and Jeff and myself B.
What do other people think?

/martin

---

From: Radek Krejčí <[email-masked]>
Date: Wed, 16 Oct 2013 10:54:54 +0200

Hi,
I prefer B) to unify place where the neighbors config/state data can be
found.

Radek

Dne 15.10.2013 12:51, Martin Bjorklund napsal(a):
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>