Subject: Re: [netmod] Fwd: New Version Notification for draft-lhotka-netmod-yang-json-02.txt

From: Andy Bierman <[email-masked]>
Date: Mon, 7 Oct 2013 11:04:07 -0700

Hi,

I have implemented all of this draft for YANG-API (draft -01 version).
I think the NETMOD WG should standardize this document.

Comments:

Sec 3.4: IANA Considerations

I think a new media type is needed (yjson?).
In the RESTCONF draft the generic "json" string is used in
media types, but really this draft is required, not plain JSON.

Accept: application/vnd.yang.data+yjson
                                                  ^^^^^ instead of json

Sec 3.5: Security Considerations

You should replace [TBD] with a short paragraph stating
that no new security threats are added by this spec, since
it is not a protocol or a data model for a protocol.

Andy

On Mon, Sep 23, 2013 at 8:33 AM, Ladislav Lhotka <[email-masked]> wrote:

> Hi,
>
> this revision of JSON mapping document clarifies several issues, mainly
> based on Andy's feedback. Several new examples appear in the text, and
> appendix A contains a complete translation of the <get> reply from appendix
> D of draft-ietf-netmod-interfaces-cfg-12.
>
> Lada
>
> Begin forwarded message:
>
> > From: [email-masked]
> > Subject: New Version Notification for
> draft-lhotka-netmod-yang-json-02.txt
> > Date: September 23, 2013 5:28:37 PM GMT+02:00
> > To: Ladislav Lhotka <[email-masked]>
> >
> >
> > A new version of I-D, draft-lhotka-netmod-yang-json-02.txt
> > has been successfully submitted by Ladislav Lhotka and posted to the
> > IETF repository.
> >
> > Filename:      draft-lhotka-netmod-yang-json
> > Revision:      02
> > Title:                 Modeling JSON Text with YANG
> > Creation date:         2013-09-23
> > Group:                 Individual Submission
> > Number of pages: 19
> > URL:
> http://www.ietf.org/internet-drafts/draft-lhotka-netmod-yang-json-02.txt
> > Status:
> http://datatracker.ietf.org/doc/draft-lhotka-netmod-yang-json
> > Htmlized:
> http://tools.ietf.org/html/draft-lhotka-netmod-yang-json-02
> > Diff:
> http://www.ietf.org/rfcdiff?url2=draft-lhotka-netmod-yang-json-02
> >
> > Abstract:
> >   This document defines rules for presenting configuration and
> >   operational state data defined using YANG as JSON text.  It does so
> >   by specifying a procedure for translating the subset of YANG-
> >   compatible XML documents to JSON text, and vice versa.
> >
> >
> >
> >
> > Please note that it may take a couple of minutes from the time of
> submission
> > until the htmlized version and diff are available at tools.ietf.org.
> >
> > The IETF Secretariat
> >
>
> --
> Ladislav Lhotka, CZ.NIC Labs
> PGP Key ID: E74E8C0C
>
>
>
>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 09 Oct 2013 15:11:02 +0200

> I think the NETMOD WG should standardize this document.

Thanks, Andy.

> Accept: application/vnd.yang.data+yjson

Far from being an expert on the use of media types, I think the format is nothing but standard JSON. Using a new media type means that generic processors and intermediaries are out of luck.

> it is not a protocol or a data model for a protocol.

Yes, I'll do that.

Lada

---

From: Andy Bierman <[email-masked]>
Date: Wed, 9 Oct 2013 07:33:16 -0700

On Wed, Oct 9, 2013 at 6:11 AM, Ladislav Lhotka <[email-masked]> wrote:

> Far from being an expert on the use of media types, I think the format is
> nothing but standard JSON. Using a new media type means that generic
> processors and intermediaries are out of luck.
>
>

OK - I guess clients that don't know about the module-name prefixes
will not attempt to do anything other than display the JSON received
from the server.  Clients that know the JSON represents YANG data
will also know what to do with specially encoded strings.

Andy