Subject: [netmod] I-D Action: draft-ietf-netmod-routing-cfg-11.txt

From: [email-masked]
Date: Fri, 18 Oct 2013 04:12:19 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the NETCONF Data Modeling Language Working Group of the IETF.

	Title           : A YANG Data Model for Routing Management
	Author(s)       : Ladislav Lhotka
	Filename        : draft-ietf-netmod-routing-cfg-11.txt
	Pages           : 93
	Date            : 2013-10-18

Abstract:
   This document contains a specification of three YANG modules.
   Together they form the core routing data model which serves as a
   framework for configuring and managing a routing subsystem.  It is
   expected that these modules will be augmented by additional YANG
   modules defining data models for individual routing protocols and
   other related functions.  The core routing data model provides common
   building blocks for such extensions - routing instances, routes,
   routing information bases (RIB), routing protocols and route filters.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netmod-routing-cfg

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-netmod-routing-cfg-11

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-routing-cfg-11

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 18 Oct 2013 13:37:46 +0200

Hi,

this is a new revision of the routing draft. Most changes resulted from discussions with the authors of the I2RS RIB info model draft. I hope the current modules are suitable for building their data model on top of them.

A useful side-effect is an improved relationship between configuration and state data versions of some lists (see sec. 4.1).

Based on the recent consensus, I also migrated address family information to identities.

Lada  

Begin forwarded message:

> From: [email-masked]
> Subject: [netmod] I-D Action: draft-ietf-netmod-routing-cfg-11.txt
> Date: October 18, 2013 1:12:19 PM GMT+02:00
> To: [email-masked]
> Cc: [email-masked]
> 
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C