Subject: [netmod] I-D Action: draft-ietf-netmod-interfaces-cfg-13.txt

From: [email-masked]
Date: Thu, 07 Nov 2013 15:55:51 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the NETCONF Data Modeling Language Working Group of the IETF.

	Title           : A YANG Data Model for Interface Management
	Author(s)       : Martin Bjorklund
	Filename        : draft-ietf-netmod-interfaces-cfg-13.txt
	Pages           : 45
	Date            : 2013-11-07

Abstract:
   This document defines a YANG data model for the management of network
   interfaces.  It is expected that interface type specific data models
   augment the generic interfaces data model defined in this document.
   The data model includes configuration data, state data and counters
   for the collection of statistics.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netmod-interfaces-cfg

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-netmod-interfaces-cfg-13

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-interfaces-cfg-13

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Lange, Jeffrey K (GE Energy Management)" <[email-masked]>
Date: Fri, 8 Nov 2013 14:17:17 +0000

The examples in this document are using ianaift: for the interface type, and section 3.1 has added a paragraph about the iana-if-type module.  But the data model uses the new interface-type identity

Also section 9.2 added in a regerence to the iana-if-type draft.

-Jeff

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of [email-masked]
> Sent: Thursday, November 07, 2013 6:56 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [netmod] I-D Action: draft-ietf-netmod-interfaces-cfg-13.txt
> 
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Martin Bjorklund <[email-masked]>
Date: Fri, 08 Nov 2013 07:07:00 -0800 (PST)

Hi,

"Lange, Jeffrey K (GE Energy Management)" <[email-masked]> wrote:
> The examples in this document are using ianaift: for the interface
> type, and section 3.1 has added a paragraph about the iana-if-type
> module.  But the data model uses the new interface-type identity
> 

I am sorry, but I don't understand what you mean.  Can you point to a
specific bug/inconsistency?

/martin

---

From: "Lange, Jeffrey K (GE Energy Management)" <[email-masked]>
Date: Fri, 8 Nov 2013 15:13:10 +0000

If interfaces-cfg-13 was created to change the /interfaces/interface/type to be an identity, all of the references in the document to the iana-iftype enumeration should be removed and replaced.

e.g: page 6:

import iana-if-type {
       prefix ianaift;
     }

     augment "/if:interfaces/if:interface" {
         when "if:type = 'ianaift:ethernetCsmacd'";

         container ethernet {
             leaf duplex {
                 ...
             }
         }
     }

> From: Martin Bjorklund [mailto:[email-masked]]
> Sent: Friday, November 08, 2013 10:07 AM
> To: Lange, Jeffrey K (GE Energy Management)
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [netmod] I-D Action: draft-ietf-netmod-interfaces-cfg-13.txt
> 
> Hi,
>

---

From: Martin Bjorklund <[email-masked]>
Date: Fri, 08 Nov 2013 07:26:16 -0800 (PST)

"Lange, Jeffrey K (GE Energy Management)" <[email-masked]> wrote:
> If interfaces-cfg-13 was created to change the
> /interfaces/interface/type to be an identity, all of the references in
> the document to the iana-iftype enumeration should be removed and
> replaced.

Section 3.1 says:

   The "iana-if-type" module [I-D.ietf-netmod-iana-if-type] defines YANG
   identities for the interface types in the IANA-maintained "ifType
   registry".

Note that there's a new version of the iana document posted, where the
typedef has been replaced with an identity.

>          when "if:type = 'ianaift:ethernetCsmacd'";
                            ^^^^^^^^^^^^^^^^^^^^^^

This is the ethernetCsmacd *identity*, defined in iana-if-type.yang.

/martin

---

From: "Lange, Jeffrey K (GE Energy Management)" <[email-masked]>
Date: Fri, 8 Nov 2013 15:29:59 +0000

> Sent: Friday, November 08, 2013 10:26 AM

Ahh.. I guess I missed that.. sorry for the confusion...

-Jeff