Subject: Re: [netmod] mapping to snmp strings

From: Randy Presuhn <[email-masked]>
Date: Thu, 19 Dec 2013 17:10:00 -0800 (GMT-08:00)

Hi -

>From: Martin Bjorklund <[email-masked]>
>Sent: Dec 19, 2013 10:36 AM
>To: [email-masked]
>Cc: [email-masked], [email-masked]
>Subject: Re: [netmod] mapping to snmp strings
...
>         A server implementation MAY map this leaf to the sysContact
>         MIB object.  Such an implementation MUST use some mechanism
>         to handle the differences in size and characters allowed
>         between this leaf and sysContact.  The definition of such
>         a mechanism is outside the scope of this document.";
...

This brings to mind an old Sidney Harris cartoon.

Am I the only one bothered by putting a MUST on an
undefined behaviour?

Randy

---

From: Martin Bjorklund <[email-masked]>
Date: Fri, 20 Dec 2013 08:11:48 +0100 (CET)

> Am I the only one bothered by putting a MUST on an

s/MUST/must/
or
s/MUST/need to/

/martin

---

From: Benoit Claise <[email-masked]>
Date: Fri, 20 Dec 2013 17:04:15 +0100

Dear all,

If someone can NOT live with the proposal below, it's time to speak up.
If no answers (allow a couple of working days), Martin, please post a 
new draft-ietf-netmod-system-mgmt version. I'll progress the draft from 
there.

Also, please include the similar changes in 
draft-ietf-netmod-interfaces-cfg, and post a new version when the IETF 
LC ends (December 23rd)

Regards, Benoit
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
> .
>

---

From: B Lukovic <[email-masked]>
Date: Fri, 20 Dec 2013 11:38:26 -0500

Based on incompatibility between NetConf string, and 
DisplayString/SnmpAdminString
I don't think that any description that suggests mapping of "string" 
yang object
to "DisplayString/SnmpAdminString" MIB object should use word MUST.
Unless we can come up with mapping algorithm (option 5) this is simply 
going to create interoperability problem.

Regards
     Borislav
     [email-masked]

On 12/20/2013 11:04 AM, Benoit Claise wrote:
> new draft-ietf-netmod-system-mgmt version. I'll progress the draft 
> from there.
>