Subject: Re: [netmod] poll of interest on I-Ds submitted to the NETMOD WG

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 3 Dec 2013 17:31:21 +0100

Hi,

here is my quick summary of the result of the poll. In total, I saw
input from six people and here is a dense summary of what I think they
said. Let me know if something is missing or widely incorrect.

* Proposed NETMOD work items

  [1] http://tools.ietf.org/id/draft-bierman-netmod-yang-conformance-01.txt
  [2] http://tools.ietf.org/id/draft-bjorklund-netmod-yang-xpath-extensions-00.txt
  [3] http://tools.ietf.org/id/draft-lhotka-netmod-yang-json-02.txt
  [4] http://tools.ietf.org/id/draft-huang-netmod-acl-03.txt
  [5] http://tools.ietf.org/id/draft-clemm-netmod-yang-network-topo-01.txt
  [6] http://tools.ietf.org/id/draft-clemm-netmod-mount-01.txt

* Martin Bjorklund

  [1] real problem, not sure the I-D has the proper solution
  [2] support (obviously) and implementation of this
  [3] support and willing to review
  [4] support of the work but not sure NETMOD is the right home
  [5] support of the work but not sure NETMOD is the right home
  [6] interesting issue but the solution may be too simplistic/specific

* Andy Biermann

  [1] support (obviously)
  [2] support as a YANG extension but not as a new YANG version
  [3] support and required if RESTCONF gets chartered in NETCONF
  [4] support of the work but not sure NETMOD is the right home
  [5] support of the work but not sure NETMOD is the right home
  [6] network-wide data models is different than the NFS mount type solution

  Andy likes to avoid another version of the YANG language at this
  point in time.

* Ladislav Lhotka

  [1] support but should be part of YANG 1.1
  [2] support but should be part of YANG 1.1
  [3] support but should be part of YANG 1.1
  [4] support of the work but not sure NETMOD is the right home
  [5] support of the work but not sure NETMOD is the right home
  [6] support of the work but not sure NETMOD is the right home

* Reinaldo Penno

  [1] 
  [2] support but with lower priority
  [3] support adoption and willing to review
  [4] support adoption and willing to review
  [5] asking for a device model to complement this...
  [6] support adoption

* Xufeng Liu

  [1] support but should be part of YANG 1.1
  [2] support but should be part of YANG 1.1
  [3] support and implementing this already
  [4] support of the work
  [5] support of the work and started to implement this
  [6] 

* Alexander Clemm

  [1] support but the solution may need further work
  [2] support
  [3] support
  [4] support (obviously)
  [5] support (obviously)
  [6] support (obviously)

  Alex believes YANG is not mainstream enough to have data models been
  done by other working groups.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Jan Medved (jmedved)" <[email-masked]>
Date: Wed, 4 Dec 2013 04:53:26 +0000

Sorry for the late response, Ive been really underwaterŠ FWIW, please find
below my input: 

1. Support
2. Support
3. Support, being implemented in OpenDaylight
4. Support
5. Support, being implemented in OpenDaylight,
6. Support, being implemented in OpenDaylight
   - Martin: agreed, the draft needs more work, but it's an implementable
             starting point
   - Andy: agreed, but we need access to device models through the
           controller too

Thanks,
Jan

On 12/3/13 8:31 AM, "Juergen Schoenwaelder"
<[email-masked]> wrote:

>http://tools.ietf.org/id/draft-bierman-netmod-yang-conformance-01.txt
>  [2] 
>http://tools.ietf.org/id/draft-bjorklund-netmod-yang-xpath-extensions-00.t
>xt
>_______________________________________________
>netmod mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/netmod

---

From: "Lisa Huang (yihuan)" <[email-masked]>
Date: Wed, 4 Dec 2013 19:31:37 +0000

Sorry for my delayed reply.

1. Support. Have not completed read the draft yet.
2. I support this. I do have questions that what are the cases that a yang
model should use xpath functions if a better design of model is not
available. Use cases in the draft would be helpful.
3. Support. However, most data model used xpath to-some-extend.
Suggestions about how to deal with xpath in the draft would be helpful.
4. Support 
5. Support. Could help to review it.
6. Support. Could help to review it.

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 05 Dec 2013 11:24:37 +0100

> Suggestions about how to deal with xpath in the draft would be helpful.

The draft is designed to handle XPath expressions appearing in the data model, the idea is to (conceptually) map JSON text to XML and an XPath expression is then evaluated with the latter.

It seems though an example would be helpul, I am appending it to the todo list.

Thanks, Lada

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Fri, 6 Dec 2013 06:07:22 +0000

Here is my late input...    I support the work on

Due to relevance to OpenDaylight and SDN.  I believe it useful to have a consistent namespace administrable across multiple network elements for certain classes of use cases.

Efforts on [1], [2], and [3] appear interesting to me, but I haven't examined them enough  to have strong opinions.

Eric

-------- Original Message --------
Subject:

[netmod] poll of interest on I-Ds submitted to the NETMOD WG

Date:

Wed, 20 Nov 2013 08:00:12 +0100

From:

Juergen Schoenwaelder <[email-masked]><mailto:[email-masked]>

Reply-To:

Juergen Schoenwaelder <[email-masked]><mailto:[email-masked]>

To:

<[email-masked]><mailto:[email-masked]>

Hi,

at the last WG meeting in Vancouver, we did run out of time to discuss

what to do with the various individual I-Ds that have been submitted

to the NETMOD WG. So I like to poll for opinions on the list in order

to get a feeling where we are. In particular, I like to poll for

opinions on whether the following I-Ds should be worked on in an IETF

working group and how you see the priorities. In particular, it would

be nice to know who is willing to actively review documents and also

who is planning to implement the technology proposed in the various

I-Ds.

YANG Infrastructure:

Data Models:

Other Stuff:

If I am missing an I-D that is mature enough to be included in this

list, please let me know.

/js

--

Fax:   +49 421 200 3103         <http://www.jacobs-university.de/><http://www.jacobs-university.de/>

netmod mailing list

[email-masked]<mailto:[email-masked]>