Subject: Re: [netmod] AD review of draft-ietf-netmod-system-mgmt

From: Randy Presuhn <[email-masked]>
Date: Thu, 12 Dec 2013 15:44:59 -0800 (GMT-08:00)

Hi -

>From: Juergen Schoenwaelder <[email-masked]>
>Sent: Dec 12, 2013 3:52 AM
>To: Randy Presuhn <[email-masked]>, [email-masked]
>Cc: [email-masked]
>Subject: Re: [netmod] AD review of draft-ietf-netmod-system-mgmt
>
>On Thu, Dec 12, 2013 at 12:42:57AM -0800, Randy Presuhn wrote:
>>
>> >    o  An implementation MUST allow any legal "string" (YANG string).
>> 
>> There are good reasons to restrict formatting and control characters -
>> I'll assume YANG strings do this already.  If not, that's another long
>> discussion.
>
>RFC 6020 says:
>
>   The string built-in type represents human-readable strings in YANG.
>   Legal characters are tab, carriage return, line feed, and the legal
>   characters of Unicode and ISO/IEC 10646 [ISO.10646]:
>
>     ;; any Unicode character, excluding the surrogate blocks,
>     ;; FFFE, and FFFF.
>     string = *char
>     char = %x9 / %xA / %xD / %x20-D7FF / %xE000-FFFD /
>            %x10000-10FFFF
>
>And so far, we have used these strings without further restrictions in
>data models when there was something to be named.

Very odd.  It restricts the C0 controls, but permits the C1
control codes?  I hope someone thought that through carefully.

Randy

---

From: Martin Bjorklund <[email-masked]>
Date: Fri, 13 Dec 2013 08:22:25 +0100 (CET)

> control codes?  I hope someone thought that through carefully.

It is what XML Schema 1.0 says is a string.  See
http://www.w3.org/TR/xmlschema-2/#string and the reference to
http://www.w3.org/TR/2000/WD-xml-2e-20000814#NT-Char

/martin