Subject: [netmod] [Technical Errata Reported] RFC6020 (3833)

From: RFC Errata System <[email-masked]>
Date: Thu, 12 Dec 2013 14:42:39 -0800 (PST)

The following errata report has been submitted for RFC6020,
"YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6020&eid=3833

--------------------------------------
Type: Technical
Reported by: Chris LaBauve <[email-masked]>

Section: 12

Original Text
-------------
decimal64-specification = fraction-digits-stmt

Corrected Text
--------------
decimal64-specification = ;; these stmts can appear in any order
                          fraction-digits-stmt stmtsep
                          [range-stmt stmtsep]

Notes
-----
decimal64 types should allow for a range substatement; 9.2.4 states the range statement "is used to restrict integer and decimal built-in types."

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6020 (draft-ietf-netmod-yang-13)
--------------------------------------
Title               : YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)
Publication Date    : October 2010
Author(s)           : M. Bjorklund, Ed.
Category            : PROPOSED STANDARD
Source              : NETCONF Data Modeling Language
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Jernej Tuljak <[email-masked]>
Date: Fri, 13 Dec 2013 09:37:50 +0100

I believe Errata 3290 has already dealt with this. 
http://www.rfc-editor.org/errata_search.php?rfc=6020&eid=3290

Jernej

Dne 12.12.2013 23:42, piše RFC Errata System:
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 13 Dec 2013 10:27:16 +0100

On 13 Dec 2013, at 09:37, Jernej Tuljak <[email-masked]> wrote:

> I believe Errata 3290 has already dealt with this. http://www.rfc-editor.org/errata_search.php?rfc=6020&eid=3290

Indeed.

I would be actually very useful if RFCs/I-Ds had some marks in places for which errata exist, ideally with links to the corresponding erratum.

Lada

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Benoit Claise <[email-masked]>
Date: Fri, 13 Dec 2013 16:35:38 +0100

> I would be actually very useful if RFCs/I-Ds had some marks in places for which errata exist, ideally with links to the corresponding erratum.
That would be nice, indeed.
Including Sean, the tools liaison manager.

Regards,Benoit