Subject: [netmod] yang 1.1 status and next steps

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 19 May 2014 22:18:00 +0200

Hi,

the WG has collected a number of issued to consider for YANG 1.1. The
result can be found here:

      http://svn.tools.ietf.org/svn/wg/netmod/yang-1.1/

The deadline for submitting issues was 2014-05-07. It seems one issue
got submitted past the deadline and one issue that came up during the
discussions was not included in the issues list. We plan to include
these two issues but otherwise the issue list is closed now.

Currently, all issues are marked as NEW. The WG now has to decide
which issues are in scope of the YANG 1.1 effort (moving them to OPEN)
and which ones are not in scope (moving them to DEAD). To kickoff this
selection process, the WG chairs, with the help of some core
contributors (namely Martin, Andy, Lada), have produced a strawman
proposal that we will distribute in subsequent messages. The goal is
to determine on which issues the WG supports the strawman proposal.
Note that some issues were left undecided because we could not come up
with a strawman (either because there are simply different opinions or
there is a lack of understanding of the issue).

Once we have selected the OPEN issues, we will have to iterate over
them with the goal to find agreement on solutions that address the
issue. In order to do that, we plan to hold weekly conference calls on
Wednesdays 16:00-18:00 CEST, starting from June 4th. Benoit is
supporting us by providing WebEx for these virtual meetings. We will
send out further details about the calls in a subsequent message.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: [email-masked]
Date: Tue, 20 May 2014 08:57:54 +0800

http://www.ietf.org/mail-archive/web/netmod/current/msg09788.html

Why this issue is not included in issue list?
/frank

"netmod" <[email-masked]> 写于 2014-05-20 04:18:00:

> Juergen Schoenwaelder <[email-masked]> 
> 发件人:  "netmod" <[email-masked]>
> 
> 2014-05-20 04:18
> 
> 请答复 给
> Juergen Schoenwaelder <[email-masked]>
> 
> 收件人
> 
> [email-masked], 
> 
> 抄送
> 
> 主题
> 
> [netmod] yang 1.1 status and next steps
> 
> Hi,
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail (and any attachment transmitted herewith) is privileged and confidential and is intended for the exclusive use of the addressee(s).  If you are not an intended recipient, any disclosure, reproduction, distribution or other dissemination or use of the information contained is strictly prohibited.  If you have received this mail in error, please delete it and notify us immediately.
--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail (and any attachment transmitted herewith) is privileged and confidential and is intended for the exclusive use of the addressee(s).  If you are not an intended recipient, any disclosure, reproduction, distribution or other dissemination or use of the information contained is strictly prohibited.  If you have received this mail in error, please delete it and notify us immediately.

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 20 May 2014 10:45:53 +0200 (CEST)

Hi,

> Why this issue is not included in issue list?

This falls under the broader Y45.

/martin

---

From: [email-masked]
Date: Tue, 20 May 2014 17:28:06 +0800

No. I suggest remove the specification of advertisement of conformance in 
YANG.
YANG should define what the conformance is.
How to advertise conformance is NETCONF's job. 
/frank

Martin Bjorklund <[email-masked]> 写于 2014-05-20 16:45:53:

> Martin Bjorklund <[email-masked]> 
> 2014-05-20 16:45
> 
> 收件人
> 
> [email-masked], 
> 
> 抄送
> 
> [email-masked], [email-masked], 
[email-masked]
> 
> 主题
> 
> Re: [netmod] 答复: yang 1.1 status and next steps
> 
> Hi,
> 
> > ZTE Information Security Notice: The information contained in this
> mail (and any attachment transmitted herewith) is privileged and 
> confidential and is intended for the exclusive use of the addressee
> (s).  If you are not an intended recipient, any disclosure, 
> reproduction, distribution or other dissemination or use of the 
> information contained is strictly prohibited.  If you have received 
> this mail in error, please delete it and notify us immediately.
> > ZTE Information Security Notice: The information contained in this
> mail (and any attachment transmitted herewith) is privileged and 
> confidential and is intended for the exclusive use of the addressee
> (s).  If you are not an intended recipient, any disclosure, 
> reproduction, distribution or other dissemination or use of the 
> information contained is strictly prohibited.  If you have received 
> this mail in error, please delete it and notify us immediately.

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 20 May 2014 11:55:10 +0200 (CEST)

> How to advertise conformance is NETCONF's job. 

So this can be your proposed solution to Y45.

/martin

---

From: Andy Bierman <[email-masked]>
Date: Tue, 20 May 2014 08:20:58 -0700

> So this can be your proposed solution to Y45.
Y45 is really about how YANG conformance is specified.
Advertising service-level conformance instead of a list
of modules is a minor part of the problem.

I think there is a separate issue here wrt/ YANG module advertisement.
RFC 6020 is very NETCONF specific in this area. RESTCONF
does not advertise capabilities at all.  YANG needs to be
protocol-independent or at least be specific for NETCONF and RESTCONF.
There is at least a document clarification issue here.

> /martin

Andy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 21 May 2014 08:02:54 +0200

> So this can be your proposed solution to Y45.

Could be even more a solution to Y16, no?

Perhaps the easiest from a process point of view is to add an issue
and then we can during the discussion whether it is in scope for YANG
1.1 determine whether it falls into another issue or not. Personally,
I do not see how the solution can be implemented in a meaningful way
since we are not chartered to revise NETCONF. But that is already a
different discussion.

/js