Subject: [netmod] Recommendations on model reuse?

From: "Osborne, Eric" <[email-masked]>
Date: Wed, 30 Jul 2014 14:01:43 +0000

Netmod folks-

 There's a discussion on the isis list that boils down to how much YANG model reuse we shoot for.  In brief:

-          MPLS-TE is implemented in both OSPF and ISIS

-          The TE parts of OSPF and ISIS are identical, but OSPF and ISIS themselves are quite different

-          There was apparently some hallway conversation in Toronto that suggested that we should write two different TE models, one for OSPF and one for ISIS, and keep those two in constant sync rather than write a common TE model that augmented both OSPF and ISIS.

I wasn't a party to the hallway conversation, so I don't know what issues were raised to justify this split.  And the people who had it are not dummies, so I'm willing to believe there was a non-ridiculous reason for this decision.  In the long run, though, it seems like a bad idea.  I don't want to end up with a huge flat space which contains all models, with no reuse because people found it easier to roll their own with minute differences.

Are there any guiding principles we can look to for direction?  I hoped rfc6087 would have had something like this, but it seems to be concerned with the production of individual models and not with the interaction between models and guidelines around overall structure.

If there are no guiding principles anywhere, would it be useful to have a document that gave general guidelines around model reuse?  Naively I think it might just be three lines long and say "you SHOULD reuse existing models wherever possible rather than reinventing your own, and if you don't reuse you MUST have a section in your document that says why you didn't reuse what already existed".   Of course, it may end up being significantly longer and more complex than that.

eric

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Wed, 30 Jul 2014 14:15:34 +0000

Eric,

I don't think that hallway conversation rejected the idea of common TE model. Please see my reply on ISIS mailing list (perhaps it is waiting for moderator to post it - just realized that I was no on the ISIS list - I'll forward to you).

Jeffrey

From: Osborne, Eric [mailto:[email-masked]]
Sent: Wednesday, July 30, 2014 10:02 AM
To: [email-masked]
Cc: [email-masked]; Chris Bowers; Alia Atlas; Derek Man-Kit Yeung (myeung) ([email-masked]); Jeffrey (Zhaohui) Zhang; Hannes Gredler; Wunan (Eric)
Subject: Recommendations on model reuse?

Netmod folks-

eric

---

From: "Osborne, Eric" <[email-masked]>
Date: Wed, 30 Jul 2014 14:29:50 +0000

Cool, thanks.
For the record (since I didn't see it on the isis list) Jeffrey's reply was:

We did not talk explicitly about TE stuffs but more general parameters that are common to both IGP and that may be part of a superset IGP model.

I'm still open to have something hierarchical or using augmentations for common parameters but we need to agree on the scope.

I agree with this.
I'm also OK with developing three flat models in parallel (ISIS, OSPF, BGP-LS) as part of exploring what we can and cannot share.  I don't want to give the impression that we need to write a half-dozen documents around framework and structure before we actually do Real Work.  I just want to make sure that the end product has as much reuse as possible.

eric

From: Jeffrey (Zhaohui) Zhang [mailto:[email-masked]]
Sent: Wednesday, July 30, 2014 10:16 AM
To: Osborne, Eric; [email-masked]
Cc: [email-masked]; Chris Bowers; Alia Atlas; Derek Man-Kit Yeung (myeung) ([email-masked]); Hannes Gredler; Wunan (Eric)
Subject: RE: Recommendations on model reuse?

Eric,

Jeffrey

From: Osborne, Eric [mailto:[email-masked]]
Sent: Wednesday, July 30, 2014 10:02 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; Chris Bowers; Alia Atlas; Derek Man-Kit Yeung (myeung) ([email-masked]<mailto:[email-masked]>); Jeffrey (Zhaohui) Zhang; Hannes Gredler; Wunan (Eric)
Subject: Recommendations on model reuse?

Netmod folks-

eric