Subject: [netmod] FW: New Version Notification for draft-zheng-netmod-integrate-operations-00.txt

From: Zhengguangying <[email-masked]>
Date: Fri, 4 Jul 2014 00:13:58 +0000

Hi all in Netmod ,

    In some datastore operation scenarios, the operations triggered from the  NETCONF client might be a set of combined operations or a complex single operation within the NETCONF agent, which may change the datastores. And  sometimes the datastore change might not be from client but from the agent itself. These operations need to manipulate the data in running datastore or candidate datastore, and thus they need the <edit-config> capability a well as a unified authorization system to control the influence to the data   stores caused by them.
  So we wrote a draft to try to make a  discussion of the issue. The draft analyzes the scenario and requirments for model operations, and briefly discuss some possible solutions to satisfy the requirments.
Please review the draft and comment.
Many thanks!
Best regards,
Zheng
________________________________________
发件人: [email-masked] [[email-masked]]
发送时间: 2014年7月2日 17:54
收件人: Jixiaofeng (Steven); Zhengguangying; Jixiaofeng (Steven); Zhengguangying
主题: New Version Notification for draft-zheng-netmod-integrate-operations-00.txt

A new version of I-D, draft-zheng-netmod-integrate-operations-00.txt
has been successfully submitted by Guangying Zheng and posted to the
IETF repository.

Name:           draft-zheng-netmod-integrate-operations
Revision:       00
Title:          Integrating Operations in YANG Models
Document date:  2014-07-02
Group:          Individual Submission
Pages:          11
URL:            http://www.ietf.org/internet-drafts/draft-zheng-netmod-integrate-operations-00.txt
Status:         https://datatracker.ietf.org/doc/draft-zheng-netmod-integrate-operations/
Htmlized:       http://tools.ietf.org/html/draft-zheng-netmod-integrate-operations-00

Abstract:
   This document introduces an extension to YANG. The extension allows
   operation methods to be directly integrated in YANG models.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: [email-masked]
Date: Wed, 9 Jul 2014 17:13:48 +0800

Hi Zhengguangying,

        After reading the draft, I have some doubts,can you answer them?

        1.In my opinion, method defines method rather than data.If the 
sample succeeds, user gets "arpList" data by <get-config> operation, 
        the responding message display both the static data and the new 
data(dynamic data).Is it right? Does it need to commit?
        After that,if user edits the new "arpList" data by <edit-config> 
operation,is the dynamic data be edited at the same time?
        If the dynamic data is deleted for some reason, the new "arpList" 
data still exist?

        2.Can you describe the attribute information of the method?
        Does the method support "output" statement? 
        Is the config statement of node meaningless?

       I think it is better and clearer to define the method by using 
YANG. 

Best regards!

Zhengguangying <[email-masked]> 
发件人:  "netmod" <[email-masked]>
2014-07-04 08:13

收件人
"[email-masked]" <[email-masked]>, 
抄送
Yangang <[email-masked]>
主题
[netmod] FW: New Version Notification for 
draft-zheng-netmod-integrate-operations-00.txt

Hi all in Netmod ,

    In some datastore operation scenarios, the operations triggered from 
the  NETCONF client might be a set of combined operations or a complex 
single operation within the NETCONF agent, which may change the 
datastores. And  sometimes the datastore change might not be from client 
but from the agent itself. These operations need to manipulate the data in 
running datastore or candidate datastore, and thus they need the 
<edit-config> capability a well as a unified authorization system to 
control the influence to the data   stores caused by them.
  So we wrote a draft to try to make a  discussion of the issue. The draft 
analyzes the scenario and requirments for model operations, and briefly 
discuss some possible solutions to satisfy the requirments.
Please review the draft and comment.
Many thanks!
Best regards,
Zheng
________________________________________
发件人: [email-masked] [[email-masked]]
发送时间: 2014年7月2日 17:54
收件人: Jixiaofeng (Steven); Zhengguangying; Jixiaofeng (Steven); 
Zhengguangying
主题: New Version Notification for 
draft-zheng-netmod-integrate-operations-00.txt

URL:            
http://www.ietf.org/internet-drafts/draft-zheng-netmod-integrate-operations-00.txt

Status:         
https://datatracker.ietf.org/doc/draft-zheng-netmod-integrate-operations/
Htmlized:       
http://tools.ietf.org/html/draft-zheng-netmod-integrate-operations-00

Abstract:

Please note that it may take a couple of minutes from the time of 
submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail (and any attachment transmitted herewith) is privileged and confidential and is intended for the exclusive use of the addressee(s).  If you are not an intended recipient, any disclosure, reproduction, distribution or other dissemination or use of the information contained is strictly prohibited.  If you have received this mail in error, please delete it and notify us immediately.

---

From: Zhengguangying <[email-masked]>
Date: Thu, 10 Jul 2014 06:10:13 +0000

Hi, Daixianxian

       Thank you for your comments firstly. I try to answer your comments here, please check my doubt, thanks.

        >>1.In my opinion, method defines method rather than data.If the sample succeeds, user gets "arpList" data by <get-config> operation,
        the responding message display both the static data and the new data(dynamic data).Is it right? Does it need to commit?

        Zheng: Right, if succeed, the dynamic data will become configuration data and it will in the  <get-config> RPC reply data.
               If define new non-standard RPC, do you think it need a sperate commit operation or commit it internally combine with the new defined RPC?

        >>After that,if user edits the new "arpList" data by <edit-config> operation,is the dynamic data be edited at the same time?
        If the dynamic data is deleted for some reason, the new "arpList" data still exist?
        Zheng: After convert the dynamic data to configuration data, the orignal dynamic data will be deleted.

        Does the method support "output" statement?
        Is the config statement of node meaningless?
        Zheng：In this version draft we want to describe the problems itself, and try to discuss it in the WG and make it clear. The detail design will describe in the next version.

Regards&Thanks

Zheng

________________________________
发件人: [email-masked] [[email-masked]]
发送时间: 2014年7月9日 17:13
收件人: Zhengguangying
抄送: [email-masked]; netmod; Yangang
主题: 答复: [netmod] FW: New Version Notification for draft-zheng-netmod-integrate-operations-00.txt

 Hi Zhengguangying,

        1.In my opinion, method defines method rather than data.If the sample succeeds, user gets "arpList" data by <get-config> operation,
        the responding message display both the static data and the new data(dynamic data).Is it right? Does it need to commit?
        After that,if user edits the new "arpList" data by <edit-config> operation,is the dynamic data be edited at the same time?
        If the dynamic data is deleted for some reason, the new "arpList" data still exist?

       I think it is better and clearer to define the method by using YANG.

Best regards!

2014-07-04 08:13

收件人
        "[email-masked]" <[email-masked]>,
抄送
        Yangang <[email-masked]>
主题
        [netmod] FW: New Version Notification for draft-zheng-netmod-integrate-operations-00.txt

Hi all in Netmod ,

Abstract:

---

From: [email-masked]
Date: Thu, 10 Jul 2014 16:01:00 +0800

Hi Zhengguangying, 

        I think I have understand your design concept. Thank you.

        A suggestion: as method is defined in module statement, users can 
only convert dynamic data module by module.
 
        Maybe you can define an new operation to accomplish all the 
dynamic data becoming configuration data,
        like "copy config" operation?

Best regards!

2014-07-10 14:10

收件人
"[email-masked]" <[email-masked]>, 
抄送
"[email-masked]" <[email-masked]>, netmod <[email-masked]>, 
Yangang <[email-masked]>
主题
答复: [netmod] FW: New Version Notification for 
draft-zheng-netmod-integrate-operations-00.txt

Hi, Daixianxian
 
       Thank you for your comments firstly. I try to answer your comments 
here, please check my doubt, thanks.
 
        Zheng: Right, if succeed, the dynamic data will become 
configuration data and it will in the  <get-config> RPC reply data. 
               If define new non-standard RPC, do you think it need a 
sperate commit operation or commit it internally combine with the new 
defined RPC?

operation,is the dynamic data be edited at the same time? 
        If the dynamic data is deleted for some reason, the new "arpList" 
data still exist? 
        Zheng: After convert the dynamic data to configuration data, the 
orignal dynamic data will be deleted.
 
        Does the method support "output" statement? 
        Is the config statement of node meaningless?
        Zheng：In this version draft we want to describe the problems 
itself, and try to discuss it in the WG and make it clear. The detail 
design will describe in the next version.
 
Regards&Thanks
Zheng

发件人: [email-masked] [[email-masked]]
发送时间: 2014年7月9日 17:13
收件人: Zhengguangying
抄送: [email-masked]; netmod; Yangang
主题: 答复: [netmod] FW: New Version Notification for 
draft-zheng-netmod-integrate-operations-00.txt

 Hi Zhengguangying, 

Best regards!

收件人

Hi all in Netmod ,

Status:         

Abstract:

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail 
(and any attachment transmitted herewith) is privileged and confidential 
and is intended for the exclusive use of the addressee(s).  If you are not 
an intended recipient, any disclosure, reproduction, distribution or other 
dissemination or use of the information contained is strictly prohibited. 
If you have received this mail in error, please delete it and notify us 
immediately.

---

From: [email-masked]
Date: Thu, 10 Jul 2014 16:01:47 +0800

Hi Zhengguangying, 

 

Best regards!

收件人

Hi, Daixianxian

 
 
Regards&Thanks
Zheng

 Hi Zhengguangying, 

Best regards!

收件人

Hi all in Netmod ,

Status:         

Abstract: