Subject: [netmod] json or i-json - this is my question

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 3 Jul 2014 17:21:51 +0200

Hi,

can someone (Lada) explain how 

  http://tools.ietf.org/html/draft-ietf-netmod-yang-json-00

relates to

  http://tools.ietf.org/html/draft-ietf-json-i-json-02

and whether any changes are necessary to conform to the i-json
restricted profile of json?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 3 Jul 2014 19:28:43 +0200

> restricted profile of json?

JSON documents resulting from the mapping in yang-json-00 conform to I-JSON spec, including the RECOMMENDED parts - I only have slight doubts about sections 2.1 (text about unpaired surrogates), and 2.2 (because I think sender of NETCONF data exprects a receiver of an uint64 leaf to be able to treat it as an exact value).

Lada

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C