Subject: [netmod] Lada's question on github repo

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 21 Jul 2014 10:52:56 -0400

RE: your objection to initial commits, I think we can address that easily by allowing the person who commits an initial file to be the initial committer, and then that person manages commits going forward.  Longer term we probably wanted this model anyways so that this would scale.  As the project progresses, they can add additional committers (or deleted stale ones).

	--Tom

---

From: Dean Bogdanovic <[email-masked]>
Date: Mon, 21 Jul 2014 15:09:01 +0000

I'm in full support to such model. Dana B, Kiran S, Lisa H and I used that model for ACL draft and worked without a problem. 

Dean

> On Jul 21, 2014, at 10:53, "Thomas D. Nadeau" <[email-masked]> wrote:
> 
> 
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 22 Jul 2014 14:53:23 -0400

"Thomas D. Nadeau" <[email-masked]> writes:

> 	RE: your objection to initial commits, I think we can address
> 	that easily by allowing the person who commits an initial file
> 	to be the initial committer, and then that person manages
> 	commits going forward.  Longer term we probably wanted this
> 	model anyways so that this would scale.  As the project
> 	progresses, they can add additional committers (or deleted stale
> 	ones).

OK, so what are we supposed to do in order to be able to push the IS-IS module into
the repo and get the necessary permissions?

Also, is it possible to have the I-D source there as well so that it can be
developed in sync with the module?

Lada

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Andy Bierman <[email-masked]>
Date: Tue, 22 Jul 2014 12:16:29 -0700

> developed in sync with the module?

How about if we have an offline meeting this week to discuss how the git
repo should
be organized and how new contributors can be added to the project with
commit rights?

An issue was raised in I2RS about using github vs. just a git repo
somewhere.
IMO, github offers great reports and external tool integration, but it does
require
that each user have a (free) github account.

> Lada

Andy

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 22 Jul 2014 15:19:46 -0400

> the repo and get the necessary permissions?

	We need to relax the create permissions. I'll look into it this week.

> developed in sync with the module?

	That I am not sure. You need to check with IETF rules for that. There are some pretty clear rules WRT re-publication of I-Ds/RFCs (you need explicit permission from the ID Editor). At least that was the case last time I checked.

	--Tom

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 22 Jul 2014 15:22:12 -0400

On Jul 22, 2014:3:16 PM, at 3:16 PM, Andy Bierman <[email-masked]> wrote:

> How about if we have an offline meeting this week to discuss how the git repo should
> be organized and how new contributors can be added to the project with commit rights?

	good idea.   How about Wednesday morning, 9AM-10AM EST?

> An issue was raised in I2RS about using github vs. just a git repo somewhere.
> IMO, github offers great reports and external tool integration, but it does require

	I agree. But in modern software engineering times, if you do not have a github account, its a liability (career wise) if you ask me. *)

	--Tom

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 22 Jul 2014 15:23:22 -0400

> be organized and how new contributors can be added to the project with commit rights?

+1

> that each user have a (free) github account.

This is IMO not a big hurdle.

Lada

---

From: Andy Bierman <[email-masked]>
Date: Tue, 22 Jul 2014 12:25:35 -0700

> good idea.   How about Wednesday morning, 9AM-10AM EST?
opsawg and sfc meet at that time, so I am busy.

> I agree. But in modern software engineering times, if you do not have a
> github account, its a liability (career wise) if you ask me. *)
>
>
Agree. I should point out that a github account is only needed for write
access.
There is public read access.

Andy

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 22 Jul 2014 15:27:00 -0400

On 22 Jul 2014, at 15:25, Andy Bierman <[email-masked]> wrote:

> 
> 
> 
> On Tue, Jul 22, 2014 at 12:22 PM, Thomas D. Nadeau <[email-masked]> wrote:
> 

I also have a meeting at that time.

Lada

> Agree. I should point out that a github account is only needed for write access.

---

From: "Lisa Huang (yihuan)" <[email-masked]>
Date: Tue, 22 Jul 2014 19:28:01 +0000

Andy,

Check-out doesn't requires github account but commit requires an account.

Thanks,

Lisa

From: Andy Bierman <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, July 22, 2014 12:16 PM
To: Ladislav Lhotka <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [netmod] Lada's question on github repo

On Tue, Jul 22, 2014 at 11:53 AM, Ladislav Lhotka <[email-masked]<mailto:[email-masked]>> wrote:

Lada

Andy

> [email-masked]<mailto:[email-masked]>

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 22 Jul 2014 15:28:27 -0400

> 	good idea.   How about Wednesday morning, 9AM-10AM EST?

	Wednesday 2:30-3:30 EST?

> There is public read access.

	Yes. But I think you need an account if you want to set up SSH keys even for read.

	--Tom

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 22 Jul 2014 15:29:54 -0400

>> 	good idea.   How about Wednesday morning, 9AM-10AM EST?

Works for me.

Lada