Subject: [netmod] Regarding draft-zheng-netmod-integrate-operations

From: Viswanath Reddy <[email-masked]>
Date: Thu, 17 Jul 2014 15:57:30 +0530

Hi Guangying Zheng,

Greetings to you!

I've come across this NETMOD draft proposed by you and Mr. X. Ji. The
proposal looks very promising in terms of extending the base methods or
operations in YANG models.

*A few queries / suggestions:*
    1) When it comes to committing / converting dynamic ARP entries to
static / configuration ARP entries; Generally not all entries need to be
committed and a selective set may need to be done. How do we do in that
case?
    2) You may provide more examples as the content looks pretty abstract.
    3) How about error handling for the extended "method" operations?

*A few comments on the grammatical content.*
    Section 3: "a well as" needs to be replaced with "as well as".
    Section 3.1: learn needs to be replaced with learnt.
    Section 3.3: You may want to replace "build-in " "built-in ".
    Scenario 3: "needs maintaining operations" can be replaced with "needs
maintenance operations".

Regards,
Viswanath

---

From: Zhengguangying <[email-masked]>
Date: Fri, 18 Jul 2014 02:03:29 +0000

Hi Viswanath,

    Thank you for your comments firstly, please check my answer.

>>A few queries / suggestions:
    >>1) When it comes to committing / converting dynamic ARP entries to static / configuration ARP entries; Generally not all entries need to be committed and a selective set may need to be done. How do we do in that case?
Answer:   For this case, the a selective set will define as input parameters.
    >>3) How about error handling for the extended "method" operations?
Answer: these two suggestions will concern in the next version draft's solution detail section.

>>A few comments on the grammatical content.
   >> Scenario 3: "needs maintaining operations" can be replaced with "needs maintenance operations".
Answer: sorry for so many grammatical errors, these will be updated in the next draft version.

  Thank you a again for your comments ans suggestions. If any other comments please let me konw.

Regards&Thanks
Zheng
________________________________
发件人: Viswanath Reddy [[email-masked]]
发送时间: 2014年7月17日 18:27
收件人: Zhengguangying
抄送: [email-masked]
主题: Regarding draft-zheng-netmod-integrate-operations

Hi Guangying Zheng,

Greetings to you!

I've come across this NETMOD draft proposed by you and Mr. X. Ji. The proposal looks very promising in terms of extending the base methods or operations in YANG models.

A few queries / suggestions:
    1) When it comes to committing / converting dynamic ARP entries to static / configuration ARP entries; Generally not all entries need to be committed and a selective set may need to be done. How do we do in that case?
    2) You may provide more examples as the content looks pretty abstract.
    3) How about error handling for the extended "method" operations?

A few comments on the grammatical content.
    Section 3: "a well as" needs to be replaced with "as well as".
    Section 3.1: learn needs to be replaced with learnt.
    Section 3.3: You may want to replace "build-in " "built-in ".
    Scenario 3: "needs maintaining operations" can be replaced with "needs maintenance operations".

Regards,
Viswanath