Subject: [netmod] IETF91 NETMOD agenda ?

From: "Sterne, Jason (Jason)" <[email-masked]>
Date: Tue, 21 Oct 2014 21:32:26 +0000

Hi all,

Is there a preliminary agenda for the two NETMOD sessions at IETF91 ?

Some thought about topics being split between the 1st (longer) and 2nd (shorter) sessions ?

Thanks,
Jason

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 21 Oct 2014 17:34:23 -0400

Not yet. Please propose topics. 

	—Tom

> On Oct 21, 2014:5:32 PM, at 5:32 PM, Sterne, Jason (Jason) <[email-masked]> wrote:
> 
> Hi all,
>  
> _______________________________________________
> netmod mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netmod <https://www.ietf.org/mailman/listinfo/netmod>

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Tue, 21 Oct 2014 23:59:38 +0000

I would like to talk about
http://datatracker.ietf.org/doc/draft-voit-netmod-peer-mount-requirements/

We chatted about this document in an Interim call two weeks ago.  The intro PPT is here<http://www.voit.org/Peer-Mount-Netconf-WG-Oct2014.pdf>.  A result of the call was that we had a wide ranging alias discussions.  A review in Hawaii would allow a recap/summary of mailing list discussions, as well as an introduction to the concepts to other participants.

Note that several discussions came out of the call.  Each has implications to possible charters across various IETF WG.  Worthy of discussion are:

- RFC 6244 defines a single-box architecture.  YANG syntax is used for multi-device abstractions in the OpenDaylight controller.  Should the IETF consider architectures where YANG models span devices?

- RFC 5277 on Netconf notifications doesn’t include information on how to handle Pub/Sub.  There is also some demand for Pub/Sub which is tied to YANG with no required linkage to a transport protocol.  There are also needs for Pub/Sub beyond YANG.  How should we approach this area?

Eric

From: netmod [mailto:[email-masked]] On Behalf Of Thomas D. Nadeau
Sent: Tuesday, October 21, 2014 5:34 PM
To: Sterne, Jason (Jason)
Cc: [email-masked]
Subject: Re: [netmod] IETF91 NETMOD agenda ?

          —Tom

On Oct 21, 2014:5:32 PM, at 5:32 PM, Sterne, Jason (Jason) <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Thanks,
Jason

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Wed, 22 Oct 2014 00:04:47 +0000

It might also be good top summarize the set of topics below during the interim call tomorrow.   That would tee up exactly what could be on the plate for Hawaii.

Eric

From: netmod [mailto:[email-masked]] On Behalf Of Eric Voit (evoit)
Sent: Tuesday, October 21, 2014 8:00 PM
To: Thomas D. Nadeau; [email-masked]
Subject: Re: [netmod] IETF91 NETMOD agenda ?

Eric

Cc: [email-masked]<mailto:[email-masked]>

          —Tom

Hi all,

Thanks,
Jason

---

From: "Sterne, Jason (Jason)" <[email-masked]>
Date: Wed, 22 Oct 2014 13:29:47 +0000

One item that might be useful:

-          “Design Teams” update:

o   List of all known “design teams” that are working on YANG models (especially ones that may be progressing outside of the IETF mailing lists)

o   Ideally a brief status update from one of the primary leaders/contributors (i.e. a few bullet points / 1-2 minutes) for each one (not to discuss the technical details of specific models – that could be other agenda items)

Regards,
Jason

From: Thomas D. Nadeau [mailto:[email-masked]]
Sent: Tuesday, October 21, 2014 5:34 PM
To: Sterne, Jason (Jason)
Cc: [email-masked]
Subject: Re: [netmod] IETF91 NETMOD agenda ?

            —Tom

Hi all,

Thanks,
Jason

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 22 Oct 2014 09:34:39 -0400

Meeting is canceled. See previous note from Benoit. 

	—Tom

> On Oct 22, 2014:9:29 AM, at 9:29 AM, Sterne, Jason (Jason) <[email-masked]> wrote:
> 
> From: Thomas D. Nadeau [mailto:[email-masked] <mailto:[email-masked]>] 
> Cc: [email-masked] <mailto:[email-masked]>
> On Oct 21, 2014:5:32 PM, at 5:32 PM, Sterne, Jason (Jason) <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Hi all,
>

---

From: "Sterne, Jason (Jason)" <[email-masked]>
Date: Wed, 22 Oct 2014 13:42:42 +0000

This email thread I started is about the IETF91 NETMOD meetings (not the interim meeting).

From: Thomas D. Nadeau [mailto:[email-masked]]
Sent: Wednesday, October 22, 2014 9:35 AM
To: Sterne, Jason (Jason)
Cc: [email-masked]
Subject: Re: [netmod] IETF91 NETMOD agenda ?

            —Tom

On Oct 22, 2014:9:29 AM, at 9:29 AM, Sterne, Jason (Jason) <[email-masked]<mailto:[email-masked]>> wrote:

-          “Design Teams” update:

Regards,
Jason

            —Tom

Hi all,

Thanks,
Jason

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 22 Oct 2014 09:50:27 -0400

ah sorry. I’ll take note of this for the proposed agenda for Hawaii. 

> On Oct 22, 2014:9:42 AM, at 9:42 AM, Sterne, Jason (Jason) <[email-masked]> wrote:
> 
> On Oct 22, 2014:9:29 AM, at 9:29 AM, Sterne, Jason (Jason) <[email-masked] <mailto:[email-masked]>> wrote:
>

---

From: Andy Bierman <[email-masked]>
Date: Thu, 23 Oct 2014 09:02:27 -0700

> Not yet. Please propose topics.
I would like 15 min. to discuss YANG conformance issues, specified in this
draft:
http://www.ietf.org/id/draft-bierman-netmod-yang-conformance-04.txt

These issues may get resolved in the NETCONF YANG 1.1 virtual interim
meeting next week. If not, this topic should be discussed at the IETF
meeting.

--Tom

Andy

> [email-masked]
> [email-masked]

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 23 Oct 2014 18:13:46 +0200

Hi,

apart from the two WG items draft-ietf-netmod-routing-cfg-16 (to be submitted) and draft-ietf-netmod-yang-json-01, I’d like to discuss the draft and draft-lhotka-netmod-yang-metadata-00. I think 5 minutes would be enough for the latter, I could even do it together with yang-json.

Thanks, Lada

On 23 Oct 2014, at 18:02, Andy Bierman <[email-masked]> wrote:

> 
> 
> On Tue, Oct 21, 2014 at 2:34 PM, Thomas D. Nadeau <[email-masked]> wrote:
> 
> I would like 15 min. to discuss YANG conformance issues, specified in this draft:
> meeting next week. If not, this topic should be discussed at the IETF meeting.
> 
> 
> 	—Tom
> 
> Andy
>  
> 
> 

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 23 Oct 2014 13:43:41 -0400

We have plenty of runway in the agenda right now so I will put it down as two items. We reserved two slots because I feel its important to encourage discussion during the face2face meetings so insofar as I can, I want to give you enough runway to discuss this in detail. 

	--Tom

> On Oct 23, 2014:12:13 PM, at 12:13 PM, Ladislav Lhotka <[email-masked]> wrote:
> 
> Hi,
>

---

From: "Dana Blair (dblair)" <[email-masked]>
Date: Thu, 23 Oct 2014 19:26:30 +0000

Need about 10 minutes to discuss the ACL Yang draft

thanks,
Dana

On 10/23/14, 1:43 PM, "Thomas D. Nadeau" <[email-masked]> wrote:

>
>	We have plenty of runway in the agenda right now so I will put it down
>as two items. We reserved two slots because I feel its important to
>encourage discussion during the face2face meetings so insofar as I can, I
>want to give you enough runway to discuss this in detail.
>
>	--Tom
>
>
>> apart from the two WG items draft-ietf-netmod-routing-cfg-16 (to be
>>submitted) and draft-ietf-netmod-yang-json-01, I¹d like to discuss the
>>draft and draft-lhotka-netmod-yang-metadata-00. I think 5 minutes would
>>be enough for the latter, I could even do it together with yang-json.
>> 
>> Thanks, Lada
>> 
>>> 	‹Tom

---

From: "Lisa Huang (yihuan)" <[email-masked]>
Date: Mon, 27 Oct 2014 17:20:46 +0000

Tom,

Is it possible to allocate each time slot to include both presentation
time and discussion time in agenda? Thanks,

Lisa

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 27 Oct 2014 13:41:45 -0400

Yes.  The idea is to discuss as part of the slot. 

	--tom

> On Oct 27, 2014:1:20 PM, at 1:20 PM, Lisa Huang (yihuan) <[email-masked]> wrote:
> 
> Tom,
>

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 27 Oct 2014 14:44:15 -0400

Tom,

I am giving an update on the BFD YANG model in the BFD WG. I can give a quick update (~1-2min) in NETMOD if such an update is desired.

Mahesh Jethanandani
[email-masked]

> On Oct 23, 2014, at 1:43 PM, "Thomas D. Nadeau" <[email-masked]> wrote:
> 
>

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 27 Oct 2014 15:14:35 -0400

ack

> On Oct 27, 2014:2:44 PM, at 2:44 PM, Mahesh Jethanandani <[email-masked]> wrote:
> 
> Tom,
> 
> [email-masked] <mailto:[email-masked]>
> 
> On Oct 23, 2014, at 1:43 PM, "Thomas D. Nadeau" <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> 
>>> On Oct 23, 2014:12:13 PM, at 12:13 PM, Ladislav Lhotka <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> Hi,
>>> 
>>> On 23 Oct 2014, at 18:02, Andy Bierman <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>>> 
>>>> 
>>>> On Tue, Oct 21, 2014 at 2:34 PM, Thomas D. Nadeau <[email-masked] <mailto:[email-masked]>> wrote:
>>>> 
>>>> http://www.ietf.org/id/draft-bierman-netmod-yang-conformance-04.txt <http://www.ietf.org/id/draft-bierman-netmod-yang-conformance-04.txt>
>>>>