Subject: Re: [netmod] issue Y56 UTF8 non-characters

From: Randy Presuhn <[email-masked]>
Date: Tue, 28 Oct 2014 17:14:12 -0700 (GMT-07:00)

Hi -

>From: Martin Bjorklund <[email-masked]>
>Sent: Oct 28, 2014 2:21 PM
>To: [email-masked]
>Cc: [email-masked], [email-masked]
>Subject: Re: [netmod] issue Y56 UTF8 non-characters
...
>What problem is solved by doing normalization of a YANG module?
>
>(I can think of a few, but they don't seem very realistic, e.g. this
>would be legal but confusing:
>
>  leaf swedish-fish {
>    type enumeration {
>      ...
>      enum ÅL;
>      enum ÅL;
>      ...
>    }
>  }
>)

In addition to ÅL, there's a third "spelling" for ÅL.

It gets *much* worse in Vietnamese.  A common word like "đường" ("street")
can literally be "spelled" 20 different ways in Unicode, depending on one's
choice of precomposed and "combining" options.  The situation is similarly
painful in Korean.

My concern is mostly for operators using text-based tools and printed
documentation.  When typing in a request, how much does "spelling"
matter?  How does an operator know whether to type "ÅL" or "ÅL",
or which way to "spell" "đường"?

But it's also a question for module writers.  Do they have to "spell"
their labels consistently in those cases where there are references to
them from within or between modules?

Randy

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 29 Oct 2014 08:15:41 +0100 (CET)

> or which way to "spell" "đường"?

But isn't this a bigger problem for instance data, i.e., strings?

> them from within or between modules?

If it comes down to this, I think I can live with this.

/martin