Subject: Re: [netmod] Some comments about ACL YANG model.

From: "Dana Blair (dblair)" <[email-masked]>
Date: Mon, 20 Oct 2014 13:09:10 +0000

The draft authors met and here is the response.  Look for DLB:
The comments mention compilable option which means the proposal compiles with pyang --ietf option.

Hi,

I am reviewing the ACL YANG model. And I got some doubts, maybe somebody can help me to understand it.

1.      There is one field: targets. In my understanding, maybe it is used to record who reference this ACL. I don’t know if Is it mandatory or not. Or my understanding is wrong.

DLB:  Your understand is correct.  It’s not mandatory.   To move beyond just using string, we need a compilable augmentation.  Since ACLs can be
applied to interfaces, that might be a good place to start.

2.      In packet-fields module, It looks the current definition is not so sufficient. For example, no "!=" definition, and no mask in acl-ipv4-header-fields group, etc…..

DLB:  no “not” definition.   This is a good catch.  Feel free to propose an augmentation or change to the existing model.

3.      In this draft, there is acl-type and ace-type. It looks the IP packet match and Ethernet packet match can be configured together. But it looks only "OR" relationship is at there, no "AND" relationship.

DLB:     What kind of “AND” relationship are you expecting ?

thanks,

Dana Blair

Thanks
Yangang

---

From: Yangang <[email-masked]>
Date: Tue, 21 Oct 2014 11:03:41 +0000

Hi,

Yangang: OK, I will do it, I try to provide data as soon as possible.

DLB:     What kind of “AND” relationship are you expecting ?
Yangang: I remember we got one requirement from the end user: They want the ACL to check the L2 MAC address and L3 IP address together. At this time, the relationship of RULEs is “AND”, not “OR”.

Thanks
Yangang.

发件人: Dana Blair (dblair) [mailto:[email-masked]]
发送时间: 2014年10月20日 21:09
收件人: Yangang
抄送: Dana Blair (dblair); Lisa Huang (yihuan); Dean Bogdanovic; Kiran Agrahara Sreenivasa; Benoit Claise (bclaise); [email-masked]
主题: RE: Some comments about ACL YANG model.

Hi,

thanks,

Dana Blair

Thanks
Yangang

---

From: "Dana Blair (dblair)" <[email-masked]>
Date: Tue, 21 Oct 2014 14:03:00 +0000

From: Yangang <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, October 21, 2014 at 7:03 AM
To: Cisco Employee <[email-masked]<mailto:[email-masked]>>
Cc: "Lisa Huang (yihuan)" <[email-masked]<mailto:[email-masked]>>, Dean Bogdanovic <[email-masked]<mailto:[email-masked]>>, Kiran Agrahara Sreenivasa <[email-masked]<mailto:[email-masked]>>, "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: 答复: Some comments about ACL YANG model.

Hi,

Great.

So do they want to do this:
match ((IP address == 1.1.1.1) AND (MAC address == 0xABCDEF)) permit

or this:

match ((IP address == 1.1.1.1) OR (MAC address == 0xABCDEF)) permit

or something else ?

thanks,
Dana

Thanks
Yangang.

发件人: Dana Blair (dblair) [mailto:[email-masked]]
发送时间: 2014年10月20日 21:09
收件人: Yangang
抄送: Dana Blair (dblair); Lisa Huang (yihuan); Dean Bogdanovic; Kiran Agrahara Sreenivasa; Benoit Claise (bclaise); [email-masked]<mailto:[email-masked]>
主题: RE: Some comments about ACL YANG model.

Hi,

thanks,

Dana Blair

Thanks
Yangang

---

From: Yangang <[email-masked]>
Date: Tue, 21 Oct 2014 15:36:57 +0000

About the NO.3, it is just like you said.

Yangang.

________________________________
发件人: Dana Blair (dblair) [[email-masked]]
发送时间: 2014年10月21日 22:03
收件人: Yangang
抄送: Lisa Huang (yihuan); Dean Bogdanovic; Kiran Agrahara Sreenivasa; Benoit Claise (bclaise); [email-masked]
主题: Re: 答复: Some comments about ACL YANG model.

Hi,

Great.

or this:

or something else ?

thanks,
Dana

Thanks
Yangang.

Hi,

thanks,

Dana Blair

Thanks
Yangang

---

From: "Dana Blair (dblair)" <[email-masked]>
Date: Tue, 21 Oct 2014 18:16:24 +0000

From: Yangang <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, October 21, 2014 at 11:36 AM
To: Cisco Employee <[email-masked]<mailto:[email-masked]>>
Cc: "Lisa Huang (yihuan)" <[email-masked]<mailto:[email-masked]>>, Dean Bogdanovic <[email-masked]<mailto:[email-masked]>>, Kiran Agrahara Sreenivasa <[email-masked]<mailto:[email-masked]>>, "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: 答复: 答复: Some comments about ACL YANG model.

You can construct both the OR and the AND example using the existing model/draft.

Dana

Yangang.

________________________________
发件人: Dana Blair (dblair) [[email-masked]<mailto:[email-masked]>]
发送时间: 2014年10月21日 22:03
收件人: Yangang
抄送: Lisa Huang (yihuan); Dean Bogdanovic; Kiran Agrahara Sreenivasa; Benoit Claise (bclaise); [email-masked]<mailto:[email-masked]>
主题: Re: 答复: Some comments about ACL YANG model.

Hi,

Great.

or this:

or something else ?

thanks,
Dana

Thanks
Yangang.

Hi,

thanks,

Dana Blair

Thanks
Yangang

---

From: Yangang <[email-masked]>
Date: Fri, 24 Oct 2014 11:11:21 +0000

Hi,

I update the model.  Please check attached file, I mark my modification with red color.

About the third issues, I can’t find a method to represent the “Boolean algebra” in a short time after I discuss somebody is at here. In order to make sure new draft can be delivered on time, I just define a simple method. Please check it.

Thanks
Yangang.

Hi,

Great.

or this:

or something else ?

thanks,
Dana

Thanks
Yangang.

Hi,

thanks,

Dana Blair

Thanks
Yangang

---

From: "Dana Blair (dblair)" <[email-masked]>
Date: Fri, 31 Oct 2014 02:39:18 +0000

Date: Friday, October 24, 2014 at 7:11 AM

Hi,

Thanks for the contribution.  The authors normally meet every couple weeks to discuss contributions and other things that come up.
our next discussion will be at the IETF.  Are ypu planning on attending ?  Can we discuss this there ?

thanks,
Dana

Thanks
Yangang.

Hi,

Great.

or this:

or something else ?

thanks,
Dana

Thanks
Yangang.

Hi,

thanks,

Dana Blair

Thanks
Yangang

---

From: Yangang <[email-masked]>
Date: Fri, 31 Oct 2014 03:28:48 +0000

Hi, Dana:

I am glad to attend your meeting. And I will arrive at there Nov 8 afternoon.

Thanks
Yangang.

发件人: Dana Blair (dblair) [mailto:[email-masked]]
发送时间: 2014年10月31日 10:39
收件人: Yangang
抄送: Lisa Huang (yihuan); Dean Bogdanovic; Kiran Agrahara Sreenivasa; Benoit Claise (bclaise); [email-masked]
主题: Re: 答复: 答复: Some comments about ACL YANG model.

Hi,

thanks,
Dana

Thanks
Yangang.

Hi,

Great.

or this:

or something else ?

thanks,
Dana

Thanks
Yangang.

Hi,

thanks,

Dana Blair

Thanks
Yangang