Subject: [netmod] Questions to draft-ietf-netmod-acl-model-00

From: Linda Dunbar <[email-masked]>
Date: Fri, 9 Jan 2015 22:58:43 +0000

Dean, et al,

On Page 15, the definition of "metadata" missed potential matching criteria of "packet length", which is described in the "metadata" definition.
Is it possible to add more constraints, such as "apply ACL when there is congestion", etc?

On Page 12, the "acl-transport-header-fields" only allows port range. If the matching criteria is a specific port number, is it still necessary to have both "lower-port" and "upper-port" specified?

On Figure 2 (Page 18), the "<actions/>"  below "<deny/>" should really be "</action>", isn't it?

Thanks, Linda Dunbar

---

From: Dean Bogdanovic <[email-masked]>
Date: Tue, 13 Jan 2015 16:20:35 +0000

Linda, please see inline
On Jan 9, 2015, at 5:58 PM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:

Dean, et al,

On Page 15, the definition of “metadata” missed potential matching criteria of “packet length”, which is described in the “metadata” definition.
Is it possible to add more constraints, such as “apply ACL when there is congestion”, etc?

What is currently in the draft, is just an example how to extend the model, so what you are proposing is allowed, but we, authors, believe that  the current examples give the way to to add standard and proprietary extensions to the model. We are trying to keep the basic ACL model as simple as possible, where extensions would go into other drafts.

On Page 12, the “acl-transport-header-fields” only allows port range. If the matching criteria is a specific port number, is it still necessary to have both “lower-port” and “upper-port” specified?

If it is just specific port number, you specify only lower-port (as this is mandatory), upper port doesn't have to be specified.

On Figure 2 (Page 18), the “<actions/>”  below “<deny/>” should really be “</action>”, isn’t it?
Thank you for the catch. It is a typo.

Dean

Thanks, Linda Dunbar