Subject: Re: [netmod] Y45 again

From: Randy Presuhn <[email-masked]>
Date: Thu, 2 Apr 2015 10:06:58 -0700 (GMT-07:00)

Hi -

>From: Andy Bierman <[email-masked]>
>Sent: Apr 2, 2015 10:01 AM
>To: Randy Presuhn <[email-masked]>
>Cc: "[email-masked]" <[email-masked]>
>Subject: Re: [netmod] Y45 again
>
>On Thu, Apr 2, 2015 at 9:17 AM, Randy Presuhn
><[email-masked]> wrote:
>> Hi -
>>
>>>From: Andy Bierman <[email-masked]>
>>>Sent: Mar 31, 2015 7:14 AM
>>>To: Juergen Schoenwaelder <[email-masked]>, Martin Bjorklund <[email-masked]>, Andy Bierman <[email-masked]>, Ladislav Lhotka <[email-masked]>, "[email-masked]" <[email-masked]>
>>>Subject: Re: [netmod] Y45 again
>> ...
>>>Extending typedefs and groupings actually works, and implementing
>>>only 1 revision actually works, but only if the server implements
>>>the advertised definitions consistently.
>>
>> How do you envision this approach working with a system
>> containing, for example, a mix of old and new line cards,
>> or managed applications from multiple vendors, where
>> the underlying resources corresponing to some usages of
>> a typedef only support the value set defined by the old
>> definition, while other instances support the full range
>> defined by the newer one?
>>
>
>It would not work -- but nothing being proposed actually solves this problem.
>You cannot have line card 1 implement one revision of a module
>and line card 2 implement a different version.  SNMP
>does not support that. NETCONF/RESTCONF do not support that.

Actually, it works just fine with SNMP, due to the SMI
versioning rules.  This is an example of a case where
subagent technology is particularly helpful.

Randy

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 02 Apr 2015 20:43:37 +0200 (CEST)

> subagent technology is particularly helpful.

Right.  But it also means that a SNMP manager has no idea what values
an SNMP agent supports for a particular instance of a particular object
(well it has *some* idea).  The only reason we are having such
problems with Y45 is that we have created a requirement on ourselves
that a client should be able to determine what the server supports
from what it advertises.

/martin