Subject: Re: [netmod] Y45 again

From: Randy Presuhn <[email-masked]>
Date: Thu, 2 Apr 2015 09:17:01 -0700 (GMT-07:00)

Hi -

>From: Andy Bierman <[email-masked]>
>Sent: Mar 31, 2015 7:14 AM
>To: Juergen Schoenwaelder <[email-masked]>, Martin Bjorklund <[email-masked]>, Andy Bierman <[email-masked]>, Ladislav Lhotka <[email-masked]>, "[email-masked]" <[email-masked]>
>Subject: Re: [netmod] Y45 again
...
>Extending typedefs and groupings actually works, and implementing
>only 1 revision actually works, but only if the server implements
>the advertised definitions consistently.

How do you envision this approach working with a system
containing, for example, a mix of old and new line cards,
or managed applications from multiple vendors, where
the underlying resources corresponing to some usages of
a typedef only support the value set defined by the old
definition, while other instances support the full range
defined by the newer one?

Randy

---

From: Andy Bierman <[email-masked]>
Date: Thu, 2 Apr 2015 10:01:02 -0700

> defined by the newer one?

It would not work -- but nothing being proposed actually solves this problem.
You cannot have line card 1 implement one revision of a module
and line card 2 implement a different version.  SNMP
does not support that. NETCONF/RESTCONF do not support that.

> Randy

Andy

>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod