Subject: [netmod] Is there any common module (like library module) for matching all IPv4 or IPv6 header fields?

From: Linda Dunbar <[email-masked]>
Date: Fri, 6 May 2016 03:48:32 +0000

Dear YANG Model experts:

Draft-ietf-netmod-acl-model-07 has matching criteria for Destination Address and Source for IPv4 and IPv6 respectively, like:

IDR FlowSpec also has  defined YANG model for matching criteria for IPv6/ IPv4-prefix plus other header fields. I2RS Filter Based RIB also define various header matching.

Is there a common library module that can be called when any IP header fields need to be used as matching criteria?

Thanks, Linda Dunbar

---

From: Dean Bogdanovic <[email-masked]>
Date: Tue, 10 May 2016 10:17:03 -0400

Linda,

If you need additional fields in ACL, it is easy to extend the existing base model. The intention of the draft authors was to create base common model that can be then extended for different uses. 

Saying that, there is nothing out there that could be used for your purposes, but using the ACL model, you should be able to augment it for your use case.

Dean

> On May 5, 2016, at 11:48 PM, Linda Dunbar <[email-masked]> wrote:
> 
> Dear YANG Model experts: 
>