Subject: Re: [netmod] yang model classification

From: Dean Bogdanovic <[email-masked]>
Date: Tue, 24 May 2016 11:07:14 -0400

Joel,

> On Apr 24, 2016, at 9:31 PM, Joel M. Halpern <[email-masked]> wrote:
> 
> What is the relationship between this taxonomy and the many models that do not fit its cateogrization?
> 
> Three examples:
> Models used in ODL to generate results which may be neither network services nor network elements.  They may be in between, or in some other dimension?

When you say generate results, those models generate results based on what? Can you give some examples?

> 
> Also, models used to describe things in other aspects of environments, such as Policy models?

Policy will describe an action on device or on a network service, as in general policy is defined as a set of match condition(s) followed by an action. I would even say that most policies are for network service models.
> 
> And models of things which are not conventional network elements, such as models of compute platforms, models of applications, even models of control systems.

We haven’t created device as generic network element, but with networking in mind. You can view it as generic. Device should always provide what it is capable of and it is a superset into which all other models must fit.

Dean

> 
> Yours,
> Joel
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 24 May 2016 11:09:18 -0400

I had real trouble mapping the taxonomy to the models I am familair with.

ODL uses YANG models to define the persistent data and interface APIs to 
any and all of its internal services.  These include controlling 
anything and everything the controller does.  But the results of the 
YANG operations are operations internal to ODL, although many result 
after processing in actions applied to the network.

Yours,
Joel

---

From: Dean Bogdanovic <[email-masked]>
Date: Tue, 24 May 2016 11:42:50 -0400

WG, 

Joel and I had an offline discussion and in order to make it more clear, a text clarification should be added to the document in which is stated that this document proposes initial elements for a taxonomy, rather than an initial taxonomy.

Dean

> On May 24, 2016, at 11:09 AM, Joel M. Halpern <[email-masked]> wrote:
> 
> ODL uses YANG models to define the persistent data and interface APIs to any and all of its internal services.  These include controlling anything and everything the controller does.  But the results of the YANG operations are operations internal to ODL, although many result after processing in actions applied to the network.
> 
> Yours,
> Joel
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 24 May 2016 11:47:36 -0400

Thank you very much Dean.
Yours,
Joel