Subject: [netmod] I-D Action: draft-ietf-netmod-yang-model-classification-04.txt

From: [email-masked]
Date: Wed, 26 Oct 2016 17:22:40 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the NETCONF Data Modeling Language of the IETF.

        Title           : YANG Module Classification
        Authors         : Dean Bogdanovic
                          Benoit Claise
                          Carl Moberg
	Filename        : draft-ietf-netmod-yang-model-classification-04.txt
	Pages           : 11
	Date            : 2016-10-26

Abstract:
   The YANG [RFC6020] data modeling language is currently being
   considered for a wide variety of applications throughout the
   networking industry at large.  Many standards-defining organizations
   (SDOs), open source software projects, vendors and users are using
   YANG to develop and publish YANG modules for a wide variety of
   applications.  At the same time, there is currently no well-known
   terminology to categorize various types of YANG modules.

   A consistent terminology would help with the categorization of YANG
   modules, assist in the analysis of the YANG data modeling efforts in
   the IETF and other organizations, and bring clarity to the YANG-
   related discussions between the different groups.

   This document describes a set of concepts and associated terms to
   support consistent classification of YANG modules.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netmod-yang-model-classification/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-netmod-yang-model-classification-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-yang-model-classification-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Dean Bogdanovic <[email-masked]>
Date: Wed, 26 Oct 2016 20:31:22 -0400

We have submitted new version of the draft. In authors view this draft describes a set of concepts and associated terms to support consistent classification of YANG modules. It should provide guidelines to other document authors in the IETF and other places to decide how to use encode information from this draft. Hence encoding suggestion in section 4, adding classification type to YANG module catalogs, has been removed.

Chairs,

Please make WGLC on this document.

Cheers,

Dean

> On Oct 26, 2016, at 8:22 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod