Subject: [netmod] Corrections needed in the draft-ietf-netmod-entity-00

From: "Carey, Timothy (Nokia - US)" <[email-masked]>
Date: Thu, 6 Oct 2016 13:38:52 +0000

Hello,

The BBF plans to use the Entity module as one of our common YANG modules within the BBF.
The current draft of the module has some errors that we feel need corrected.

Specifically there is a circular reference for the identity entity-physical-class; we feel that this should be moved to the iana-entity-module.

What does the group think?

BR,
Tim

---

From: Alex Campbell <[email-masked]>
Date: Thu, 6 Oct 2016 22:40:38 +0000

Hi,

If you are referring to the circular reference in the expresssion 'derived-from-or-self(../class, "iana-entity", "sensor")', I would rather see sensor-data separated into another module than see  entity-physical-class moved to iana-entity.

This would be more consistent with the RFC 7223 interface model, where interface-type-specific modules augment the basic generic interface module with interface-type-specific data.

It also leaves open the possibility of a server not supporting iana-entity if it doesn't need any of the standard entity types.

Alex

________________________________
From: netmod <[email-masked]> on behalf of Carey, Timothy (Nokia - US) <[email-masked]>
Sent: Friday, 7 October 2016 2:38 a.m.
To: [email-masked]
Subject: [netmod] Corrections needed in the draft-ietf-netmod-entity-00

Hello,

BR,
Tim

---

From: "Carey, Timothy (Nokia - US)" <[email-masked]>
Date: Fri, 7 Oct 2016 10:44:23 +0000

Alex,

Yes - but the problem is more than sensors or whatever entities the entity module provides support.
The problem is an import/reference structural problem with respect to the IANA entity (imports IETF entity) and IETF entity imports the IANA entity.
We think the proper, future proof method is to move the entities to the IANA entity and have the IETF entity import that module.
It's a simple future proof fix that doesn't change the actual model behavior.
We don't think importing the IANA entity is a problem for servers to support.

BR,
Tim

From: Alex Campbell [mailto:[email-masked]]
Sent: Thursday, October 06, 2016 5:41 PM
To: Carey, Timothy (Nokia - US) <[email-masked]>
Cc: [email-masked]
Subject: Re: Corrections needed in the draft-ietf-netmod-entity-00

Hi,

Alex

________________________________
From: netmod <[email-masked]<mailto:[email-masked]>> on behalf of Carey, Timothy (Nokia - US) <[email-masked]<mailto:[email-masked]>>
Sent: Friday, 7 October 2016 2:38 a.m.
To: [email-masked]<mailto:[email-masked]>
Subject: [netmod] Corrections needed in the draft-ietf-netmod-entity-00

Hello,

BR,
Tim