Subject: [Notifications] Use cases

From: <[email-masked]>
Date: Fri, 27 Jul 2007 19:25:42 +0300

Hello everyone,
is there some sort of use case template available that we should use, or is it freestyle?
Thank You.

Best regards: Zoltán Ördögh
E-mail: zoltan dot ordogh at nokia dot com
Phone: +358 50 386 0566

_______________________________________________
Notifications mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/notifications

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 27 Jul 2007 20:20:00 +0100

> is there some sort of use case template available that we should use, 
I think it is freestyle.

---

From: <[email-masked]>
Date: Fri, 27 Jul 2007 22:03:34 +0300

Good luck to whoever volunteered to consolidate them :-)

>-----Original Message-----
>From: ext Alexey Melnikov [mailto:[email-masked]] 
>Sent: 27 July, 2007 22:20
>To: Ordogh Zoltan (Nokia-TP-MSW/Tampere)
>Cc: [email-masked]
>Subject: Re: [Notifications] Use cases
>
>> is there some sort of use case template available that we 
>should use, 
>> or is it freestyle?
>>
>I think it is freestyle.
>
>

---

From: Dave Crocker <[email-masked]>
Date: Fri, 27 Jul 2007 14:06:41 -0500

>> is there some sort of use case template available that we should use, 

Yeah, but as long as the question got asked, here are the kinds of things I 
try to answer with a use case:

Scenario:

    What is it that someone wants to do, that they cannot current do.  This is 
a non-technical, user-level description.  Probably no acronyms and certainly 
no implementation choices.  (User-level can refer to end-users, sysadmin, or 
anyone else that is the consumer of the service.)

Problem:

    What prevents using existing tools for accomplishing this?

Market:

    Who needs this and should we believe they need it immediately?

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: <[email-masked]>
Date: Fri, 27 Jul 2007 22:58:29 +0300

Oh, so it would be good to agree beforehand because I had completely different ideas.
Like:

Scenario
Joe wants to turn on his coffee machine in the morning so that when he wakes up, the coffee is already waiting...

Actors:
IMAP Server, Notification Server, Client (Joe's coffee machine), Joe

Pre-conditions
1. Joe goes to sleep but before doing so, He schedules a future mail delivery for Himself, 0600 in the morning (subject: coffee "1 big decaf +milk"; no body).
2. Client (Joe' coffee machine) is subscribed to Joe's mail events, particularly to the an event when an email arrives from Himself.
3. Client is configured to ingore all other mails that those from Joe with "coffee" in the subject line, and the hardware configuraton is satisfactory (has coffee, electricity, water, cups, etc).
4. The Notification Server supports sender and subject fields.
5. IMAP Server has AfterBLAST support.

Flow:
1. Future delivery is triggered at 0600 in the morning, therefore a new mail arrive to Joe from Himself.
2. IMAP Server BLASTs some info to the Notification Server.
3. Notification Server informs the Client.
4. Client validates conditions and prepares Joe's coffee, as instructed by the subject field -> a big decaf coffee with milk.
5. As instructed by Joe's SIEVE script (that is triggered AfterBLAST), the unnecessary email is removed from the mailbox after the information was BLASTED to the Notification Server.

Alternate flow:
 - two coffees, one for the wife as well, using the same Client - using the same event.
 - two coffees, one for the wife as well, using the same Client - using different events.

Expected results:
 - the coffee conforms to the requested parameters.
 - Joe is a happy IMAPCoffee customer enjoying the benefits of his well-spent investment.

>From: ext Dave Crocker [mailto:[email-masked]] 
>Sent: 27 July, 2007 22:07
>Yeah, but as long as the question got asked, here are the 
>kinds of things I try to answer with a use case:
>
>
>Scenario:
>

---

From: "Rohan Mahy" <[email-masked]>
Date: Mon, 30 Jul 2007 10:19:57 -0700

Scenario:
A widget on my cell phone that correlates all package tracking emails
from Federal Express.  It is interested in the Subject and To header
of all emails sent From tracker.fedex.com. When it gets a new
notification, it parses the tracking number from the Subject and does
an HTTP fetch to get the current status of the package. It can then
beep or chime or prompt you to send an email or a phone call or SMS
when various things happen (package picked up, package delivered,
package delayed, package cleared customs).

This model would apply nicely to other widgets for package tracking,
flight status, sales order notifications, and stock trade
confirmations.

Problem:
The cell phone does not want to poll for new messages (for example
using IMAP) because this would negatively affect battery life.  Better
to use an existing open TCP connection already used by SIP or XMPP to
receive these async notifications.

Also, the phone is only interested in a filtered view of
notifications.  There are ways of doing this today in email, but just
forwarding all your email to an IM gateway using a static filter isn't
sufficient.   If the phone has multiple widgets, these filters my need
to be somewhat dynamic.

Market:
Widgets like this are popping up left and right, but they use HTTP
polling.  The market would like these apps and decent battery
consumption too.

thanks,
-rohan