Subject: [Notifications] Use case--reply mail notification

From: Qian Sun <[email-masked]>
Date: Thu, 23 Aug 2007 11:35:52 +0800

Hi, all

Scenario: Bob is sending a email to Alice. Bob wants to get a instant notification via SMS something if Alice replies, since he is eager to know the reply of Alice. He is not interested in other emails. When Bob's mailbox in the email server recieves a new email, and find out it is a reply from Alice for that mail, a notification of SMS,like "You have got a reply mail from Alice", will be sent to Bob's cellphone.

Problem: For the email sending part, I prefer to realize this requirement by using a SMTP extension, e.g. define a new parameter for MAIL command, which includes the SMS URI or IM URI. (To Webmail, we need not to do any standard.)
For the notification part, pager mode message may be better; SUB/NOT event mechanism is not necessary. For example, SIP MESSAGE could be a good choice, if the users only want to get few notifications.

Market: It might be an attractive feature to enhance the existing email service.

Opinion?

Cheers,
Qian

_______________________________________________
Notifications mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/notifications

---

From: Eric Burger <[email-masked]>
Date: Fri, 24 Aug 2007 21:03:13 -0400

Why not use MDN and a sieve filter?  Sounds like major surgery to do what
people do every day with today's tools.

On 8/22/07 11:35 PM, "Qian Sun" <[email-masked]> wrote:

> Hi, all
> 
> Scenario: Bob is sending a email to Alice. Bob wants to get a instant
> notification via SMS something if Alice replies, since he is eager to know the
> reply of Alice. He is not interested in other emails. When Bob's mailbox in
> the email server recieves a new email, and find out it is a reply from Alice
> for that mail, a notification of SMS,like "You have got a reply mail from
> Alice", will be sent to Bob's cellphone.
> 
> Problem: For the email sending part, I prefer to realize this requirement by
> using a SMTP extension, e.g. define a new parameter for MAIL command, which
> includes the SMS URI or IM URI. (To Webmail, we need not to do any standard.)
> For the notification part, pager mode message may be better; SUB/NOT event
> mechanism is not necessary. For example, SIP MESSAGE could be a good choice,
> if the users only want to get few notifications.
> 

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

---

From: Qian Sun <[email-masked]>
Date: Mon, 27 Aug 2007 19:53:53 +0800

Hello, Eric

Any document defines a "reply" disposition type? And some people might prohibit MDN.

Do you want to set a sieve script like this?

    if header :contains "In-Reply-To" "[email-masked]" {
        notify :message "You got reply mail" "sms: +10231223";

If not, could you explain your solution in more details?

Cheers,
Qian

---

From: "Eric Burger" <[email-masked]>
Date: Tue, 28 Aug 2007 10:59:50 -0700

In the "do it today", the execution step runs an external shell script,
but yes, this is the basic flow.

Remember, that to protect the privacy interests of the recipient, just
as they can prohibit MDN, they can prohibit "automatic SMS
notification." 

-----Original Message-----
From: Qian Sun [mailto:[email-masked]] 
Sent: Monday, August 27, 2007 7:54 AM
To: Eric Burger
Cc: [email-masked]
Subject: RE: [Notifications] Use case--reply mail notification

Hello, Eric

Any document defines a "reply" disposition type? And some people might
prohibit MDN.

Cheers,
Qian

-----Original Message-----
From: Eric Burger [mailto:[email-masked]]
Sent: Saturday, August 25, 2007 9:03 AM
To: Qian Sun; [email-masked]
Subject: Re: [Notifications] Use case--reply mail notification

Why not use MDN and a sieve filter?  Sounds like major surgery to do
what people do every day with today's tools.

On 8/22/07 11:35 PM, "Qian Sun" <[email-masked]> wrote:

> notification via SMS something if Alice replies, since he is eager to 
> know the reply of Alice. He is not interested in other emails. When 
> Bob's mailbox in the email server recieves a new email, and find out 
> it is a reply from Alice for that mail, a notification of SMS,like 
> "You have got a reply mail from Alice", will be sent to Bob's
cellphone.
> 
> Problem: For the email sending part, I prefer to realize this 
> requirement by using a SMTP extension, e.g. define a new parameter for

> MAIL command, which includes the SMS URI or IM URI. (To Webmail, we 
> need not to do any standard.) For the notification part, pager mode 
> message may be better; SUB/NOT event mechanism is not necessary. For 
> example, SIP MESSAGE could be a good choice, if the users only want to
get few notifications.
> Market: It might be an attractive feature to enhance the existing 

Notice:  This email message, together with any attachments, may contain
information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated
entities,  that may be confidential,  proprietary,  copyrighted  and/or
legally privileged, and is intended solely for the use of the individual
or entity named in this message. If you are not the intended recipient,
and have received this message in error, please immediately return this
by email and then delete it.

---

From: Qian Sun <[email-masked]>
Date: Wed, 29 Aug 2007 11:40:01 +0800

Hello Eric
I don't think so. A recipient can not prohibit things in sender's mail server. And the sender's mail server has no reason to prohibit the sender to know what stuff is in the sender's mailbox.

In detail:
When a reply email arrives at sender's mail server, the server may check if the in-reply-to or references header field of this reply email contains the recorded message-id value of original email. If YES, then the sender's server can send an automatic SMS notification to the sender. The recipient can prohibit MDN in his email client, but how can the recipient prohibit this "automatic SMS notification"?

Cheers,
Qian

-----Original Message-----
From: Qian Sun [mailto:[email-masked]] 
Sent: Monday, August 27, 2007 7:54 AM
To: Eric Burger
Cc: [email-masked]
Subject: RE: [Notifications] Use case--reply mail notification

Hello, Eric

Cheers,
Qian

-----Original Message-----
From: Eric Burger [mailto:[email-masked]]
Sent: Saturday, August 25, 2007 9:03 AM
To: Qian Sun; [email-masked]
Subject: Re: [Notifications] Use case--reply mail notification

cellphone.

get few notifications.