Subject: Re: [Notifications] Use cases

From: Cullen Jennings <[email-masked]>
Date: Mon, 13 Aug 2007 15:38:11 -0700

It seems like this use case was pretty much outside the email  
notifications scope we were trying to do for first version. Is this  
is the you have have to have it , or the could wait till later category?

On Jul 30, 2007, at 10:19 AM, Rohan Mahy wrote:

> Scenario:
> A widget on my cell phone that correlates all package tracking emails
> from Federal Express.  It is interested in the Subject and To header
> of all emails sent From tracker.fedex.com. When it gets a new
> notification, it parses the tracking number from the Subject and does
> an HTTP fetch to get the current status of the package. It can then
> beep or chime or prompt you to send an email or a phone call or SMS
> when various things happen (package picked up, package delivered,
> package delayed, package cleared customs).
>
> This model would apply nicely to other widgets for package tracking,
> flight status, sales order notifications, and stock trade
> confirmations.
>
> Problem:
> The cell phone does not want to poll for new messages (for example
> using IMAP) because this would negatively affect battery life.  Better
> to use an existing open TCP connection already used by SIP or XMPP to
> receive these async notifications.
>
> Also, the phone is only interested in a filtered view of
> notifications.  There are ways of doing this today in email, but just
> forwarding all your email to an IM gateway using a static filter isn't
> sufficient.   If the phone has multiple widgets, these filters my need
> to be somewhat dynamic.
>
> Market:
> Widgets like this are popping up left and right, but they use HTTP
> polling.  The market would like these apps and decent battery
> consumption too.
>
> thanks,
> -rohan
>
>
> _______________________________________________
> Notifications mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/notifications

_______________________________________________
Notifications mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/notifications

---

From: Leif Johansson <[email-masked]>
Date: Tue, 14 Aug 2007 12:02:47 +0200

Cullen Jennings wrote:
> notifications scope we were trying to do for first version. Is this is
> the you have have to have it , or the could wait till later category?
>
Why? It sounds to me like a (relatively) straightforward
combination of sieve and some notification mechanism
running over the existing IM/Presence framework on
the phone.

Imo it nicely illustrates the need for multiple transports
and why existing implementations of pubsub will be a
natural point of integration.

    Cheers Leif

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 14 Aug 2007 10:13:20 -0700

> natural point of integration.

Ok - fair enough. However, if we start dealing with use case outside  
of mail stores, I probably have over 100. I just failed to see how  
this one involved a mail store.

---

From: Leif Johansson <[email-masked]>
Date: Tue, 14 Aug 2007 23:12:33 +0200

> this one involved a mail store.
Isn't the the mailstore typically where sieve runs?

    Cheers Leif

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 14 Aug 2007 17:52:20 -0700

> Isn't the the mailstore typically where sieve runs?

yes - you are right