Subject: Re: [OAUTH-WG] draft-ietf-oauth-v2-bearer-09: Open Issues & Proposed Resolutions

From: Eran Hammer <[email-masked]>
Date: Mon, 16 Jan 2012 11:46:02 -0700

Added:

  scope       = scope-token *( SP scope-token )
  scope-token = %x21 / %x23-5B / %x5D-7E

EHL

> -----Original Message-----
> From: Julian Reschke [mailto:[email-masked]]
> Sent: Tuesday, October 18, 2011 9:40 AM
> To: Eran Hammer-Lahav
> Cc: OAuth WG
> Subject: Re: [OAUTH-WG] draft-ietf-oauth-v2-bearer-09: Open Issues &
> Proposed Resolutions
> 
> On 2011-10-18 17:38, Eran Hammer-Lahav wrote:
> > Space is allowed inside a quoted string and is already not allowed inside
> each scope string.
> >
> > EHL
> > ...
> 
> a) yes.
> 
> b) well:
> 
>     The value of the scope parameter is expressed as a list of space-
>     delimited, case sensitive strings.  The strings are defined by the
>     authorization server.  If the value contains multiple space-delimited
>     strings, their order does not matter, and each string adds an
>     additional access range to the requested scope.
> 
> That certainly implies that you can't have a space inside a token, but it could
> be clearer.
> 
> Optimally, state the character repertoire precisely:
> 
>    scopetokenchar =  %x21 / %x23-5B / %x5D-7E
>    ; HTTPbis P1 qdtext except whitespace, restricted to US-ASCII
> 
> ?
> 
> Best regards, Julian

---

From: Eran Hammer <[email-masked]>
Date: Mon, 16 Jan 2012 11:47:00 -0700

Sorry:

  scope       = scope-token *( SP scope-token )
  scope-token = 1*( %x21 / %x23-5B / %x5D-7E )

EHL

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Eran Hammer
> Sent: Monday, January 16, 2012 10:46 AM
> To: Julian Reschke
> Cc: OAuth WG
> > That certainly implies that you can't have a space inside a token, but
> > it could be clearer.
> >
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth