Subject: [OAUTH-WG] Implementing MAC bearer

From: Erlend Hamnaberg <[email-masked]>
Date: Tue, 7 Feb 2012 20:02:12 +0100

Hi guys and gals.

I am trying to implement the MAC bearer within a client library.

Searching the Archive I find that the current draft version of the MAC
bearer is incorrect.

For instance the body-hash is no longer supported. Is there a new draft
planned soon?
For implementers there would be great help in more examples.
That way we can write test cases which conforms to the spec more easily.

Best regards

Erlend

---

From: William Mills <[email-masked]>
Date: Tue, 7 Feb 2012 11:27:56 -0800 (PST)

You're asking about MAC tokens right?  The term "bearer" on this list usually refers to the Bearer Token draft style stuff.  

________________________________
 From: Erlend Hamnaberg <[email-masked]>
To: [email-masked] 
Sent: Tuesday, February 7, 2012 11:02 AM
Subject: [OAUTH-WG] Implementing MAC bearer

Hi guys and gals.

Searching the Archive I find that the current draft version of the MAC bearer is incorrect.

For instance the body-hash is no longer supported. Is there a new draft planned soon?
For implementers there would be great help in more examples. 
That way we can write test cases which conforms to the spec more easily.

Best regards

Erlend
_______________________________________________
OAuth mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/oauth

---

From: Erlend Hamnaberg <[email-masked]>
Date: Wed, 8 Feb 2012 08:53:24 +0100

On Tue, Feb 7, 2012 at 8:27 PM, William Mills <[email-masked]> wrote:

> You're asking about MAC tokens right?  The term "bearer" on this list
> usually refers to the Bearer Token draft style stuff.
>
>
>
>   ------------------------------
> *From:* Erlend Hamnaberg <[email-masked]>
> *To:* [email-masked]
> *Sent:* Tuesday, February 7, 2012 11:02 AM
> *Subject:* [OAUTH-WG] Implementing MAC bearer
>
> Hi guys and gals.
>

Yes, of course.

Sorry for the confusion.

http://tools.ietf.org/html/draft-hammer-oauth-v2-mac-token-05

--
Erlend

---

From: Eran Hammer <[email-masked]>
Date: Wed, 8 Feb 2012 15:59:22 -0700

New draft:

http://tools.ietf.org/html/draft-ietf-oauth-v2-http-mac-01

EH

From: [email-masked] [mailto:[email-masked]] On Behalf Of Erlend Hamnaberg
Sent: Tuesday, February 07, 2012 11:02 AM
To: [email-masked]
Subject: [OAUTH-WG] Implementing MAC bearer

Hi guys and gals.

Best regards

Erlend

---

From: Erlend Hamnaberg <[email-masked]>
Date: Thu, 9 Feb 2012 09:11:30 +0100

Great. Thanks.

One question:
 Is it possible to use mac tokens in a non-OAuth setting?

How would a UA get the MAC id and algorithm then?

The old spec had a version where you could use Cookies to do this.

Is there a reason why this couldn't work as with Digest authentication?

-E

On Wed, Feb 8, 2012 at 11:59 PM, Eran Hammer <[email-masked]> wrote:

> New draft:****
>
> ** **
>
> http://tools.ietf.org/html/draft-ietf-oauth-v2-http-mac-01****
>
> ** **
>
> EH****
>
> ** **
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Erlend Hamnaberg
> *Sent:* Tuesday, February 07, 2012 11:02 AM
> *To:* [email-masked]
>
> *Subject:* [OAUTH-WG] Implementing MAC bearer****
>
> ** **
>
> Hi guys and gals.****
>
> ** **
>
> I am trying to implement the MAC bearer within a client library.****
>
> ** **
>
> bearer is incorrect.****
> ** **
> planned soon?****
> For implementers there would be great help in more examples. ****
>
> That way we can write test cases which conforms to the spec more easily.**
> **
>
> ** **
>
> Best regards****
>
> ** **
>
> Erlend****
>

---

From: William Mills <[email-masked]>
Date: Thu, 9 Feb 2012 02:46:45 -0800 (PST)

It's designed to be a form of HTTP auth independent of OAuth 2.0, however you get your credentials you can still use it.  OAuth 2.0 auth bindings are defined but not required.

________________________________
 From: Erlend Hamnaberg <[email-masked]>
To: Eran Hammer <[email-masked]> 
Cc: "[email-masked]" <[email-masked]> 
Sent: Thursday, February 9, 2012 12:11 AM
Subject: Re: [OAUTH-WG] Implementing MAC bearer

Great. Thanks.

One question:

-E

New draft:
>From:[email-masked] [mailto:[email-masked]] On Behalf Of Erlend Hamnaberg